Windows 10: Firefox will not work on this site, but Edge does. Solved

Page 2 of 2 FirstFirst 12
  1.    26 Feb 2017 #11

    Checking the bit version today and I discovered that I was on revision 39 of Firefox. I upgraded to 51 and the problem seems to have gone away.

    Thank you to everyone for their help and comments. I'm marking this thread as solved.
      My ComputerSystem Spec


  2. Posts : 6,478
    10 Home x64 (1709) (10 Pro on 2nd pc)
       26 Feb 2017 #12

    Mediocrites said: View Post
    Checking the bit version today and I discovered that I was on revision 39 of Firefox...
    That was seriously out of date. There have been countless security patches since then. You should check more often, you can set 'Check for updates, but let me choose whether to install them' in Options > Advanced > Update.
      My ComputersSystem Spec

  3.    26 Feb 2017 #13

    Part of that is not logging into Win 10 for a very long time. Now that I'm using it more, FF will be kept up to date.
      My ComputerSystem Spec


 
Page 2 of 2 FirstFirst 12

Related Threads
Hi guys, hope someone can fix this: Lenovo Thinkpad R500 - Touchpad scroll works in Internet Explorer, Firefox, File Explorer, Device manager, Help and some other places, but it does not work in Start menu or any menu under Control panel, Edge...
I sometimes get this sort of error in firefox and chrome But when I open the same URL in Edge it works - and after that it works in Firefox and Chrome. When it happens, it's invariably at the most inconvenient time - e.g. on a link someone...
IE11 is giving me problems and I don't like Edge. I want to download Firefox also to my computer as a 3rd alternative browser. I've been told to go to CNET website to safely do so. Is this the site you recommend to use to download a new Firefox...
My son's laptop has Windows 10 as its OS, the latest version of Firefox, no antivirus (just Windows Defender). When he tries to open Google, a message comes up that the site is insecure, and there is no possibility to add a certificate. Does anyone...
I have setup a Site-to-Site VPN using Sophos UTM at each end. I set up an Ubuntu VM as a WINS Server using Samba. So far so good. VPN Works. My problem is with the WINS Server. I have taken two Windows 10 computers and for both of them added...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:28.
Find Us