Page 1 of 2 12 LastLast
  1.    28 Jan 2017 #1
    Join Date : Aug 2016
    Posts : 3
    Windows 10

    What is wrong with my Edge?


    Microsoft Edge browser became really buggy all of a sudden. I've done a clean Windows install soon after that (WIn10 build 1607), but the problem is still there. I have tried resetting the browser only, but no success. GPU drivers are up to date (R9 380). It only happens in Edge, all other browsers are fine. When I made a new local account, there were no problems.

    Video upload (AK1G) - vidme

    This kind of a twitch happens every now and then and I have to restart the browser so I can use it normally. It happens in all kinds of situations, while browsing, being open in the background or being completely idle. The apps which are running simultaneously become unresponsive until I minimize/ maximize/ switch between them.

    Is there a way to fix this without making a new account?
      My ComputerSystem Spec
  2.    28 Jan 2017 #2
    Join Date : Jan 2017
    Posts : 18
    none

    in a nutshell it's a microsoft browser, that is what is wrong with it.
      My ComputerSystem Spec
  3.    28 Jan 2017 #3
    Join Date : Jul 2015
    Poole Dorset UK
    Posts : 2,559
    Windows 10 x64 Home Version(1709) Build16299.64

    Quote Originally Posted by MaxPad View Post
    in a nutshell it's a microsoft browser, that is what is wrong with it.
    Nothing wrong with Edge Browser been using it since day one, it is 99% better than IE as since installed have had no freezes etc
      My ComputerSystem Spec
  4.    28 Jan 2017 #4
    Join Date : Jul 2015
    Poole Dorset UK
    Posts : 2,559
    Windows 10 x64 Home Version(1709) Build16299.64

    Quote Originally Posted by jakov1 View Post
    Microsoft Edge browser became really buggy all of a sudden. I've done a clean Windows install soon after that (WIn10 build 1607), but the problem is still there. I have tried resetting the browser only, but no success. GPU drivers are up to date (R9 380). It only happens in Edge, all other browsers are fine. When I made a new local account, there were no problems.

    Video upload (AK1G) - vidme

    This kind of a twitch happens every now and then and I have to restart the browser so I can use it normally. It happens in all kinds of situations, while browsing, being open in the background or being completely idle. The apps which are running simultaneously become unresponsive until I minimize/ maximize/ switch between them.

    Is there a way to fix this without making a new account?
    Just a question do you have Java anywhere on your computer as that could or might cause your problem, or any other program you have installed.
    Also have you downloaded and installed the latest update
    Critical Update KB3211320 for Windows 10 Version 1607
    Last edited by hTconeM9user; 28 Jan 2017 at 08:16. Reason: Added link
      My ComputerSystem Spec
  5.    28 Jan 2017 #5
    Join Date : Sep 2015
    Posts : 32
    Windows 10

    Quote Originally Posted by hTconeM9user View Post
    Nothing wrong with Edge Browser been using it since day one, it is 99% better than IE as since installed have had no freezes etc

    That's only your experience and obviously doesn't mirror everyone's. In my experience, Edge is junk with constant freezes and crashes. Went back to Firefox and highly doubt I'll ever go back to Edge.
      My ComputerSystem Spec
  6.    28 Jan 2017 #6
    Join Date : Jul 2015
    Poole Dorset UK
    Posts : 2,559
    Windows 10 x64 Home Version(1709) Build16299.64

    Quote Originally Posted by JBGoode View Post
    That's only your experience and obviously doesn't mirror everyone's. In my experience, Edge is junk with constant freezes and crashes. Went back to Firefox and highly doubt I'll ever go back to Edge.
    I know that but Chrome, Firefox and IE all messed up my systems I look after including ones in my grand daughter shops Edge runs fast and keeps her business going
      My ComputerSystem Spec
  7.    28 Jan 2017 #7
    Join Date : Jan 2017
    Posts : 18
    none

    Quote Originally Posted by hTconeM9user View Post
    Nothing wrong with Edge Browser been using it since day one, it is 99% better than IE as since installed have had no freezes etc
    you can stop stocking / trolling me.
      My ComputerSystem Spec
  8.    28 Jan 2017 #8
    Join Date : Jan 2017
    Posts : 18
    none

    Quote Originally Posted by JBGoode View Post
    That's only your experience and obviously doesn't mirror everyone's. In my experience, Edge is junk with constant freezes and crashes. Went back to Firefox and highly doubt I'll ever go back to Edge.
    thank you
      My ComputerSystem Spec
  9.    28 Jan 2017 #9
    Join Date : Jun 2014
    Posts : 5,524
    Windows 10 Pro

    IMHO, MS never got IE right and I doubt they every get Edge right. I only use it for testing on my Insider build.*I prefer to use Pale Moon as my main browser.
      My ComputerSystem Spec
  10.    28 Jan 2017 #10
    Join Date : Jun 2014
    Posts : 5,524
    Windows 10 Pro

    I see I just got my first asterisk*using Edge*on the latest Insider Build. I'm going back to Pale Moon.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Speedtest.net and edge show wrong location
I noticed over the weekend when I go to speedtest.net it shows the wrong location. I live on the east outskirts of London yet it thinks my nearest test server is Aberdeen / Edinburgh. If I go to edge, the home/start page which can be customised...
Network and Sharing
Solved what the heck went wrong with edge ?
so i logged onto pc just now and edge browser's configuration has been reset..all my saved bookmarks are gone. have to recreate them. unless during the night it received an anonymous upgrade.. i want to physically strangle this program.:mad:
Browsers and Email
Microsoft Edge: Search bug or have I set wrong
I have setup Google as my default search engine in Edge. If I open a new tab, and see "Where to next?" I have a problem that if I enter a search that has a "." it will fail. i.e. Search for "how to boot from NVMe m.2 SSD" I get an error...
Browsers and Email
Outlook suddenly displaying at wrong size in Edge
Not sure if this is a MS issue. Default zoom setting for Edge is 125% but Outlook email is suddenly really tiny in size despite Edge showing 125%. The right hand 30% of the screen is now just empty white space. If I change it to 100% and back to...
Browsers and Email
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:32.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums