Edge Stopped Working


  1. Posts : 6
    Windows 10
       #1

    Edge Stopped Working


    I'm on Build 14986 of Win 10.
    Today, I tried to use Edge. It launches to the point where the home page URL appears in the address bar, but the page itself does not display. No other page will display either.
    In IE, all is well, so I'm pretty sure Edge is messed up.
    NB Before today, Edge was OK.
    Is there any way to fix/refresh Edge to get it working again?
      My Computer


  2. Posts : 149
    Windows 10 Pro x64
       #2

    I found this a few days ago when my Edge stopped working. The "Repair Edge" button basically does everything as outlined by Ramiiiiiiil in this Microsoft Answers thread. NOTE: If you download the repair tool it will be shown as Win_Tool<dot>exe<dot>part. You'll need to eliminate the <dot>part for the tool to work.

    Need to repair or reinstall Microsoft Edge - Microsoft Community

    warning   Warning
    Before trying the repair tool or using the method described by Ramiiiiiiil, suggest you make a new restore point or system image just in case.
      My Computer


  3. Posts : 6
    Windows 10
    Thread Starter
       #3

    Thanks for the info, Marsmimar. Unfortunately, the procedure did not fix Edge for me. Guess I'll just wait for the next Win 10 build and hope for the best.
      My Computer


  4. Posts : 149
    Windows 10 Pro x64
       #4

    Sorry to hear that the repair tool didn't work for you. Couple of other thoughts if you're feeling adventurous. :)

    You could try using System Restore to roll back your computer to a date/time prior to Edge acting up.

    System Restore Windows 10

    Another possibility is to Repair your current build. I'm guessing since you have Build 14986 it might be better to wait for 14997.

    Windows 10 Build 14997 Brings New Features and Changes
      My Computer


  5. Posts : 156
    Win 7,8.1 ,10
       #5

    Dumb Q but did you try resetting permissions on the appdata folders for edge? Every other issue I have had with it were permission based. 0-o
      My Computer

  6. Winuser's Avatar
    Posts : 6,459
    Windows 10 Pro Insider
       #6

    Are you using Malwarebytes 3.0.5? Edge won't run or loads very slowly if Malwarebytes 3.0.5 is running. I stopped using Edge until this gets fixed.
      My Computers



  7. Posts : 6
    Windows 10
    Thread Starter
       #7

    Thanks, Winuser! I do run MB 3.0.5. I'll wait for a fix.
      My Computer


  8. Posts : 156
    Win 7,8.1 ,10
       #8

    Winuser said:
    Are you using Malwarebytes 3.0.5? Edge won't run or loads very slowly if Malwarebytes 3.0.5 is running. I stopped using Edge until this gets fixed.
    Funny I am running MWB3 up to date and its giving me no issues, now a few versions ago it hated FF and would not let it run at all, its working fine now.

    MWB3 will make things take forever when MWB3 is just starting up tho, could be that?
      My Computer

  9. Winuser's Avatar
    Posts : 6,459
    Windows 10 Pro Insider
       #9

    ZippyDSMlee said:
    Funny I am running MWB3 up to date and its giving me no issues, now a few versions ago it hated FF and would not let it run at all, its working fine now.

    MWB3 will make things take forever when MWB3 is just starting up tho, could be that?
    I run Malwarebytes full time. I was going to disable it but I don't really care that much for Edge so I went back to using Pale Moon. I only use Edge for testing.
      My Computers


  10. Posts : 156
    Win 7,8.1 ,10
       #10

    Winuser said:
    I run Malwarebytes full time. I was going to disable it but I don't really care that much for Edge so I went back to using Pale Moon. I only use Edge for testing.
    I use the resource eater known as Fire Fox LOL
    I pay attention to edge/ie because other in my family will only use it or IE.Also IE was a cornerstone of windose if its acting odd then something in windose is broken so I tend to at least make sure its working before I move on, then again I reinstall windose 2 or 3 times a year just because something breaks and it takes as much time to go back to a fresh install as fixing something half the time if you use a day old image it goes even faster. The worst is migrating the profile I wish soemone would make that less time consuming.
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 14:09.
Find Us




Windows 10 Forums