I ran into what appeared to be a fatal Catch 22 with Eudora 7.1 under Windows 10, then discovered a fix and wanted to share it with others. First, as Eudora users probably know by now, you can use this wonderful program under Windows 10 easily, but if (like me) you are popping email from Gmail to your desktop Eudora folders, you have to periodically tell Eudora to add new certificates to the trusted lists, both incoming and outgoing. This happens about once every 10 days or so.

Today I attempted to send some queued emails and got the familiar "certificate not recognized" error message, but then Windows 10 popped up it's little dialog saying the program had crashed and Windows would now close it. I could not make Eudora respond at that point. When I reopened it and went to personalities/properties to start the certificate manager, it informed me that there were no certificates to add, because I had not sent any mail since last opening Eudora!

Hence the Catch 22. For Eudora to know what certificate to fix, you have to attempt sending mail, fail, then go into your personality properties and add the failed certificate to trusted certificates. But if Windows 10 insists on closing the program when you fail to send email, you can't do that.

The solution turned out to be turning on Windows XP compatibility mode. (Find the Eudora.exe program using file explore, go into properties/compatibility, and turn it on). Then Windows allowed me to fail to send email (!) but, crucially, did not insist on closing Eudora at that point. I was able to add the new certificate, and everything was working again. Whew.

Win 10 then asked, after I closed Eudora, if everything had worked OK. I said yes, and I guess I'll just leave it in XP compatibility mode since it seems to work that way and I will run into this situation again in 10 days or so.

Hope that helps somebody when they run into the same problem.

Cheers!