Windows 10: Edge takes up huge amounts of memory

  1.    24 Nov 2016 #1

    Edge takes up huge amounts of memory


    At times my computer bogs down horribly.* Loading Taskmanager, which can take several minutes, shows Edge taking up 1gb of memory (more or less).* It is usually 100mb or so.
    I have two other computers using Edge, and they seem fine.
    Is there any fix for this?
      My ComputerSystem Spec


  2. Posts : 3,589
    Mac OS Sierra
       24 Nov 2016 #2

    Grab Sysinternals Process Explorer and run it to see which sub-process is killing CPU cycles. You can go in and tweak Cortana, so that it is not sending data to Bing.com, along with settings in System that deals with Telemetry. Windows Sysinternals: Documentation, downloads and additional resources

    The other is do not log in with the email for a Live account. Use a standard Local network type account. Lastly move over to maybe Firefox or Chrome, which you have a lot better security options to help restrict what Flash and Javascript can do to keep Pop-overs and such from killing your browsing sessions.
      My ComputerSystem Spec


 

Related Threads
I tried to execute copying a recent ISO file from macrium to dvd rw disc..and somehow lost a lot of memory on C..what happened? and now trying to find cause on own but cant.. I need that back.:shock: 108029 108030
Hi guys! We're having an issue with a laptop computer connected to an external screen where the tabs in internet explorer are huge compared to the other browsers. When not connected to an external screen there is no problem with huge tabs....
This has only happened since I upgraded to Windows 10. Previously on Windows 7 I never had any memory problems when running a high end video game, multiple web browsers on, and Firefox with multiple tabs open. Ever since getting Windows 10, with...
Hello, Whenever I launch MS Edge, it takes about a minute to bring up the home screen (default). Also, when I click to create a new tab, it takes as long for a new tab to come up where I can type in a new web address. I've searched the web...
Now i'm using windows 10 but I had this problem also when using windows 8.1pro. The windows 81.pro I have the original dvd here and I tried few times to make clean install. Also windows 10 I got it free online and the same problem. For example...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 17:56.
Find Us