Windows 10: Chrome keeps becoming "unresponsive", but IE works perfectly fine

  1.    23 Jun 2016 #1

    Chrome keeps becoming "unresponsive", but IE works perfectly fine


    About an hour ago, websites are starting to load slower (not my internet) than they normally do, and the ones that do load eventually become unresponsive. It's so bad that I can't even load chrome://history or chrome://plugins without them becoming unresponsive (image here). On the other hand, Internet Explorer works perfectly fine. Websites on it load instantly and I can use it for more than five minutes without it becoming unresponsive, so it's obviously something on Chrome's side. I've restarted my PC and uninstalled/reinstalled Chrome and both doesn't help. I've removed all my extensions to see if they are the culprit, but they're not. This happened all of a sudden, and I haven't changed any settings in Chrome before or after all of this started happening.
    Attached Thumbnails Attached Thumbnails EavFo05.png  
      My ComputerSystem Spec

  2.    23 Jun 2016 #2

    VHeroes said: View Post
    About an hour ago, websites are starting to load slower (not my internet) than they normally do, and the ones that do load eventually become unresponsive. It's so bad that I can't even load chrome://history or chrome://plugins without them becoming unresponsive (image here). On the other hand, Internet Explorer works perfectly fine. Websites on it load instantly and I can use it for more than five minutes without it becoming unresponsive, so it's obviously something on Chrome's side. I've restarted my PC and uninstalled/reinstalled Chrome and both doesn't help. I've removed all my extensions to see if they are the culprit, but they're not. This happened all of a sudden, and I haven't changed any settings in Chrome before or after all of this started happening.
    Save your bookmarks, and uninstall it ..
    Go here : Chrome Browser

    for chrome 64Bit , run better+ faster ..
      My ComputerSystem Spec


 

Related Threads
Folks, I'm using a PIN number for logging in to my Win 10 system. All is well for the first few (typically, 5 or 6) logins, but then I get a message that "Something went wrong..." and thereafter I have to use my Microsoft account password to...
I notice that Chrome icon pinned to taskbar has inconsistent behavior between my Windows 10 Pro installs. (My taskbar is configured for "Taskbar buttons: Never combine", but it makes no difference) 1. On one machine clicking on pinned Chrome...
Chrome Messages and "Dings" virus? in AntiVirus, Firewalls and System Security
So i've been getting these popping up in chrome at random times: 3132931328 And i've also been hearing a "ding" noise that sounds sort of like the mario coin sound, but not exactly. It also seems to happen randomly. It happens sometimes with the...
I'm at my wits end. I took advantage of the Windows 10 update on my Samsung laptop several weeks ago, and everything went fine. I've been using it daily with no issues. So, when my wife asked if she should allow the update on her (identical)...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 05:16.
Find Us