1. Joined : Mar 2015
    Palm Springs, CA
    Posts : 41
    Windows 10 Professional (x64) Build 14393
       26 May 2016 #1

    Microsoft Edge: Search bug or have I set wrong


    I have setup Google as my default search engine in Edge.

    If I open a new tab, and see "Where to next?" I have a problem that if I enter a search that has a "." it will fail.

    i.e. Search for

    "how to boot from NVMe m.2 SSD"

    I get an error saying:
    Hmm, we can't reach this page.

    Try this
    •Make sure you’ve got the right web address: http://how%20to%20boot%20from%20nvme%20m.2%20ssd
    •Refresh the page
    •Search for what you want

    If I take out "." it works.
    "how to boot from NVMe m2 SSD"

    Has anybody seen this?
      My System SpecsSystem Spec


  2. Joined : Jan 2015
    UK, Midlands
    Posts : 6,522
    Win 10 Pro (1607)
       26 May 2016 #2

    Hi, it depends- if you mean an exact search using " " to exactly specify the search string as here:
    Click image for larger version. 

Name:	Snap 2016-05-26 at 21.11.06.jpg 
Views:	44 
Size:	15.0 KB 
ID:	81766
    Then you get no results. (That's DuckDuckGo in Firefox). Don't know why you get such an obscure message with Edge.

    Whereas see this:
    Click image for larger version. 

Name:	Snap 2016-05-26 at 21.13.16.jpg 
Views:	1 
Size:	51.7 KB 
ID:	81767
    Last edited by dalchina; 27 May 2016 at 00:39.
      My System SpecsSystem Spec


  3. Joined : Mar 2015
    Palm Springs, CA
    Posts : 41
    Windows 10 Professional (x64) Build 14393
       26 May 2016 #3

    no quotes. just text in quotes
      My System SpecsSystem Spec


  4. Joined : Jan 2015
    UK, Midlands
    Posts : 6,522
    Win 10 Pro (1607)
       27 May 2016 #4

    Just that text in Edge works ok for me.. using Bing. (I don't use Edge normally). Ok with Google in FF, and ok in Edge if I first go to google, then search.
      My System SpecsSystem Spec


  5. Joined : Jul 2014
    UK
    Posts : 16,429
    Windows 10
       27 May 2016 #5

    I have had this in the past, but cannot replicate it now
    For me it was a setting in IE, even though you are using Edge
    See what you have this set to

    Click image for larger version. 

Name:	searchoptions.JPG 
Views:	1 
Size:	42.2 KB 
ID:	81846
      My System SpecsSystem Spec


  6. Joined : Mar 2015
    Palm Springs, CA
    Posts : 41
    Windows 10 Professional (x64) Build 14393
       27 May 2016 #6

    I have the box checked.

    It is definitely something I have set incorrectly. I tried it on my laptop that I don't use as much and it works fine.

    Not sure how much more I am going to fiddle with it, as I am getting a new computer in a week (why I was searching for M.2 SSD) and will just be reinstalling, so hopefully the setting won't get carried thru.
      My System SpecsSystem Spec

  7.    27 May 2016 #7

    IsaacFL said: View Post
    ...It is definitely something I have set incorrectly. I tried it on my laptop that I don't use as much and it works fine.
    Mine is the same so I don't think it's a settings problem, but rather a design problem in Edge.

    As you mentioned, it treats anything you search for in the Edge address bar with a ./period/full stop as a web address instead of a search term (I.E Windows 8.1 Lifecycle). It does the same with slashes too (I.E Canon 600mm f/4 lens). If you search for something with a colon such as a '16:9 monitor', it tells you that you need an app...

    As a interim fix, you can use a ? in front of the search term until Microsoft fix it (I.E ?Windows 8.1 Lifecycle, ?Canon 600mm f/4 lens, ?16:9 monitor). This way it's treated as a search term instead of a website URL, so Google search will work correctly.

    When you say it's OK on your laptop, is Edge on the the laptop set to 'Search in the address bar' with Google too (because the problem doesn't occur when it's set to Bing)? Alternatively, is the laptop maybe running an insider build of Windows 10 where Microsoft may have resolved the issue?
      My System SpecsSystem Spec


  8. Joined : Mar 2015
    Palm Springs, CA
    Posts : 41
    Windows 10 Professional (x64) Build 14393
       27 May 2016 #8

    On the laptop, I have never changed any of the settings in Edge, so it is pretty much the default settings (i.e. using Bing as search). That is why I think it is probably something to do with a change I made on Edge on my main computer. I think it started after I changed the default search to Google. But I changed it back to Bing and the problem persists.
      My System SpecsSystem Spec


  9. Joined : Sep 2014
    Posts : 2,923
    Windows 10 Pro
       28 May 2016 #9

    The reason for this is that the browser is considering the . to be a domain name, like blah.com etc.. so it's trying to look up the site as if it were a domain name.

    The solution to this is to start search queries that might be confused as domain names with a ? (question mark)

    so to search google for foo.com you type ? foo.com, then the browser will submit the text verbatim to the search engine rather than try to look it up. You can also type Ctrl-E and it will automatically add the ? at the beginning of the search query.
    Last edited by Mystere; 28 May 2016 at 15:51.
      My System SpecsSystem Spec

  10.    03 Aug 2016 #10

    I've noticed Microsoft Edge now allows you to use . / and : in address bar searches since the Anniversary Update.

    So we can now search for "NVMe M.2 SSD", "Windows 8.1 Lifecycle", "Canon 600mm f/4 lens" and "16:9 monitor" without needing to use the ? prefix anymore.
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
Microsoft Edge changing search bar
How to change the default search engine in Microsoft Edge These instructions are outdated- my Microsoft edge no longer has the "Add New" button for search engines Instead of I try to follow the instructions, there is only a button to change...
General Support
Outlook suddenly displaying at wrong size in Edge
Not sure if this is a MS issue. Default zoom setting for Edge is 125% but Outlook email is suddenly really tiny in size despite Edge showing 125%. The right hand 30% of the screen is now just empty white space. If I change it to 100% and back to...
Browsers and Email
What the heck is wrong with Microsoft, are they serious?
Can anyone actually read these instructions and not be confused, has to be about the biggest pile of garbage I have seen written in my entire life, I am a well educated man and this just comes off as insanely difficult to understand. ...
General Support
microsoft edge and search box not working
All was working a couple of days ago, now today I can not access edge. double click nothing, went to task bar and cannot enter anything into the "Search the web and windows" then went to windows icon and do not see/get the apps What has...
General Support
Microsoft Edge Search Engine - Change in Windows 10
How to Change Default Search Engine in Microsoft Edge in Windows 10 Microsoft Edge is a new web browser that will be available across the Windows 10 device family. It is fast, compatible, and built for the modern Web. By default, Microsoft...
Tutorials
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:53.
Find Us
Twitter Facebook Google+



Windows 10 Forums