1.    29 Mar 2016 #1
    Join Date : Nov 2015
    Posts : 26
    Windows 10 Pro

    B&H Site Links Freeze IE11


    I can get to (http://www.bhphotovideo.com) but clicking on any link freezes IE11 and MS Edge. Problem is with this site only. Can I assume it's this website? Any ideas?
      My ComputerSystem Spec
  2.    29 Mar 2016 #2
    Join Date : Nov 2015
    Posts : 26
    Windows 10 Pro
    Thread Starter

    Quote Originally Posted by capri3156 View Post
    I can get to (http://www.bhphotovideo.com) but clicking on any link freezes IE11 and MS Edge. Problem is with this site only. Can I assume it's this website? Any ideas?
    Never mind. The website was not working for the past few days but it is now working again.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Site-to-Site Network connectivity issues (Since W10 Upgrade) (URGENT)
Hi Guys, I've done a fair amount of googling before referring myself to W10 Forums.. I hope this helps someone else in the process. Since rolling out Windows 10 we've noticed users are having difficulty accessing their personal user data drives,...
Network and Sharing
IE11 does not want to start all web site
hay all, when open IE11 in win 10 Pro 32 bit ver.1511, it wont open all site 53667 but when i open IE11 run as admin... then works prefect. 53668
Browsers and Email
Anybody Getting System Freeze From Hovering Over IE11 On Taskbar?
This has happened to me 5-6 times in a month and half. A few minutes ago with just one IE window in the background. In the past there's been 5-6 IE windows in the background. Hovering the mouse to expose the thumbnails freezes the PC. Nothing to...
Performance & Maintenance
Mailto Links
Win 10 Ms Edge (and Chrome) How do I make mailto links in websites point to Gmail? Currently every time I click a mailto it gives a choice of Gmail or Outlook. I wish it default to Gmail, and if possible not the app but the program.
Browsers and Email
Solved Hyper Links
Having trouble with Outlook 2013 and Edge. Outlook will not open hyper links. This problem used to be solved by setting IE as default browser. How is this done with Edge? Solved the problem using the Microsoft Fix It program.
Browsers and Email
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:39.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums