I noticed a strange issue in my father's new notebook (Windows 10 Home). He had Windows Live Mail in his Windows 7 desktop, so I installed Windows Essentials 2012 in the notebook as well to use a familiar e-mail application. I setup the same account and the first days it worked flawlessly. Yesterday my father told me he could not sent mail. There was a popup to enter the user name and password. I could not make it work. Out of curiosity, I configured the same mail account in Outlook 2010 using exactly the same settings, servers, ports, user name and password. And of course it worked! It also works without any problem in Windows Live Mail in his Windows 7 PC. What's going on here? I thought to backup the account, uninstall Windows Essentials and reinstall it but I'm not sure it will help and it was rather late so I postponed it. Any ideas? I already tried to disable Windows Defender and Windows Firewall and test settings such as port 465, require secure connection etc. Nothing did the job.

Thank you in advance.

PS: Just in case this info helps, I live in Greece, Athens and my father's ISP is OTENET (now called COSMOTE) with default POP host mail.otenet.gr, default SMPT host mailgate.otenet.gr. The user name can either be my email address or just the bit before @ of my email address. I tried both didn't work.