Internet won't connect when clicking on Edge icon


  1. Posts : 2
    Windows 10
       #1

    Internet won't connect when clicking on Edge icon


    I started having problems last week. When I click on the Edge icon, nothing happens. My default browser is Internet Explorer. Everything was working fine before. I've checked my settings and nothing seems to have changed. The other users on this computer can get connected. I can connect to the internet if I click on the Google Chrome icon on my desktop. I've tried changing my default browser to Chrome and Edge, but still nothing happens when I click on the Edge icon
      My Computer


  2. Posts : 299
    Win-10 Pro x64
       #2

    Did you happen to try the one within the app section, rather than the shortcut on the quick-launch? I've had shortcuts go bad in the past, so that's one thing I usually check before delving in too much with finding a fix.

    b1rd
      My Computer


  3. Posts : 2
    Windows 10
    Thread Starter
       #3

    Yes, I tried the app icon, but that didn't connect either
      My Computer


  4. Posts : 299
    Win-10 Pro x64
       #4

    I did do some quick checking and I found THIS article, which has some good info.

    Also, I found another thread from this same site titled, Reinstalling Microsoft Edge, which may offer some help too.


    b1rd
      My Computer


  5. Posts : 278
    Windows 10 Home Edition 64 bit
       #5

    Thanks for the links. I was having the same issues, among other issues. I did a clean install of Windows 10 and Edge now works.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:34.
Find Us




Windows 10 Forums