Windows 10: Random sites and pages won't load (on all browsers)

  1.    14 Nov 2015 #1

    Random sites and pages won't load (on all browsers)


    Hi,
    this happened two weeks ago. almost 30 percent of images on facebook will not load. some web sites or pages will not load, for example https://www.heroku.com. for this site I'm getting SSL connection error ERR_SSL_PROTOCOL_ERROR in Chrome. I try http and I get a blank page. I tried opening this site on Firefox, Edge and still the same. The same goes for Facebook. I tried on other browsers and still some images wont load. I do not have a third party antivirus/firewall. tried disabling windows defender ( including firewall) and still the same.
    I have two VMs , Win 8 and Ubuntu 14.04. everything is working fine on these two VMs. so I'm quite sure something is wrong with my Win 10 but cannot think of anything. I was thinking it is most probably a firewall issue, so I'm posting in Security section.
    anyone has any idea what to do?
      My ComputerSystem Spec


  2. Posts : 2,675
    Windows 10.4 Home 1703 x64 16288.1000
       15 Nov 2015 #2

    Try changing DNS or download my file bellow and run as admin.

    How to Switch to OpenDNS or Google DNS to Speed Up Web Browsing
    Random sites and pages won't load (on all browsers) Attached Files
      My ComputerSystem Spec

  3.    15 Nov 2015 #3

    Thank you. changed my DNS to Google's and everything is working now.
    What I'm wondering about is that if I uninstall Chrome, everything is fine. so apparently on Win 10 when we install Chrome, we need to set the DNS to Google's also.
      My ComputerSystem Spec

  4.    15 Nov 2015 #4

    I'm not clear where you changed your DNS settings, e.g. the adapter or router
    However, I don't believe any browser is contingent on a particluar DNS setting
    I use OpenDNS and have used Edge (ahem), IE, Chrome and Firefox all without any issue whatsoever
      My ComputerSystem Spec

  5.    15 Nov 2015 #5

    I changed the my network adapter settings and applied Google's DNS. it was good for a few minutes however. my problem seems to be Chrome. I tried uninstalling chrome and all other browsers starting working fine. a very strange and frustrating situation.
    I get Failed to load resource: net::ERR_CONNECTION_REFUSED intermittently for pages and images on facebook!
    I'm still trying to find a solution for this in Chrome Forums.
      My ComputerSystem Spec


 

Related Threads
Hi All, I just booted up a brand new PC this morning with Windows 10 installed. I can connect to the internet via WIFI but when using any of my 2 browsers (Edge & Firefox) neither of them will load any pages. Edge did initially after a few...
as per title what i have tried is checking the installation media is good which it is checked it on another rig running windows 10. okay so what happens is it will go through the normal boot up procedure my rig that is, bios will post normally and...
Hi, I cannot reach some websites that were easily accessible to me about a couple of weeks ago and get this message from (For example..) Firefox, here's another site I discovered this morning: Unable to connect Firefox can't establish a...
Slow Web Pages. in Browsers and Email
Since I upgraded to Windows 10, my Web Pages are slow to react. Is there anything that I can do, short of installing more RAM, to speed up the Web Pages? Also, is there a list of Cortana Commands? I know "Open" and I just say what Web Page to go to....
Hi there I get IE11 hanging after using two or 3 pages on loads of websites - BBC, even this Forum etc. I can say post a topic and then when I try and read another post IE11 hangs . It's IMO NOT the Forum as this happens on other sites such as...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:08.
Find Us