Windows 10: Internet Explorer is very Slow... Solved

  1.    03 Nov 2015 #1

    Internet Explorer is very Slow...


    When I first upgraded IE was OK but for some unknown it has become very slow.
    What can I look for?
      My ComputerSystem Spec


  2. Posts : 22,804
    64-bit Windows 10 Pro build 16257
       03 Nov 2015 #2

    Hello rfrharbin,

    If you have any toolbars or add-ons installed in IE, then one of them could cause this. If you do, temporarily disable them to see how IE performs afterwards.

    Internet Explorer - Enable or Disable Toolbars and Extensions Add-ons - Windows 7 Help Forums
      My ComputersSystem Spec

  3.    03 Nov 2015 #3

    I had three add-ons. It took over five minutes to disable them one at a time. This did not help. Thanks for the idea. Any other ideas?
      My ComputerSystem Spec


  4. Posts : 22,804
    64-bit Windows 10 Pro build 16257
       03 Nov 2015 #4

    In that case, you could see if resetting IE back to default may help.

    https://www.tenforums.com/tutorials/2...dows-10-a.html
      My ComputersSystem Spec

  5.    04 Nov 2015 #5

    Thanks very much, the reset did the trick. I will add things back in slowly over the next few days.
      My ComputerSystem Spec


  6. Posts : 22,804
    64-bit Windows 10 Pro build 16257
       04 Nov 2015 #6

    Great news. You're most welcome.
      My ComputersSystem Spec


 

Related Threads
My interent on my custom desktop, as far as I can remember, has functioned fine for a long time now. However, after upgrading to windows 10 and having it around for a while, I noticed a sharp decrease in internet speed. I've tried multiple...
Hi hope somebody can help. Since upgrading to windows 10 my internet speed on my Packard Bell PC has dropped to almost nothing, less than 1mb. Before upgrade it was around 76mb. All my other laptops, tablets etc are getting good wifi speeds. When I...
After I downloaded Windows 10 pro, downloading anything from the internet is incredibly slow or I loose connection completely. Please advise. Thanks, catszw
I recently upgraded from W7 to W10 on my W7 laptop. The install went well, no problems to report. Since then my broadband speed has suffered badly. I've just tested the speed - the download speed is 1.6mbps and upload speed 0.29mbps. It's not...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 08:47.
Find Us