Windows 10: Windows 10 - internet site visitation is slow, lags behind & stps wrkg

  1.    19 Oct 2015 #1

    Windows 10 - internet site visitation is slow, lags behind & stps wrkg


    I have Windows 10. Frequently when I'm on the Internet I get the message "INTERNET EXPLORER HAS STOPPED WORKING". In addition, my mouse lags behind my commands - the Internet explorer connection is frequently lost, website viewing is slow and often stalls, 3rd party sites do not animate or move.

    Pls advise as to how to fix this ... many thanks.

    A newbieClick image for larger version. 

Name:	FullSizeRender.jpg 
Views:	1 
Size:	374.0 KB 
ID:	43614
      My ComputerSystem Spec


  2. Posts : 2,036
    Ubuntu14.04x64 MintMate17x64 Win10Prox64
       19 Oct 2015 #2

    Here's what I suggest you to do:
    1. Download Malwarebytes Anti-Malware. Install and run to make sure that the PC is clean.
    2. I don't know what browser you are using but all of them have the options to disable Add-ons/Plugins. Temporarily disable them all.
    3. Check your Router manufacturer for the latest firmware and update it.
    4. Reset your router by unplugging the power cord and leave it out for 10' or so. This will refresh the DNS cache if it was outdated or corrupted.
    5. From your PC, Open Admin command prompt and type: ipconfig /flushdns to clear up the PC DNS Cache.
    6. From admin command prompt. Copy and paste the following line and run:
      Dism.exe /online /Cleanup-Image /StartComponentCleanup&dism /online /cleanup-image /restorehealth&sfc /scannow&pause
      NOTE: This will take a while. Please be patient.
    7. Reboot your PC.


    Try again to see if it helps.
    Good luck.
      My ComputerSystem Spec


 

Related Threads
Boot time for windows 10 seems much slower when connected to the Internet. Anybody else find this to be true?
I recently upgraded from W7 to W10 on my W7 laptop. The install went well, no problems to report. Since then my broadband speed has suffered badly. I've just tested the speed - the download speed is 1.6mbps and upload speed 0.29mbps. It's not...
Solved Internet site in Start in General Support
How to pin internet site to Start?

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:46.
Find Us