Microsoft Edge Bad Rep.


  1. Posts : 29
    windos 8.1
       #1

    Microsoft Edge Bad Rep.


    I am beginning to think that I gave Microsoft Edge a bad Rep. I switched to Google Chrome and now I am still having problems with logging onto web pages. I think that it may be a Windows 10 problem. I use CCleaner every night before I shut down so I know that it is not a "buildup" of excess files on my computer. At first Chrome was a little faster than Edge and I was satisfied but now the same old thing is happening. I have 8 Gigs of RAM. That should be enough to have a speedy computing experience. I do not know much about other Browsers such as Firefox or any other. Can anyone tell me what is going on? I have not tried IE. I can bring up IE with Cortana or just find it in the apps.

    Any advice will be helpful,

    Jay
      My Computer


  2. Posts : 751
    Win10 Version 20H2 19042.844
       #2

    Have you scanned with your AV for malware, or could it be the AV causing the slow performance ? Disable the AV to check.

    Check Event Viewer and Troubleshoot (Control Panel/Security & Maintenance/Troubleshoot

    Could software or apps be causing the issue ?

    Lots of troubleshooting tips in the tutorials on this site and on the web. If all fails, consider a System Restore or Refresh.
      My Computer

  3. Torquemada's Avatar
    Posts : 354
    Widows 10/Linux
       #3

    Try turning off IPv6 if it's enabled. Network and sharing centre/Change adapter settings/ Right click adapter/Properties

    Microsoft Edge Bad Rep.-ipv6.jpg
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:32.
Find Us




Windows 10 Forums