Latest Firefox Released for Windows

  1. Anak's Avatar
    Posts : 1,256
    10 Home 64-bit | v2004 | Build - 19041.685 - See other Info below
       #1821

    Superfly said:
    Dunno, ... but I haven't seen it for a while lately -- might be beta 11 fixed it.

    BTW: I did try removing all extensions - that was not the cause.

    I looked around after I posted that and the closest an answer I can find is it may have to do with Akamai's CDN (Content Delivery Network) or some other CDN, here's from Tom's Hardware: An error occurred while processing your request | post #5:
    The following is what has been communicated to me from the devs, verbatim:

    What we know is that this bug is not directly our own, it rather looks like it lies under akamaï’s responsibility. Akamaï owns servers that serve our pages as a sort of ‘cache’, we use them in the US because it improves the page load performance.
    Since this is not under our very own control, the investigation is taking a long time.
    We're doing what we can to address the issue, but certain aspects are out of our control. It appears to mainly be affecting US West Coast users, which helps to narrow things down. The issue is being prioritized as a result of all the people it seems to affect, but I'm told that we should not expect any immediate resolutions to this. It seems as if this will take some time.
    All I did to fix it is add an 's' to the http in the link I had for the NWS site and that cured it. Then I took Callender's suggestion an installed the HTTPS Everywhere add-on from EFF and haven't had a problem since. Some of these CDN's may balk at sending a request through if they don't see that 's'.

    Check for the spurious 's' on your bookmark it may be your problem to unless beta 11 holds for you and Firefox figured it out, but TenForums has always been https so I don't know. You'd need something like wireshark to see if akamai or again some other CDN has a hand in, however minutely, with content delivery for 10F.

    Ubuntu? That's not in my pay-grade, yet.
      My Computers

  2. Superfly's Avatar
    Posts : 3,337
       #1822

    Hmmm.. dunno if we are talking the same thing here - that link mentions Chrome ( I have Vivaldi which does not have the Network protocol issue)

    (As far as Ubuntu is concerned... it's amazing how MS has embraced it... I would never have even considered writing .Net apps for Linux (Mono-develop not being up to Windows standard) but who would have thought... eg: Powershell on Linux? -- very cool! :)
      My Computer

  3. Josey Wales's Avatar
    Posts : 24,868
    Win 10 Pro 19043.985
       #1823

    Anak said:
    Sure, If you're in a hurry.
    It is out to fix something possibly security one should be in a hurry.
      My Computer

  4. Anak's Avatar
    Posts : 1,256
    10 Home 64-bit | v2004 | Build - 19041.685 - See other Info below
       #1824

    Superfly said:
    Hmmm.. dunno if we are talking the same thing here
    Apologies, I mis-understood.
      My Computers

  5. Superfly's Avatar
    Posts : 3,337
       #1825

    Anak said:
    Apologies, I mis-understood.
    All good... ..

    BTW I ran it by my SysAdmins at work - they had no clue either (altho' they're not the brightest crayons TBH -- but anyway... )
      My Computer

  6. Demonlord4lf's Avatar
    Posts : 102
    Windows 10
       #1826

    Got the update now :)
      My Computer

  7. Edwin's Avatar
    Posts : 17,478
    Windows 10
       #1827

    Firefox Nightly 67.0a1 custom Content Blocking...

    Latest Firefox Released for Windows-000143.png
      My Computer

  8. Wynona's Avatar
    Posts : 28,128
    Windows 10 20H2 Build 19042.928
       #1828

    Anak said:
    I checked also but it may be protocol to hold release until notes are published.
    I'm a little late to the party, but when I checked Help>about FF, it immediately started to update. I'm on 65.0.2 now.
      My Computer

  9. f14tomcat's Avatar
    Posts : 53,661
    Multi-boot Windows 10 - RTM, RP, Beta, and Insider
       #1829

    Anak said:
    I checked also but it may be protocol to hold release until notes are published.
    Firefox does a staggered rollout of the updates. If it doesn't get to you soon (tomorrow) you can download the installer and do it yourself.
      My Computers

  10. Anak's Avatar
    Posts : 1,256
    10 Home 64-bit | v2004 | Build - 19041.685 - See other Info below
       #1830

    Superfly said:
    All good... ..
    Cool...

    Superfly said:
    BTW I ran it by my SysAdmins at work - they had no clue either (altho' they're not the brightest crayons TBH -- but anyway... )
    Yea if its gone away since beta11 maybe it was just a hiccup an fixed itself.

    I'm good. Checked as soon as I jumped online and I'm on 65.0.2
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:34.
Find Us




Windows 10 Forums