Latest Firefox Released for Windows

  1. Edwin's Avatar
    Posts : 17,737
    Windows 10
       #1051

    Latest Firefox Released for Windows-000558.jpg
      My Computer


  2. KCR
    Posts : 310
    Windows 10 Home, 64-bit, Version 21H1 (OS Build 19043.1055)
       #1052

    :). . . .

    Latest Firefox Released for Windows-image.png

    .
      My Computer


  3. Posts : 26
    Windows 10 Pro 64bit
       #1053

    For some reason, while Chrome plays HD youtube videos fine, Firefox 58 does not play them at all in my Windows 10 Pro setup. Is there a way to fix this?
      My Computer

  4. OldMike65's Avatar
    Posts : 109,166
    Windows 10 Pro (x64) 21H1 19043.1055
       #1054

    zanxion said:
    For some reason, while Chrome plays HD youtube videos fine, Firefox 58 does not play them at all in my Windows 10 Pro setup. Is there a way to fix this?
    Can you post a link to one of those video's that your FF won't run, I'll test it on my FF 58.2
      My Computers


  5. Posts : 26
    Windows 10 Pro 64bit
       #1055

    OldMike65 said:
    Can you post a link to one of those video's that your FF won't run, I'll test it on my FF 58.2
    Here is one:
    The Eagles - Hotel California solo (Cover by Chloé) - YouTube

    And another one:
    Deep Purple solo by Gretchen Menn - YouTube

    Both play wonderfully in Chrome, but in firefox they stop after two-three frames.
    I run firefox on Windows 10 Pro 64bit on a Dell Latitude E4300 with the GMA 4500MHD graphics chipset.

    My Firefox is v58.0.1. I can see these plugins already installed:
    OpenH264 Video Codec provided by Cisco Systems, Inc.
    Widevine Content Decryption Module provided by Google Inc.

    Could it be something missing?
      My Computer

  6. CountMike's Avatar
    Posts : 18,673
    W10+Developer Insider + Linux
       #1056

    Works perfectly here.
      My Computers

  7. OldMike65's Avatar
    Posts : 109,166
    Windows 10 Pro (x64) 21H1 19043.1055
       #1057

    zanxion said:
    Here is one:
    The Eagles - Hotel California solo (Cover by Chloé) - YouTube

    And another one:
    Deep Purple solo by Gretchen Menn - YouTube

    Both play wonderfully in Chrome, but in firefox they stop after two-three frames.
    I run firefox on Windows 10 Pro 64bit on a Dell Latitude E4300 with the GMA 4500MHD graphics chipset.

    My Firefox is v58.0.1. I can see these plugins already installed:
    OpenH264 Video Codec provided by Cisco Systems, Inc.
    Widevine Content Decryption Module provided by Google Inc.

    Could it be something missing?
    Could not run the 1st one, because it reported not available in my country. :)
    2nd one ran fine, no issues. Latest FF is 58.0.2 Also. You need to update.
    What I would suggest is do a Clean install of your FF. Make a backup of your bookmarks and Passwords before removing your FF. I've had to do a clean install, and after I did, FF ran better and faster than it ever did. :) You could try using this older app for making your FF backup.
    Download Mozbackup - MajorGeeks
      My Computers

  8. Bree's Avatar
    Posts : 19,626
    10 Home x64 (21H1) (10 Pro on 2nd pc)
       #1058

    Good, isn't she?

    In FF 58.0.2 (x64) Stats for Nerds:

    Latest Firefox Released for Windows-stats-nerds.png

    Latest Firefox Released for Windows-ff-58-0-2-plugins.png
      My Computers

  9. Edwin's Avatar
    Posts : 17,737
    Windows 10
       #1059

    Both links work here under normal settings.
      My Computer


  10. Posts : 26
    Windows 10 Pro 64bit
       #1060

    Bree said:
    Good, isn't she?

    In FF 58.0.2 (x64) Stats for Nerds:

    Latest Firefox Released for Windows-stats-nerds.png

    Latest Firefox Released for Windows-ff-58-0-2-plugins.png
    Good indeed!

    I have tried removing and cleaning up FFox but at no avail.

    Eventually I have tried something from the 4X era of FFox, disabling the "Use hardware acceleration when available" option.
    CPU usage has fallen from 78 down to 35% and the HD youtube videos play now nicely!
    Strange, but it works! :)

    A great thank you to you all!
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:20.
Find Us




Windows 10 Forums