Edge - does not update - error code 7: 0x80072EFD — system level

Page 1 of 2 12 LastLast

  1. Posts : 867
    Windows 10 x64
       #1

    Edge - does not update - error code 7: 0x80072EFD — system level


    Yesterday and today I have been trying to update Edge.
    Both on VM and host, the 'Check for updates' runs for a while (checking) but ends with an error.

    "
    An error occurred while checking for updates: Unable to connect to the Internet. If you use a firewall, please allow list MicrosoftEdgeUpdate.exe. (error code 7: 0x80072EFD — system level).

    "
    Disabled Microsoft Defender firewall : makes no difference
    The MicrosoftEdgeSetup.exe can not connect with Internet, however, everything is in order.

    -microsoft-edge-unable-update-10032023-061056.png

    Any suggestions?

    Thanks!
    (Host-PC Windows 10 x64 19044.2311 - VM: Windows 10 x64 19045.2673)
      My Computer


  2. Posts : 42,512
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #2

    Hi, do you have any other internet-related problems?

    What happens if you check for Windows Updates for example?

    And the Store?

    Are you using a VPN or proxy?

    Might be a temporary issue connecting to the MS server.

    If this affects Edge alone, try clearing its browsing history etc:

    1. Click on the three dots on the top right corner of the browser and click on the settings option.
    2. Scroll down and you get a button choose what to clear under the clear browser data option.
    3. Click this option and you can selectively clear the cache on your browser. You can choose from browsing history, cookies, cached files, delete history etc.

    You could also try using In Private window, by clicking on the three dots and select New In Private window.

    Basic ideas e.g.
    How to Fix Windows Update error 0x80072efd in Windows 10
      My Computers


  3. Posts : 867
    Windows 10 x64
    Thread Starter
       #3

    Hello

    No Internet issues. Updating (VM) of Windows, no problem. VPN is disabled, not using proxy.
    Just tried to update Edge on a 'clean' Windows VM (19045.2604)
    Clean means clean, i.e. same as a fresh install on a formatted drive. In this case only Edge is installed.
    No history, no cache, nothing, same error.
    Checked out my Surface Pro - same error.

    So, 2 VM, host-pc and Surface Pro - they are unable to connect Internet... while they are all working fine (except updating)

    It is funny....
      My Computer


  4. Posts : 42,512
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #4

    DNS or server issue perhaps.. outside your control. You could try pinging, and changing the DNS.

    Compare Store and Windows Updates.
    Check if anyone else you know with the same ISP has the same problem, for example- or at least in the same area.
      My Computers


  5. Posts : 867
    Windows 10 x64
    Thread Starter
       #5

    Please would you do me a favour?
    Go into Edge > Settings > Search: Security

    -snagit-10032023-114735.png

    On
    https://learn.microsoft.com/en-us/de...rity-endpoints
    and
    on
    https://support.microsoft.com/en-us/...microsoft-edge

    they say that
    https://msedge.api.cdp.microsoft.com

    should always work.

    I get a timeout error.

    -snagit-10032023-115102.png

    Nothing is set under "Manage enhanced security for sites"

    OTOH - I believe things worked well in the past.

    All in all, strange.

    If there is no solution, I guess I let it rest.
      My Computer


  6. Posts : 42,512
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #6

    https://msedge.api.cdp.microsoft.com/

    - gives me a 403 error in Edge and Firefox.
      My Computers


  7. Posts : 867
    Windows 10 x64
    Thread Starter
       #7

    What happens if YOU check for Edge updates ('About Microsoft Edge')
      My Computer


  8. Posts : 42,512
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #8

    Works.
      My Computers


  9. Posts : 867
    Windows 10 x64
    Thread Starter
       #9

    Thanks.
    After endlessly trying whatever 'solutions':
    running MicrosoftEdgeSetup.exe, do Firewall settings, adjust Services where needed, check out Proxy , TCP/IP4 properties, Troubleshooters, run DISM and SFC , did Repair Install, did the 'Update Now' thing from MS website and ...
    even running 19045.2728 Update MSU-File,
    problem still remained. Edge was unable to connect.

    Windows was updated though - it did not update either so far...

    Still this Edge problem.


    Finally I changed the DNS Server addresses (Network & Internet > Change adapter settings - TCP/IP4 - Properties):
    Preferred 8.8.8.8
    alternate: 8.8.4.4

    That worked.

    pheww...
      My Computer


  10. Posts : 42,512
    Win 10 Pro (22H2) (2nd PC is 22H2)
       #10

    Good, hinted at in post #4.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 14:44.
Find Us




Windows 10 Forums