To start off with, when I initially upgraded to W10 everything in Outlook worked perfectly fine. I could both open hyperlinks to Firefox (my default) and get instant search results as I typed. However, about 3 days ago I went to search and I got the notification: "Instant Search is not available when you have administrator permissions. please log out and login without administrator permissions." I had previously updated to insider build 10525 with no issues for several days prior to the notification, so this problem was out of left field with nothing changed to prompt the issue (as far as I can tell).

Through trial and error I discovered that opening Outlook from a shortcut anywhere other than the start menu would open it as an administrator even if that was unchecked in the compatibility tab of the properties menu. Only by opening it directly from the .exe in the explorer or from the start menu would it open not as an administrator. Doing this brought back the instant search functionality. However, running explicitly not as the administrator caused hyperlinks to stop working. I must right-click and "run as administrator" for that functionality.

Basically, if I run Outlook as an administrator I can open hyperlinks to my web browser, but the instant search is non-functional. If I make sure to not run as administrator, the instant search works perfectly but hyperlinks are broken again.