Edge update has issues with support.microsoft sites

  1. XXLMandalorian's Avatar
    Posts : 29
    Win 10 64
       #1

    Edge update has issues with support.microsoft sites


    I had my edge browser update to 89.774.63 yesterday. I am unable to go to any support.microsoft.com sites as it gives a bad request-request too long, HTTP error 4004 The size of the request header is too long. This happened on a previous update as well.


    Clearing the cookies/cache fixes it but it's annoying losing all of that cache each update. It's no issue on those sites in Chrome. We are on a domain at work and a coworker had no issues with the same site in edge on the same version. I also asked one of our "work at home people" to try it as well on the same version on their home internet and they had no issue.

    Anyone else having this issue? What could be on my end that would cause this?
    Attached Thumbnails Attached Thumbnails Edge update has issues with support.microsoft sites-edge-error-2021-03-30-104604.jpg  
      My Computer

  2. AndreTen's Avatar
    Posts : 23,299
    Windows 10 (Pro and Insider Pro)
       #2

    Try to delete only cookies for this domain. Would then work?

    Could be something related to your privacy settings
      My Computers

  3. Bree's Avatar
    Posts : 18,652
    10 Home x64 (20H2) (10 Pro on 2nd pc)
       #3

    XXLMandalorian said:
    Anyone else having this issue? What could be on my end that would cause this?
    I can only confirm that it must be something at your end, as I don't have this issue either - even for that page in your screenshot.

    Edge update has issues with support.microsoft sites-image.png
      My Computers

  4. Callender's Avatar
    Posts : 4,071
    N/A
       #4

    Try:

    Edge update has issues with support.microsoft sites-settings-personal-microsoft-edge.jpg

    Then clear cache and relaunch.
      My Computer

  5. XXLMandalorian's Avatar
    Posts : 29
    Win 10 64
    Thread Starter
       #5

    Thanks for the tips everyone. I really like having Edge pick up where I left off but I'll try it.
      My Computer

  6. XXLMandalorian's Avatar
    Posts : 29
    Win 10 64
    Thread Starter
       #6

    Callender said:
    Try:

    Edge update has issues with support.microsoft sites-settings-personal-microsoft-edge.jpg

    Then clear cache and relaunch.
    I turned off "continue where..." closed edge and the error went away. Turn "continue where..." back on and seems to still let me on the ms support sites. Guess ill just do this each update as I like "continue where..." too much ��
      My Computer

  7. Callender's Avatar
    Posts : 4,071
    N/A
       #7

    It might be something to do with long term cookies expiring or something. So "Continue" would load cookies but if they've expired after some time you might see the messge. Just a guess. Unchecking that option then visiting the site would give you a fresh set of cookies.
      My Computer

  8. XXLMandalorian's Avatar
    Posts : 29
    Win 10 64
    Thread Starter
       #8

    Callender said:
    It might be something to do with long term cookies expiring or something. So "Continue" would load cookies but if they've expired after some time you might see the messge. Just a guess. Unchecking that option then visiting the site would give you a fresh set of cookies.
    Ah, I see. Thanks for the explanation!
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:01.
Find Us




Windows 10 Forums