Slow browsers  


  1. Posts : 228
    w10
       #1

    Slow browsers


    Guys

    On my previous post, I said that I have reformatted my w10 so started with a blank canvas again. I was using Google Chrome as browser, but it is EXCEPTIALLY slow so i did a Google question and the world opened with solutions, but also, many people had same probl;em.

    I have tried Opera and Edge, all slow, maybe Edge a bit faster.

    How can this be with a clean install and all working ok except browser, is it because browser problems are net related and not pc problem. advice please as when I c/o Google Chrom icon, screen open totally white until it eventually opens.
      My Computer


  2. Posts : 17,962
    Win 10 Pro 64-bit v1909 - Build 18363 Custom ISO Install
       #2

    Hello @frenchman96,

     System Specifications

    Please update your system specifications [ System AND Hardware ] by editing your profile. It will allow us to give you more Specific Advice and Help! . . .

    > How to Fill in your System Specs at Ten Forums.

    To make this process easier for you, there is an Automated method that you can use by clicking the Download button at the top of the Tutorial. It contains a standalone .exe file delivered in a .zip file. You just need to Unzip the file and Run SystemInfo.exe. Please note that this file does NOT save ANYTHING to your computer.

    You might also find this Tutorial useful . . .

    > Collecting System Specifications in Windows

    • Please include Case, Cooler, HDD, PSU, SSD, etc.
    • Include ANY Peripherals attached to the computer, both wired or wireless [ Headset, Keyboard, Mouse, Printer, Scanner, Speakers, USB, Wireless Network Card, xBox, etc].

    Thanks.
      My Computer


  3. Posts : 2,487
    Windows 10 Home, 64-bit
       #3

    frenchman96 said:
    I was using Google Chrome as browser, but it is EXCEPTIALLY slow
    Please provide more details and context.......such as:

    Slow compared to what and when?

    What browser have you ever considered "fast" on Windows 10 using your current hardware?

    Has your PC undergone any hardware changes since the browser was fast?

    Is there any correlation to particular web sites?

    Have you taken a gander at Task Manager?

    Have you done any browser speed tests recently and how do the results compare to months ago?

    Are you convinced your ISP is innocent?
      My Computer


  4. Posts : 17,962
    Win 10 Pro 64-bit v1909 - Build 18363 Custom ISO Install
       #4

    Hello @frenchman96,

    Also, you could try this => How to Enable or Disable Sync in Google Chrome in Windows

    I hope this helps.
      My Computer


  5. Posts : 228
    w10
    Thread Starter
       #5

    ignatzatsonic

    Thanks for reply, but a lot of questions, I will keep it simple if I may.

    I have used my pc daily for ages without any trouble, but because of a problem recently , I decided to do a reformat to my w10 and it went well and i have got myself back to normal.

    Only problem is, my Google Chrome which I use for browsing, has become VERY slow in opening up, same with Gmail.

    I followed tips on net by trying Edge and Opera and it seems that Edge is the quickest.
      My Computer


  6. Posts : 2,487
    Windows 10 Home, 64-bit
       #6

    Based on what you say, I assume Chrome works fine..........once it is opened. Your only problem is that it is slow to open.

    So, use Edge if the slow opening speed of Chrome is a big issue.

    My Chrome opens to a blank page in about 1 second. It brings up a random web site in about 2 seconds, occasionally slower.

    You may or may not have many processes unrelated to Chrome going on in the background since your new installation, but that would require you to investigate in Task Manager, which may not be as simple as you'd like.

    You have told us virtually nothing about your hardware......it may be superb, mediocre, or failing.

    Good luck.
      My Computer


  7. Posts : 1,013
    Win10 Version 21H2 19044.1645
       #7

    frenchman96 said:
    ignatzatsonic

    Thanks for reply, but a lot of questions, I will keep it simple if I may.

    I have used my pc daily for ages without any trouble, but because of a problem recently , I decided to do a reformat to my w10 and it went well and i have got myself back to normal.

    Only problem is, my Google Chrome which I use for browsing, has become VERY slow in opening up, same with Gmail.

    I followed tips on net by trying Edge and Opera and it seems that Edge is the quickest.

    Review the questions in post #3. Are the browsers just slow to launch, or also slow to browse ?

    Check your internet speed and network adapter drivers. Depending on your system, sometimes the drivers installed on a clean install do not play well. May try to reinstall or go to the HP site for the original drivers.
      My Computer


  8. Posts : 228
    w10
    Thread Starter
       #8

    My BB speed is 35 Mb/s and I would say the slow speed is mainly when I open up rather than when I browse.

    Would need to check again as I have started using Edge as it is much quicker, not sure if its relevant, but my Chromebook does not have this problem
      My Computer


  9. Posts : 1,957
    Windows 11 Pro (latest update ... forever anal)
       #9

    What have you got your home page set as for each browser - different? the same?
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:07.
Find Us




Windows 10 Forums