Edge wants to do a first-time install when called from other apps


  1. Posts : 80
    Win10 x64
       #1

    Edge wants to do a first-time install when called from other apps


    I prefer Edge over Chrome for my default browser, but recently it began occasionally auto-launching as if it were a first time install (Welcome to Edge). If I let it do that, I lose all my settings and bookmarks (I now backup Edge settings weekly). I want to stop this behavior.

    I originally noticed this behavior when I double-clicked certain PDFs, Edge would launch as if it were its first time (even if Edge was already running). I've since changed PDF associations to another program.

    I thought these nuisance launches were behind me. But today, while running OneNote 2013, I selected a note to be viewed in fullscreen. When I did that, Edge launched with it's nefarious Welcome screen again. So I opened Task Manager to kill Edge before it took over (it already added a few "default" bookmarks from who knows where).

    What's with this? And how do I prevent it? I'm about to revert to Chrome (!!!)

    Thanks in advance. This is Win10 x64 Home 20H2.
      My Computer


  2. WXC
    Posts : 13,156
    Windows 10 Pro 64-bit 22H2 19045.4046
       #2

    Hello @Telos,

    Firstly, I can not advise the following will work in your situation.

    Some months ago, I experienced the same issues as you described.

    Ok, so I know nothing...but one thing. I uninstalled Edge Chromium, then reinstalled.

    An aggravation? Certainly.

    But the issue never recured.

    Perhaps of no relevance to your specific issue, I understand. Just throwing it out there.

    Stay safe.
      My Computer


  3. Posts : 80
    Win10 x64
    Thread Starter
       #3

    WXC said:
    Hello @Telos,

    Firstly, I can not advise the following will work in your situation.

    Some months ago, I experienced the same issues as you described.

    Ok, so I know nothing...but one thing. I uninstalled Edge Chromium, then reinstalled.

    An aggravation? Certainly.

    But the issue never recured.

    Perhaps of no relevance to your specific issue, I understand. Just throwing it out there.

    Stay safe.
    I just tried this. Rebooted and opened OneNote 2013... selected note and then "full screen". Edge did not launch and OneNote went to full screen. So far, so good.

    I used HiBit Uninstaller to remove Edge. Interstingly, neither the Edge uninstaller or the HiBit scan removed my settings. When I initially launched I got a new empty page with promoted shortcuts, but after my blocks of *.msn.com kicked in. I had a clean new page (full black).

    So far, so good... thanks!
      My Computer


  4. Posts : 1,959
    Windows 10 Pro x64
       #4

    There must be a better ( much easier !) solution to change this unwanted behaviour .............

    Encountered this problem many times , when clicking on a link in other software also , booom , "welcome" ..all setting gone !
    My solution is ; backup once/twice a week , using special software to backup Edge-Chromium , works fine and fast...........
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:16.
Find Us




Windows 10 Forums