how to enable auto login in ChrEdge


  1. Posts : 23
    win 10 Pro 64b 1909
       #1

    how to enable auto login in ChrEdge


    I'm using the Chrome version of Edge in Win 10 1909. I do NOT login to a Microsoft account and will not sync passwords to online accounts.

    In Edge I have "save passwords" and "auto login" turned on, When I manually enter username and password fields, the browser offers to save them (unfortunately only when a password field is present which complicates two screen logins). I save the username (manually entered into the save window) and password.

    When I revisit the site to login, no auto login sequence executes. I'm presented with the normal login window(s) for the site and have to manually enter the UID and Passwords.

    Must be doing something wrong, but can't figure out what. Searches haven't helped. Any suggestions? Thanks
      My Computers

  2. dalchina's Avatar
    Posts : 25,081
    Win 10 Pro (1903)
       #2

    Hi, just to clarify, when you access such sites, are you expecting...
    - the login fields to be filled automatically and the button clicked
    - no login fields to appear at all even momentarily- your login state is remembered as you didn't log out after your previous session?

    If the latter (e.g. tenforums) the login state is remembered by a cookie.

    Banking and other sensitive sites will time you out if you simply close the tab or browser of course.

    This will probably be familiar: I can't find anything on password management in Edge Chromium in the tutorials here yet except for the password monitor.
    Enable and Manage Passwords & Form-fill in Edge browser
      My Computers


  3. Posts : 23
    win 10 Pro 64b 1909
    Thread Starter
       #3

    Thanks for the link Dalchina.

    Did some more digging and think I found the problem. My normal password manager is Roboform in Vivaldi which I use because it can be set up to only store password files locally. Apparently this is not the case in Edge in which you are required to sync passwords to Roboform Everywhere which I don't want to do. (At least in the original Edge)

    Anyway, the auto login I was trying to set up was for Disney + on our HTPC. Since there's no Win 10 App for D+ you have to use the browser. Unfortunately D+ uses a dual stage login (one screen each for UID and Password). Edge apparently only saves if a password field is present. This results in the saved token having the URL of the password page only and even though it allows you to manually enter the UID, nothing is done with it. The result is that you still have to manually enter the UID, click continue (or whatever) and then you can click on the Password field, select the saved password and then click login. Kind of awkward. Roboform will handle such sites correctly even though you do have to click "fill" when the password page presents.

    I did set up a saved token for a site that has a single login (both UID and PW) page and it works correctly. Since Edge does NOT allow you to edit the login token directly, you can't modify the target URL to go to the first login page and start there. I dunno, maybe they'll eventually fix this. Thanks again.
      My Computers

  4. dalchina's Avatar
    Posts : 25,081
    Win 10 Pro (1903)
       #4

    Hi, I think you're right about the Roboform extension for Edge/Edge C being Everywhere. I use Roboform Everywhere myself, so have never considered whether Roboform Desktop was available for Edge.

    There is the lower toolbar of course:
    Enabling the RoboForm lower toolbar (Chrome, Edge, and Firefox) – RoboForm
    - have you tried that? I've only used it occasionally.

    I appreciate what you're saying about the now more common 2 page 2 -stage login- sometimes the 2nd page may have a different URL, sometimes not.

    They do have a Store add-on for Edge Chromium, but again, nominally for Everywere as you say.
    Using RoboForm with Microsoft Edge on desktop – RoboForm

    I wouldn't expect the same flexibility with a browser- based password manager as with a dedicated one.
      My Computers


  5. Posts : 23
    win 10 Pro 64b 1909
    Thread Starter
       #5

    Well, as it turns out I should have checked the Roboform extension first. If you dig down in its description, the is a line that says that if you DON'T have Roboform for Windows installed the extension works in a standalone local mode. So I gave it a try and sure enough it does work. I don't put Roboform on our HTPC as we don't do a lot of protected browsing on it. Once the extension was installed going to D+ worked flawlessly with a full login.

    It appears that the extension just uses the password tokens stored in Edge but doesn't have the menu bar, password generator, etc. For our purposes on the HTPC this is fine since we don't do secured sites (financial etc.) on that system. Problem solved. Thanks for your help.

    BTW on my systems with Roboform for Windows I do use the lower toolbar most of the time.
      My Computers

  6. dalchina's Avatar
    Posts : 25,081
    Win 10 Pro (1903)
       #6

    Good news- they make that hard to find. Promoting Everywhere, I guess (I got 5 years of that for $25 total, so worth it..!)
      My Computers



 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:15.
Find Us




Windows 10 Forums