1.    10 Aug 2015 #1
    Join Date : Aug 2015
    Posts : 2
    Windows 10 Pro 64-Bit

    Internet Explorer 11 "This page can't be displayed"


    Hi all,

    I cant seem to gain access to the internet using IE11.

    Using Edge/Firefox/Chrome is fine, but using IE doesn't work.

    I have checked to make sure its not got any proxy setting configured (as its my home machine)

    Other than that I am out of ideas. Any help would be appreciated.

    Thank you in advance.

    Sup3r
      My ComputerSystem Spec
  2.    16 Aug 2015 #2
    Join Date : Oct 2013
    Penns Forrest
    Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3

    Close IE 11
    In Control Panel > Internet options
    Content tab > Clear the SSL state
    Advanced tab > disable both SSL 2.0 and 3.0

    Launch IE 11 and see if that helped.
      My ComputerSystem Spec
  3.    27 Aug 2015 #3
    Join Date : Aug 2015
    Posts : 2
    Windows 10 Pro 64-Bit
    Thread Starter

    Hi,

    Thank you for your suggestion, unfortunately that has not made a difference.

    SSL 2.0/3.0 were both already disable
      My ComputerSystem Spec
  4.    28 Aug 2015 #4
    Join Date : Oct 2013
    Penns Forrest
    Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3

    Long shot ... try booting into safe mode
    then restart in normal mode.

    I read something recently where this corrects an issue. I can't recall what the issue was though. That's why it's a long shot
      My ComputerSystem Spec
  5.    28 Aug 2015 #5
    Join Date : Dec 2013
    England
    Posts : 944
    Windows IP 17017

    Quote Originally Posted by Sup3r SGT View Post
    Hi,

    Thank you for your suggestion, unfortunately that has not made a difference.

    SSL 2.0/3.0 were both already disable
    Are you using your ISP's default DNS? If yes, try switching to either Open dns or google dns and see whether it fixes the problem.
      My ComputersSystem Spec
  6.    28 Aug 2015 #6
    Join Date : Oct 2014
    Posts : 338
    Win 10 Home Build 1703 64bit

    Did you try to reset IE ? InternetOptions/Advanced/Reset
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved How to remove the "send a smile/frown" on internet explorer 11
that smiley icon is a bit of annoying.
Browsers and Email
Explorer.EXE "Unspecified error" in "User's Files
Hi all, Just installed Win 10 pro on a new SSD, so a clean install. Started installing all my programs etc. Everything seems to be running well, except on thing that is annoying... I have placed a few icons on the desktop via right clicking...
General Support
Solved "Unidentified Network" - No Internet Access (LAN)
Hello. I am having a problem with my LAN wired connection showing "Unidentified Network" I have No Internet Access, and it happened after I upgraded my desktop PC from Windows 7 to 10. The first day I upgraded, my Internet worked perfectly. It's a...
Network and Sharing
Build 10162 File explorer partially "Broken".
Hi there Not a mega issue but I'm getting DOUBLE showing of my internal card reader. Shows the SDHC (Volume D) twice. 23269 Cheers jimbo
Windows Insider
Error explorer.exe "The memory could not be read"
Hi everyone! Im new on this forum. Ive been using windows 10 since this january and everything was fine until build 10130 came up. Everytime I shut down my computer I receive the following error: This is a bit annoying because I dont know...
General Support
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:30.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums