Dropped frames in Firefox after upgrading from Win7 to Win10  


  1. Posts : 3
    Windows 10
       #1

    Dropped frames in Firefox after upgrading from Win7 to Win10


    I've upgraded from Windows 7 Ultimate 64 bit (installed on my SSD) to Windows 10 Pro 64 bit.
    Since then, I've dropped frames on YouTube using Firefox at 2K@60 (VP9 308) and at 4K@24/25/30 (VP9 313).
    I used to play them smoothly without any frame lose on Firefox in Windows 7.
    I've 1080p monitor, but I prefer to play higher res, because of the video quality is much better (higher bitrate).
    Tried enabling/disabling WebRender, WebGL, Hardware Acceleration. Tried Firefox Portable, older version an reinstalling Firefox. Nothing Works...
    I've the latest Nvidia drivers, and the latest Firefox version.

    Sample videos:
    YouTube
    2K @ 60 (4K @ 60 is too much for my machine...)

    YouTube
    4K @ 24

    I can play them in VLC (in the same res) without frame lost in Windows 10, but not on Firefox...
    I have another HDD with Windows 7 Ultimate 64 bit and latest Nvidia drivers and Firefox release, and these videos play smoothly in Firefox without a single frame lost.

    My Specs:
    i5-750 @ 2.67 (stock)
    8GB RAM DDR3 1333Mhz Dual-Channel
    MSI GTX 750 Ti 2GB GDDR5
    GA-P55-USB3 MotherBoard
    Kingston A400 SSD 240GB

    Thanks
      My Computer


  2. Posts : 7,764
    windows 10
       #2

    Welcome to the forum. We need to work out if it's a ff problem or network problem. Are you using the latest ff and is ms edge the same? If you do a speed test is it the same on both windows?
      My Computer


  3. Posts : 3
    Windows 10
    Thread Starter
       #3

    No network problem, I get 200Mbps both on Windows 10 and Windows 7.
    I'm using the latest Firefox, both on Windows 10 and Windows 7.
    Edge not relevant, no frame drops but it supports up to 1080p... the problem is with higher resolutions.
    VLC plays 1440p60 or 2160p24 on Windows 10 (and also on 7) without frame lost. Same happens with Firefox on Windows 7, but not on Windows 10...
      My Computer


  4. Posts : 3
    Windows 10
    Thread Starter
       #4

    Someone? Maybe move this to Performance & Maintenance or to General Support.
    Tried Opera Portable, YouTube videos drops frames both in Windows 7 and Windows 10. (~0.5% at 1080p60, ~5% at 1440p60)

    In Summary:
    Firefox drops frames (at 1440p60 2160p24/25/30) in Windows 10, but not in Windows 7 (only rarely frame drops at 2160p30).
    I think 1080p60 and 1440p30 doesn't drop frames in Firefox on Windows 10.
    I can play 2160p30 YouTube in Firefox for Android on Galaxy S6 Edge+ without frame lost... but 2160p24 in Windows 10 drops frames...
    VLC doesn't drop frames for these videos (1440p60, 2160p24/25/30), both in Windows 10 and 7.

    Another issue I have is with DOSBox under the following settings:
    Code:
    fullscreen=true
    fullresolution=0x0
    windowresolution=0x0
    output=overlay
    mapperfile=mapper.txt
    Video and audio stuttering in fullscreen in Windows 10, but it works smoothly in Windows 7.
    However it works smoothly in Windows 7 and 10 in non-fullscreen mode, even if I change the resolution to 1728x1080. I have 1080p 60Hz monitor.

    Thanks
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:43.
Find Us




Windows 10 Forums