Chrome Weirdness


  1. Posts : 253
    Windows 10
       #1

    Chrome Weirdness


    I did a search in Google using Chrome. All the different tabs were OK but Images was not. When I clicked on Images (like, say, searching "Europe"), I got a lot of images of Europe, which of course I expected. BUT when I clicked on any of them, I just got the same search page, i.e., all the images for Europe.

    When I did the same in Opera, Google worked as expected. If I clicked on a particular image I got detail for that image.

    Not sure exactly what is going on.

    See this image:

    Chrome Weirdness-image.png

    All the images (those which are not colored squares) have web pages but clicking on them just gets me the same general search page. And then there are those blank squares.

    Also, all the specific links are actually just the main images page.

    Chrome on Android works as expected.


    RON
    Last edited by RonNewYork; 02 Oct 2019 at 22:25.
      My Computer


  2. Posts : 35,604
    Win 10 Pro (21H2) (2nd PC is 21H2)
       #2

    FWIW - works ok for me- tried google:
    maps europe
    Google Chrome is up to date
    Version 77.0.3865.90 (Official Build) (64-bit)
    Chrome Weirdness-snap-2019-10-03-09.05.20.png
      My Computers


  3. Posts : 17,832
    Windows 10
       #3

    For me, clicking on the image shows a blowup of that image...

    Chrome Weirdness-002043.png

    ... clicking on the link brings me to the web page...

    Chrome Weirdness-002044.png
      My Computer


  4. Posts : 253
    Windows 10
    Thread Starter
       #4

    Yes, and it used to do that for me as well. But now, no. All the links for the images are for the main image page. And then there are those blank squares. They appear in all searches.

    - - - Updated - - -

    The problem is solved!!! The issue was that Chrome failed to bring in all the data from the search (even if I refreshed it a few times). I did a similar search in Firefox and noticed that at first some of the lower down images were just blank colored squares, but they quickly filled in properly. I went back to Chrome, did the search again, waited, refreshed and now all the images and links are as expected.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 02:51.
Find Us




Windows 10 Forums