GMail SUPER SLOW since a week

Page 1 of 2 12 LastLast

  1. Posts : 138
    10
       #1

    GMail SUPER SLOW since a week


    Hi, first off, my PC is 9th gen, with 64GB of DDR-4 RAM. Latest Win 10.
    Not sure why but my gmail is becoming unusable... been like that for about a week now and I don't know what is causing it. I'll try to apply a label - I'll click the label button and will take over 10 seconds before the drop down opens... Or I'll click to open an email and same thing...

    I have no idea how to troubleshoot this. Using Chrome.

    Suggestions? Or, anyone else experiencing this?
      My Computer

  2. Caledon Ken's Avatar
    Posts : 20,033
    Windows 10 Pro x64 Version 1909
       #2

    Please try another browser, suggest Firefox. Do you have the same issue?

    Need to determine if this is a Chrome issue or an issue further down in system.

    Have you checked your internet speed? Speedtest.net


    Ken
      My Computer

  3. bro67's Avatar
    Posts : 8,169
    Mac OS Catalina
       #3

    Always check Google's/Alphabet's forums, regarding gmail or other google product issues. https://support.google.com/mail/answer/7074871?hl=en

    The first step is always delete cookies, history, etc, when running into issues with any website.
      My Computers


  4. Posts : 138
    10
    Thread Starter
       #4

    OK, noticing other problems... which are happening on BOTH Chrome and Firefox.
    Last few days, I can no longer play radionomy. The big image with the play button is missing. My account picture is missing.
    GMail SUPER SLOW since a week-broken-site-experience-radionomy-chrome-firefox-.jpg

    On Facebook and Instagram, images take 10 seconds to load:

    GMail SUPER SLOW since a week-broken-site-experience-instagram-firefox-.jpg

    plot thickens.. please any advice? trying to avoid having to do a clean reinstall of windows

    oh, also had a BSOD shortly after waking pc from sleep.
    system is being overclocked 36% automatically by Asus.

    NOTE: This images not loading at all or loading super slow is happening on both my desktop and my laptop.
    Speedtests indicate download of 94.45Mbps. So I have no clue whats going on.
      My Computer

  5. Caledon Ken's Avatar
    Posts : 20,033
    Windows 10 Pro x64 Version 1909
       #5

    Did you clear browsing data as bro67 suggested?


    Might try these five commands.

    Run the following five bolded commands. Use a Command Prompt(admin) or Powershell(admin)

    Do not key in info in brackets, there for your information.

    ipconfig /flushdns (Clear the dns cache)
    nbtstat -RR (release and refresh NetBIOS names)
    netsh int ip reset (reset ip settings)
    netsh winsock reset (Reset Winsock Catalog)
    netsh interface ip delete arpcache (reset Address Resolution Protocol cache)


    BSOD's are obviously not good. There is a section in the forum to address these.

    Have you run any diagnostic checks on drives or memory?

    What is being reported in "Reliability History"? Click start, type Reliability and it should pop to top of list.
      My Computer


  6. Posts : 138
    10
    Thread Starter
       #6

    ok thx Caledon Ken, is this normal?

    GMail SUPER SLOW since a week-normal.jpg

    I will deal with BSOD later, since this issue is also happening on my laptop (that is not overclocked and a lesser build).

    - - - Updated - - -

    I just disables a distraction-blocker app that I PURCHASED a few years ago called "Freedom"
    It appears to have resolved the issue of slow-loading images on Instagram and Facebook.
    Tested on both desktop AND laptop and issue was fixed on both. I trust this was also causing the Gmail slowdown.

    HOWEVER, can someone please go to http://www.radionomy.com/en/radio/CINEMIX-1/index
    and post a screenshot? I posted mine up on this thread and you will see that images are missing (incl. the big play button top left). Disabling the Freedom app did not fix this so I would like to know if it might be on their end...
      My Computer



  7. Posts : 131
    Windows 10 Pro
       #7

    Not sure what the problem is but I've had Gmail issues for about a week too. It's slow to load, when I sign out it sometimes tells me Gmail is temporarily unavailable, etc. Then it's fine for several hours, then it happens again.

    Everything is up to date and clean as can be. The only thing I'm doing different lately (by lately I mean the last few months) is using Lastpass. Don't think it has anything to do with Lastpass though as it works fine for the other sites I use it for.
      My Computer

  8. Caledon Ken's Avatar
    Posts : 20,033
    Windows 10 Pro x64 Version 1909
       #8

    Yes those fails are normal.

    I would disable lastpass extension, actually disable all extensions and see what happens.

    Third time, did you clear browsing data?
      My Computer


  9. Posts : 138
    10
    Thread Starter
       #9

    Caledon Ken said:
    Yes those fails are normal.
    Thanks, in my case, I would say that this is solved. "Freedom" app was causing the havoc.
    I have not experienced issues with Dashlane.
      My Computer


  10. Posts : 131
    Windows 10 Pro
       #10

    Caledon Ken said:
    I would disable lastpass extension,
    Will do.

    Thanks Ken
      My Computer


 
Page 1 of 2 12 LastLast

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:26.
Find Us




Windows 10 Forums