1. Joined : Aug 2015
    Posts : 65
    Windows 10
       01 Aug 2015 #1

    How do I launch edge?


    Having tried and dismissed edge, I have gone back to IE11 as my default browser, but as this freezes up on opening a webpage I though I would try Edge again just to see if it froze on the same webpages but can't find it to launch it? Not showing in the programs on start menu?
      My System SpecsSystem Spec


  2. Joined : Jul 2014
    UK
    Posts : 16,472
    Windows 10
       01 Aug 2015 #2

    I initially couldn't find it

    Make sure you are looking under M for Microsoft Edge, not just E for Edge
      My System SpecsSystem Spec


  3. Joined : Aug 2015
    Posts : 65
    Windows 10
       01 Aug 2015 #3

    paulsalter said: View Post
    I initially couldn't find it

    Make sure you are looking under M for Microsoft Edge, not just E for Edge

    I did and not there.
      My System SpecsSystem Spec


  4. Joined : Jul 2014
    UK
    Posts : 16,472
    Windows 10
       01 Aug 2015 #4

    when you went back to IE, did you just change the defaults for browsing to IE instead of Edge?
      My System SpecsSystem Spec


  5. Joined : Aug 2015
    Posts : 65
    Windows 10
       01 Aug 2015 #5

    paulsalter said: View Post
    when you went back to IE, did you just change the defaults for browsing to IE instead of Edge?
    I did but its not automatically opening links in IE its annoyingly offering a box to open in Edge instead every time.
      My System SpecsSystem Spec


  6. Joined : Jul 2015
    Posts : 51
    Windows 10
       01 Aug 2015 #6

    What do you get when you type in Microsoft Edge down in the Search box next to the Start button?

    It should show up.
      My System SpecsSystem Spec


  7. Joined : Aug 2015
    Posts : 65
    Windows 10
       01 Aug 2015 #7

    ventanasguy said: View Post
    What do you get when you type in Microsoft Edge down in the Search box next to the Start button?

    It should show up.
    No that doesn't find it.
      My System SpecsSystem Spec


  8. Joined : Jul 2015
    Posts : 51
    Windows 10
       01 Aug 2015 #8

    In the Windows 7 days I would have tried a 'restore' to see if that fixed the problem. But I have no clue as to how to do a restore on Windows 10.
      My System SpecsSystem Spec

  9.    01 Aug 2015 #9

    ventanasguy said: View Post
    In the Windows 7 days I would have tried a 'restore' to see if that fixed the problem. But I have no clue as to how to do a restore on Windows 10.
    System Restore works exactly the same.
      My System SpecsSystem Spec


  10. Joined : Aug 2015
    Posts : 65
    Windows 10
       02 Aug 2015 #10

    Due to this and several other irritating problems but mainly that I lose my internet connection and it takes 10 minutes to sort during which time restart computer doesn't work, so its back to 8.1 for me.
      My System SpecsSystem Spec


 


Similar Threads
Thread Forum
How to launch new Microsoft Edge Browser with admin rights?
Hi guys, So we have these tools that need elevated rights within IE to install correctly. In windows 7 we always did the right click, run as admin thing. However, now after the upgrade and Edge there seems to be no availability to run it as...
Browsers and Email
Battlefield 4 won't launch
Recently installed Battlefield 4 and am currently using Windows 10 build 10074. I have my OS on my C drive and my games installed on the D drive. Whenever I attempt to launch a game through battlelog (tried using Chrome and IE) it gives me the...
Gaming
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:21.
Find Us
Twitter Facebook Google+



Windows 10 Forums