Windows 10: Edge Browser - fails to open websites on certain machines Solved

  1.    04 Jun 2018 #1

    Edge Browser - fails to open websites on certain machines


    Hi all,

    I wanted to ask the forum about this issue that I`ve seen with edge for some time now, to verify its a known issue or otherwise.

    When using edge to browse to any given website, on some machines, edge simply will refuse to load the site. I can force the page to load by closing edge (not rebooting) and re-opening the browser.

    I get this behaviour on an old Haswell i5 Lenovo Helix and also on an Atom powered 2gb Xaomi Tablet.

    I don't get this behaviour (or at least its very rare) on my Surfacebook 2.

    Have seen this behaviour for some time now (well over a year, perhaps longer) and it is not remedied by a reinstall. Seems to be a bug in Edge.

    Would like to understand if others see this behaviour and if theres any known remediation.
      My ComputerSystem Spec


  2. Posts : 549
    Win 10 Pro, 18219 (Skip) 64bit
       05 Jun 2018 #2

    Just a guess, but it may be the older hardware. Another poster had the same issue with Chrome on an older system. Though it is strange with the i5 Lenovo.
      My ComputerSystem Spec

  3.    05 Jun 2018 #3

    It could be lazy dns set your dns to 1.1.1.1 & 1.0.0.1
      My ComputerSystem Spec

  4.    06 Jun 2018 #4

    Samuria said: View Post
    It could be lazy dns set your dns to 1.1.1.1 & 1.0.0.1
    Thats a really good shout, I`ll check out DNS and test it for a couple of days. .
      My ComputerSystem Spec

  5.    08 Jun 2018 #5

    Be advised that Cloudflare DNS servers *might* not work for some routers (specially some of them requiring a firmware update). At least, here in Spain.
    There are a lot of options for DNS nameservers:
    Google: 8.8.8.8
    OpenDNS: 208.67.222.222 - 208.67.220.220

    Etc...
      My ComputerSystem Spec

  6.    12 Jun 2018 #6

    Samuria said: View Post
    It could be lazy dns set your dns to 1.1.1.1 & 1.0.0.1
    This was it, not getting issues Amy more since changing dns. Thanks!!
      My ComputerSystem Spec


 

Related Threads
I have Windows 10 - version 1709 OS build 16299.192 X64 Every time I start Edge it fails - I have attached a file listing information from the event viewer. I do not have any software restriction policies. If I set up another user account I...
When I search my Yahoo mail, opened in Microsoft Edge, it gives me error: An error occurred while trying to fetch the items in this list. Retry Search works okay when Yahoo Mail is opened in other browser. Why so? I just switched to Edge...
Folks, Using Edge, if I click the "+", open a new tab, then drag that tab out to start a new browser window everything seems fine. I can open more and more tabs on that "daughter" window. If I then choose "close all tabs", they all go...
Everytime I download a pdf document within the EDGE browser, it's going to open it automatically, and then it shows this error: "Something is missing To view a PDF, you need some media functionality that you donít currently have. You can...
cant open edge browser in Browsers and Email
hi all;i cannot open the edge browser.The blue page only comes on for a few seconds then goes off.I have tried deleting my other browsers so edge is the only one but it still does the same thing.Would living in the uk have any bearing on this?Your...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 05:51.
Find Us