Edge, Firefox and IE 11 security question TLS

Page 1 of 2 12 LastLast

  1. Posts : 1,327
    Windows 10 Home x64
       #1

    TLS Security Question- Firefox,Edge and IE11


    O.K. Yesterday I ran a DISM restorehealth. When I went to reboot, I also had updates to install (that I hadn't noticed). Since then I have been unable to go to at least 2 sites due to a TLS security reason. I mean the browser(s) just flat out refuse to go there. No option to ignore. I've looked at the Microsoft help site and others seem to have this problem too. I tried every "fix" offered with no help. Internet Properties > Advanced > Security and checking/unchecking every available setting for TLS 3.0, 1.0, 1.1 , 1.2 with a restart after each try. Nothing will work. Of the 2 (at least) sites I cannot go to 1 of them is for my pre-paid debit card, which I have set to get my Tax refund on. So I guess my question is twofold. What exactly is TLS? I know O.S.'s but am pretty shaky on internet/networking issues so laymans terms please. And should I be concerned about my Debit card site?

    This issue happens with Edge, Firefox and as stated I even dragged IE 11 out of mothballs to see if any difference. The ONLY browser I have that will take me to these sites is Vivaldi. I will not use Chrome so don't know if its affected. Any ideas?

    Edge, Firefox and IE 11 security question TLS-capture.png
    Last edited by indianacarnie; 19 Feb 2018 at 06:39.
      My Computer


  2. Posts : 27,806
    Windows 10 Pro x64 Version 21H1
       #2

    Hi Indianacarnie

    Have you tried clearing all your browser data from the impacted browsers. Know your passwords if you are using cookies to "Keep me signed in". No need to delete passwords if you are storing but I would recommend cookies as part of the overall sweep.
      My Computer


  3. Posts : 1,327
    Windows 10 Home x64
    Thread Starter
       #3

    Yeah, tried that. In fact I've got Edge , my main browser, to delete them every time I close. Plus run Ccleaner at least twice a day sometimes more. I don't understand why this is happening. Its not at all bookmarked sites just two of them and they both say "secure connection" on the little lock icon in the address bar. I've done this "chrome://pippki/content/exceptionDialog.xul " and inputted the address and got this " Certificate Status : No Information Available. Unable to obtain identification status for this site. " That was in Firefox btw. Its got me scratching my head for sure. Vivaldi takes me to them with nary a wasted second but I'm one of the few who use Edge as my primary browser and its a pain to have to switch to see these sites.

    Just checked and I can't get to my V.A. HealtheVet account either. Now its starting to make me mad.
      My Computer


  4. Posts : 27,806
    Windows 10 Pro x64 Version 21H1
       #4

    Are you using bookmarks / favorites to access. Could you try just typing address into Address bar?

    If that doesn't work I would suggest this to further reset Network settings.

    Start => Settings => Network & internet => Scroll to bottom of right hand side =>Network Reset

    This will cause your system to “Forget” your wireless passwords and you may have to reset any VPN or customized communication software if you use.

    Run the following four bolded commands. Use a Command Prompt(admin) or Powershell(admin)

    Do not key in info in brackets, there for your information.

    ipconfig /flushdns (Clear the dns cache)
    nbtstat -RR (release and refesh NetBIOS names)
    netsh int ip reset (reset ip settings)
    netsh winsock reset (Reset Winsock Catalog)

    Failing that I might contact those web sites web support team and report issues. They might already have a fix as you are not likely to be the only one using Edge. MS is pushing it pretty hard.
      My Computer


  5. Posts : 1,327
    Windows 10 Home x64
    Thread Starter
       #5

    Thank you for your time. Tried all that , no joy. My debit card people say its .......... everything under the sun depending who I talk to. My sister will be home from work in a bit, I'll see if its the same on her computer. Just don't understand it.
      My Computer


  6. Posts : 1,327
    Windows 10 Home x64
    Thread Starter
       #6

    Now I have a clue at least but still need guidance. I CAN go to the sites on another computer running off the same router. Only difference is my connection is wireless and the other machine is wired. Would that have any bearing on this?

    Edge, Firefox and IE 11 security question TLS-capture.png

    This is what Firefox looks like
    Last edited by indianacarnie; 19 Feb 2018 at 15:38.
      My Computer



  7. Posts : 1,327
    Windows 10 Home x64
    Thread Starter
       #7

    Edge, IE 11 and Firefox says no encryption. Vivaldi says this:

    Edge, Firefox and IE 11 security question TLS-aaaacapture.png
    Edge, Firefox and IE 11 security question TLS-aaacapture.png
      My Computer


  8. Posts : 27,806
    Windows 10 Pro x64 Version 21H1
       #8

    It shouldn't but I guess it could. Is your wireless connection marked as Public or Private. Can't imagine them interrogating this setting but it does change your firewall settings. Is yours set to "Private"?

    Are you using any security extensions in Firefox like HTPS Everywhere. Any VPN software?

    Saw that on the encryption which would say to me your browser are looking for a more secure environment than Green Dot can provide.

    Is your sister on the same version of windows (windows key +R, type winver, enter) and the same version of Firefox?
      My Computer


  9. Posts : 1,327
    Windows 10 Home x64
    Thread Starter
       #9

    Yes and yes on Sisters Firefox and Windows. No extensions on my Firefox at all, its straight out of the box. Only installed it to check if it would get me to these sites. My connection is Public. No VPN.

    Edge, Firefox and IE 11 security question TLS-111aacapture.png

    Doesn't this say the encryption is sha256 ?

    Also , when I click the exclamation point to the left in the address bar (where the lock should be) it says "This a secure Microsodt Edge page". In Edge of course, but it still won't take me there. Just the screen in my first post.
      My Computer


  10. Posts : 27,806
    Windows 10 Pro x64 Version 21H1
       #10

    Could you set to Private and see if this changes behaviour?
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:59.
Find Us




Windows 10 Forums