Windows 10: Microsoft Edge keeps on closing after a few seconds of opening it Solved

Page 2 of 3 FirstFirst 123 LastLast
  1.    14 Sep 2015 #11

    i cannot change it back, because my Edge is closing after 2 seconds, and so I can not go to the setting menu anymore :-(
      My ComputerSystem Spec

  2. Posts : 2
    Windows 10 Pro 64
       13 Nov 2015 #12

    Finally I found a solution how the MS edge works without creating new user account. I read this from reddit and I found the solution really works for me. Microsoft Edge opens and immediately closes itself. : Windows10
    ( To admin Please delete my reply If these links are looks suspicious or something.)

    STEP 1: Delete the corrupted Microsoft Edge Folder. "C:\Users\%username%\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe"
    Delete the "Microsoft.MicrosoftEdge_8wekyb3d8bbwe" the FOLDER itself, Make sure you are logged as ADMIN before doing so.

    STEP 2: Then Launch Powershell as administrator by pressing Windows key then R, then type powershell, to launch it as admin try to right click the powershell icon at the taskbar after you launch it, the click RUN as ADMIN.

    STEP 3: Copy and paste these command: Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" -Verbose}

    Hit enter and once the command is executed,

    STEP 4: Quit powershell and restart the computer to complete the process.

    STEP 5: Open the MS EDGE to see if its working on you.

    Thanks for all the people who are hassled in these problem, finally I made great fix for corrupted ms edge in my pc.
      My ComputerSystem Spec

  3. Almighty1's Avatar
    Posts : 1,039
    Windows XP/7/8/8.1/10, Linux, Android, FreeBSD Unix
       13 Nov 2015 #13

    I had a similar problem where it would not let me login anywhere so I did what's mentioned in post #12 above and except with step 3, I used a different command:

    Add-AppxPackage -register "C:\Windows\SystemApps\Microsoft.MicrosoftEdge_8wekyb3d8bbwe\appxmanifest.xml" -DisableDevelopmentMode
    I did not do step 4.

    Except this forum has the same fix that is easier:
      My ComputerSystem Spec

  4. Posts : 181
    Windows 10 Pro x64
       07 Dec 2015 #14

    It appears this is, or it's related to, a permissions issue. This would immediately be confirmed if you receive an access denied error from one of the folders within Microsoft.MicrosoftEdge_8wekyb3d8bbwe. when trying to delete; Attempting to use takeown or icacls failed to provide access to the offending folder.

    If this occurs with anyone else, boot into WinRE and delete Microsoft.MicrosoftEdge_8wekyb3d8bbw, ensuring to empty the recycle bin on drive X:\ prior to rebooting. Once rebooted, complete steps 2 & 3 of Tsirk's instructions. Once 3 is completed, you should now be able to open Edge.
      My ComputerSystem Spec

  5.    17 Mar 2016 #15

    Elite Albino said: View Post
    I just downloaded Windows 10 yesterday night and after using it for the first time this morning, I decided to try out Microsoft Edge. Whenever I open it from the app section or the bottom tab section, it shuts down automatically after two seconds. I don't so much as get an error message, it just closes as if I pressed the close button. However, when I ask Cortana to open up some sort of search, then the window works and stays open. Does anyone seem to know what the problem is? Thank you in advance.
    I had this one as well but I do have a fix!!!
    Delete the folder c:\users\%username%\AppData\Local\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe

    where %username% is the name of the user with the issue.
    Run Powershell as administrator (right click on it and select Run As Administrator) and run the following script:

    Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" -Verbose}

    Please note that you will need local admin privileges for this to work though that may be an issue with folder permissions. I will post back if I get any further info.
      My ComputerSystem Spec

  6. Joan Archer's Avatar
    Posts : 1,659
    Microsoft Windows 10 Home 64-bit
       18 Mar 2016 #16

    Pleased I found this thread as it happened to me today, clicked on the taskbar icon and nothing, followed Brinks tutorial and did the code for all users shut powershell then restarted the machine. Back up and running, well for the time being although I've been trying out Firefox and Chrome.
      My ComputersSystem Spec

  7. Posts : 14
    Windows 10 Enterprise
       20 Apr 2016 #17

    Same problem in latest Fast build 14316. Not timer related - just bam.

    I keep going back to Chrome....
      My ComputerSystem Spec

  8. Posts : 1
    windows 10 and 7
       24 May 2016 #18

    I found some way that worked and took a min. Type control panel and click programs. Once in programs click internet explore or chrome and set as default instead of edge. when I typed in internet explore it didn't close.
      My ComputerSystem Spec

  9.    31 May 2016 #19

    This is ****ing ridicules, I have tried every fix here and my Edge still keeps shutting down and will not stay up. I get a few days of no issues, then a whole day of issues. Microsoft needs to get this shit fixed ASAP. I ****ing tired of it. This on top of all the service_exception_errors and full shutdown of computer is really pissing me off. Every fix spoken about with both items, I have tried to no avail.
      My ComputerSystem Spec

  10.    07 Nov 2016 #20

    Our solution

    We also had this problem with Edge and the Photos App opening and instantly closing when trying to open.
    This happend only to domain joined Windows 10 computers (ver. 1607) so I suspected a GPO.
    We had a GPO that was messing with the: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\NetworkProvider key
    One thing the gpo did was replacing the permissions on the Networkprovider-key which resulted in that the local security group: ALL APPLICATION PACKAGES-group was removed from the NetworkProvider-key.
    After adding: ALL APPLICATION PACKAGES-group and giving it Full Control to the: NetworkProvider-key, Edge and Photos application started working immediately.
    Of course we also removed the GPO-setting that was causing the problem :).
    Hopfully someone finds this helpful.
    Last edited by galli73; 07 Nov 2016 at 09:25.
      My ComputerSystem Spec

Page 2 of 3 FirstFirst 123 LastLast

Related Threads
Has anyone found a method to open multiple favorites in Spartan/Edge? IE always has had the ability to right click a favorites folder and choose the option to open all favorites in the folder at once. I have yet to see any discussion or find a...
I lose explorer.exe shortly after logon. If I click on Firefox or other app, it comes up and stays up, but rest of the screen goes black. No issues at all with previous W7 install. HP Pavilion, not sure of all hardware particulars. Took HD to...
Which SSD are you guys using and how much of a speed increase has it given your boot times. I bought a Samsung 850 Evo 256Gb, it takes about 10 seconds to boot to the lock screen. I am still in awe about how much faster they are.
hi. I make a little script to switch the themes back and forth coz since 9926 a custom theme F*cks up the whole windows until I call the default and restart explorer and I work on a CMD working on that, but I have one little problem. at...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:25.
Find Us