Windows 10: Windows 10 1709 failed restore point 0xc0000043

Page 1 of 2 12 LastLast
  1.    21 Oct 2017 #1

    Windows 10 1709 failed restore point bootstat.dat 0xc0000043


    Since I upgraded to Windows 10 1709 16299.19 from 1703 every new system restore point recovery fails with error:

    System restore did not complete successfully. Your computer's system files and settings were not changed.

    Details
    System restore failed to restore a file. This could happen if an anti-virus program is protecting the file. If the failure persists switch off your anti-virus and retry the restore, or perform system restore from Windows Recovery Environment. System restore failed in delayed delete operation for the file \ ?? \ Volume{9d282722-a6f7-4867-bef2-dc00dcb23c58} \ WINDOWS \ bootstat.dat. (0xc0000043)


    Just for testing I manually created some new restore points with 1709 and noticed it always fails on restore after reboot popping up this requester (ITA)



    I don't have 3rd party antivirus installed or similar tools that might lock that file, I use just Defender + Malwarebytes Pro (disabled auto-start at every Windows login). Never had issues with Restore points before.
    Since C:\Windows\bootstat.dat is a legit system boot status file (contains infos about latest successful boot etc.) generated at every boot I wonder if it can be a bug of the new OS.
    Last edited by hexaae; 08 Nov 2017 at 13:43. Reason: changed title
      My ComputerSystem Spec


  2. Posts : 71
    Windows 10 Professional (x64)
       22 Oct 2017 #2

    Were you booting to WinPE on recovery media?

    Not sure if related your issue, but I just found out that Win10 1607, is the most recent WinPE version that Reflect currently supports.

    In my case that means Storage Spaces aren't accessible now from WinPE. I guess there must have been a change to Storage Spaces in the 1709 update. Have not been able to find out what it was.

    So something in the update to 1709 is incompatible with 1607 now.
      My ComputerSystem Spec

  3.    23 Oct 2017 #3

    IsaacFL said: View Post
    Were you booting to WinPE on recovery media?
    No, a notebook PC. Upgraded from 1703 to 1709.
      My ComputerSystem Spec


  4. Posts : 13,428
    Windows 10 Pro
       23 Oct 2017 #4

    The restore fails, because whatever is accessing bootstat.dat doesn't have the right 'share access flags'.

    Have you run sfc?
      My ComputersSystem Spec

  5.    23 Oct 2017 #5

    Yes, SFC /scannow reports no integrity issues.
      My ComputerSystem Spec

  6.    23 Oct 2017 #6

    Trying to rename C:\Windows\bootstat.dat it says "The action can't be completed because the file is open in System".
    All advanced permissions and owner are correctly set compared with another PC with Windows 10 1703 (where I can rename the file).
      My ComputerSystem Spec

  7.    30 Oct 2017 #7

    News
    A friend of mine on a fresh install of Windows 10 x64 1709 reproduced the same problem: the bootstat.dat is forever locked by System task!
    This makes the restore points fail on restore-reboot.

    Generic Windows 1709 bug with restore points?
      My ComputerSystem Spec

  •    11 Dec 2017 #8

    I too have the same issue, are there any solutions?
      My ComputerSystem Spec

  •    11 Dec 2017 #9

    This is a MAJOR issue in Win 10 CFU, but unfortunately Microsoft is ignoring this big problem.

    Please, cast your vote +1 here: Feedback Hub - Windows Insider
      My ComputerSystem Spec

  •    12 Dec 2017 #10

    Well i solved with a workaround, booted in a WinPE i used the Sergei Strelec one ( i think a linux live distro would work too) and deleted the bootstat.dat file form windows folder and rebooted the system. I finally manually created a new restore point and tried to restore the system to the restore point previously made and it worked no errors.
      My ComputerSystem Spec


  •  
    Page 1 of 2 12 LastLast

    Related Threads
    I am experiencing something strange. I have Windows 10 home 32 bit version 1703 on my hp pavillion x2 and I cannot update it to 1709. Windows Update returns an error after downloading the feature update, Windows Update Assistant reports that I have...
    Windows 10 automatics updates did not end up looping until 17 January 2017 and system restore point were made regularly also taking backup from those parts of system Windows10 does not save to restore points because they are not MS products but...
    I followed the instruction to manually create a Manual Restore Point and that works fine. Then I decided to set up the task in the Task Scheduler to automatically create a restore point once daily. For some reason the task is started as it should...
    So why did Microsoft change this? If I remember correctly all previous versions would create a system restore point before doing Microsoft updates. Since 10 installed all updates that come in for me are downloaded and installed without a restore...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 09:03.
    Find Us