Windows 10: System Restore fails: AppxStaging %ProgramFiles%\WindowsApp 0x80070091


  1. Posts : 6
    Windows 10 Enterprise
       05 Mar 2017 #1

    System Restore fails: AppxStaging %ProgramFiles%\WindowsApp 0x80070091


    Hi, is there any 100% reliable solution for this problem I run into this morning? Error is occuring both from normal and safe mode. Thx in advance.
      My ComputerSystem Spec

  2.    05 Mar 2017 #2

    Hi, would you care to read and join this long thread on exactly this topic?
    System Restore fails: AppxStaging %ProgramFiles%\WindowsApp 0x80070091

    (I happened to start it- after some weeks, I found it self-corrected- perhaps after an update).

    We often recommend using disk imaging e.g. Macrium Reflect free as a more reliable and complete solution for restoring PCs, although I would agree that having System Restore can be more convenient, provided it both works and addresses the issue.
      My ComputerSystem Spec


  3. Posts : 6
    Windows 10 Enterprise
    Thread Starter
       06 Mar 2017 #3

    Ok, it is a long thread but I will go over it. I took a look yesterday without finding a 100% solution. There is some cumulative update for Windows 10 in January which could cause this problem but some folks here wrote that update was not primary cause but something else. Anyway thank you very much.
      My ComputerSystem Spec


  4. Posts : 6
    Windows 10 Enterprise
    Thread Starter
       12 Mar 2017 #4

    I tried Macrium Reflect software to create system restore point. As expected big disadvantage of third party tool like this is big image file. Furthermore I have to create restore point manually while Windows does it automatically before system change like installing updates, software, driver etc. Finally (I did not try) if I need more than one restore point just in case I would run out of disk space very quickly on partition where image file is located.
      My ComputerSystem Spec


 

Related Threads
Hi, thought I'd check if System Restore was still functional and got System Restore did not complete successfully. Your computer's system files and settings were not changed. Details: System Restore failed while restoring the directory from...
So I try to restore any point and get an error: 35772 I have turned off Malwarebytes and SuperAntiSpyware. I also did a sfc /scannow with no integrity violations. Running Windows 10 Pro 64bit... Any suggestions?
Solved System restore Error 0x80070091 in Backup and Restore
Hi, I was trying to perform a restore to fix my favorites list menu and got this error. I ran chkdsk C: /f /r /x and Windows Resource Protection did not find any integrity violations. Running WIN 10 Pro V 1607 Build 14393.693
I accidently deleted my Dark Souls 3 save file. I've put much time into the game and I've been trying to get it back for a day now. File recovery programs didn't do the job. The windows system restore should do the job, But everytimeI try to restore...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:24.
Find Us