Windows 10: System restore - weird behavior

Page 1 of 2 12 LastLast

  1. Posts : 190
    Windows 10 64-bit home
       15 Feb 2017 #1

    System restore - weird behavior


    I seem to be running into some odd behavior with system restore. I wanted to delete my old restore points and create a new one. So under system restore>configure, I selected delete. The "current usage" dropped to 0 GB. But when I closed it and went back in to restore>configure, it still showed "current usage" of 7+GB. I then selected "disable system protection" to be sure it deletes my restore points. Again, the "current usage" dropped to 0. But when I selected "Turn on system protection" it immediately said "current usage" was back to 7+GB - before I created a new restore point!

    So what's going on here? If I open ccleaner and go to tools to delete restore points (I don't do that in ccleaner but I went in just to see what it said), it shows no restore points exist currently. Yet under system restore>configure, windows is telling me 7+GB is being used. I've also restarted the PC and went through it all again with the same results. If I delete the restore points, or disable system protection, shouldn't "current usage" drop to 0 and stay there until I create a new restore point? That's how it's always been before. Am I missing something?

    For now I just made a new restore point, And it still shows 7+GB. I also typed "vssadmin list shadows" into an elevated command prompt and it listed only 1 shadow copy - the one I just made. So, it seems it's deleting the old restore points, but it's not reporting the usage correctly. And it doesn't seem that I'm gaining any space back after I delete the old restore points. So I'm wondering what's going on here.
      My ComputerSystem Spec

  2.    16 Feb 2017 #2

    Hi rivre

    Have you tried checking usage after rebooting or after totally shutting Windows down.

    If you want to totally shut Windows down, hold shift key down and click shutdown. (not restart)

    Check your space and see if either of these items updated space.
      My ComputerSystem Spec


  3. Posts : 2,395
    Windows 10.3 Home 1703 x64 (Home per choice)
       16 Feb 2017 #3

    Try to remove it manually:

    vssadmin delete shadows /for=c: /all /quiet
      My ComputerSystem Spec

  4.    16 Feb 2017 #4

    I found it easy to clean System Restore points through the Disk Cleanup. Go to the option to Clean up system files, and then Clean up for System Restore and Shadow Copies on the More Options tab.

    Click image for larger version. 

Name:	image.png 
Views:	43 
Size:	64.7 KB 
ID:	121459
    Click image for larger version. 

Name:	image.png 
Views:	43 
Size:	15.4 KB 
ID:	121461
      My ComputerSystem Spec


  5. Posts : 190
    Windows 10 64-bit home
    Thread Starter
       17 Feb 2017 #5

    Before deletion:

    current usage: 8.62 GB
    free space: 35.2 GB
    "vssadmin list shadows"
    1 shadow copy found
    "vssadmin delete shadows /For=C: /all"
    1 shadow copy deleted

    After deletion:

    current usage: 8.62 GB
    free space: 35.2 GB
    "vssadmin list shadows"
    0 shadow copies found

    Clearly there's something wrong. I just ran this a minute ago. I currently have no shadow copies according to system restore, ccleaner, and "vssadmin list shadows". Yet it still shows current usage: 8.62 GB and my free space has not gone down. What is going on here?

    Right now, system restore is disabled. It lists OFF. "Disable system protection" is ticked. Yet it still says current usage: 8.62 GB!

    Click image for larger version. 

Name:	Screenshot_1.png 
Views:	36 
Size:	14.0 KB 
ID:	121564
      My ComputerSystem Spec


  6. Posts : 2,395
    Windows 10.3 Home 1703 x64 (Home per choice)
       17 Feb 2017 #6

    Try to set the size to 320MB, that is the minimum.

    vssadmin Resize ShadowStorage /For=C: /On=C: /Maxsize=320MB
      My ComputerSystem Spec

  7.    17 Feb 2017 #7

    Shot in the dark, but when it's on is the recovery drive "on" (if you have one)? Maybe that's what is taking up the space, and not the actual OS drive.
      My ComputerSystem Spec


  8. Posts : 190
    Windows 10 64-bit home
    Thread Starter
       17 Feb 2017 #8

    Bobby Phoenix said: View Post
    Shot in the dark, but when it's on is the recovery drive "on" (if you have one)? Maybe that's what is taking up the space, and not the actual OS drive.
    I'm not sure what you mean by recovery drive, but the system restore is just on for C drive, not the other drives.

    This just happened fairly recently I think. I don't recall this ever happening before on this PC. I have no idea what would have caused this though.
      My ComputerSystem Spec


  9. Posts : 190
    Windows 10 64-bit home
    Thread Starter
       17 Feb 2017 #9

    TairikuOkami said: View Post
    Try to set the size to 320MB, that is the minimum.

    vssadmin Resize ShadowStorage /For=C: /On=C: /Maxsize=320MB
    I'll give that a shot later this evening or tomorrow and report back. I've tried setting it to 0 with the standard slider and that did nothing, but I'll try it with this command and see what happens.
      My ComputerSystem Spec

  10.    17 Feb 2017 #10

    rivre said: View Post
    I'm not sure what you mean by recovery drive, but the system restore is just on for C drive, not the other drives.

    This just happened fairly recently I think. I don't recall this ever happening before on this PC. I have no idea what would have caused this though.
    That's what I meant. When on you have the main C drive, and then other drives. I thought maybe another drive was taking up the space.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Weird behavior, possible Trojan in AntiVirus, Firewalls and System Security
Symptoms: 1. Volume icon appears with a red cross even though all sound devices are working. 2. With UAC set to default, a notification pops up at startup asking my permission to run explorer.exe 3. I can't run some programs. 4. Malwarebytes web...
Hi! I have an HP 15z aw000; ProId-VSC49AV I am hugely frustrated with Win 10! Am I allowed to say the H@te word?The colors and photos are distorted after a System Restore, and I have tried everything I can think of to fix it....
The only reason I'm using Windows at all, (and not using Linux), is Windows is the only OS that's "handicap accessible" for people with my type of eye problems. I have very poor eyesight... and without the magnifier, I can't use the computer at...
Weird behavior after update in General Support
I had a recent update of win10. After that everything is ok except when I launch applications a small window with an html file open with the buttons save and open. If I open they open in the browser but nothing happen if I save them the same because...
Weird windows 10 behavior in General Support
Just wonder if anyone has encountered these behaviors? It happens to me every time without exception: If I do a restart, the computer restarts but makes the windows 7-start sound. Upon getting to the desktop, the laptop battery meter is missing...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:34.
Find Us