Cannot backup to Macrium Reflect Free Solved

Page 1 of 6 123 ... LastLast

  1. Posts : 169
    Win 10 64 Build 1709

    Cannot backup to Macrium Reflect Free

    A couple of days ago Macrium was working just fine but then when it started it's daily backup of my system drive (incremental) it failed pretty well straight away, with this message:
    Starting Image - Friday, January 20, 2017 15:05:10
    Destination Drive: Free Space 741.95 GB
    Free space threshold: Delete oldest backup sets when free space is less than 5.00 GB

    Creating Volume Snapshot - Please Wait
    Failed: Code: 0x8004230f - Retrying without VSS Writers
    ERROR: COM call "m_pVssObject->AddToSnapshotSet((LPWSTR)volume.c_str(), GUID_NULL, &SnapshotID)" failed.
    - Returned HRESULT = 0x8004230f
    ERROR: COM call "m_pVssObject->BackupComplete(&pAsync)" failed.
    - Returned HRESULT = 0x80042301
    - Error text: VSS_E_BAD_STATE
    ERROR: COM call "m_pVssObject->AddToSnapshotSet((LPWSTR)volume.c_str(), GUID_NULL, &SnapshotID)" failed.
    - Returned HRESULT = 0x8004230f
    Gathering Windows Events - Please Wait

    I have tried imaging a partition on the main laptop drive (in above example), an image to two separate USB drives and wherever I try to save the image the same error comes up. I have read that 'Volume Shadow Copy',' Microsoft Software Shadow Provider and Com+ Event System should all be running and set to automatic, and indeed they all are. I thought I would try a System Restore but that failed straight away as follows:
    'There was an unexpected error in the Property page. System Restore encountered an error. Please try to run System Restore again. (0x81000203). Please close Property page and try again.'

    In Property page no drives were shown and it was just searching and finding nothing.

    I am way out of my comfort zone here, but it seems as though the VSS stuff isn't working as I got the same messages when running Veeam Endpoint Backup. But, when I run Aomei Backupper I can image just fine, and that is while using the Winsdows VSS option as opposed to the built- in Aomei option.

    On the subject of Aomei, I find I cannot create a startup disk to get into the menu, it just fails each time. I have produced about six Cd's all of which fail to boot the system. I used a legacy build as well rather than using Aomei built in burner.The last thing I did was to download Aomei PE Builder and while that will boot the system (sort of) I get a message telling me that wfplwfs.sys is either missing or corrupt. I did locate it so it is there.

    So, bottom line is that I have lost the means of backing up my system and the ability to access any images I already have!

    So I really don't know where to go from here other than to try some more imaging software!

    Any help will be greatly appreciated as my 81 year old brain has run out of ideas.

    Oh yes, I did a chkdsk c: /f and that went OK, and I did an sfc /scannow now which found nothing.
    Windows 10 AU (1607 OS build 14393.693)

    Last edited by bertie11; 20 Jan 2017 at 10:55.
      My ComputerSystem Spec

  2. dalchina's Avatar
    Posts : 19,882
    Win 10 Pro (1903)

    Hi a quick search for
    macrium 0x8004230f

    VSS Error: 0x8004230F - KnowledgeBase - Macrium Reflect Knowledgebase

    Unfortunately rather technical, but possible fix.

    Boot disk: hopefully you have a Macrium boot disk. Can you boot from that- or a Windows installation disk?

    It's likely someone else will come along who's seen this problem.

    And if you have purchased the product you can use Macrium's forum - which I gather is not open to free users.

    There is an ENORMOUSLY long and detailed thread here (SOLVED)
    Macrium Reflect Backup Failures
    - I think the conclusion in that thread was to fix VSS, do an in-place upgrade repair install.
      My ComputersSystem Spec

  3. Posts : 169
    Win 10 64 Build 1709
    Thread Starter

    Hi, thanks for quick reply, that link is one of many I followed without success. I also tried the VSS fix which made no difference.
    Yes, I do have a Macrium disk which does work, I can access images and I did do a system image so I'm not completely up the creek, although it feels like it! I usually have all these backup taking place on schedules so more extra work until I can get this fixed.

    It is a free Macrium which is why I'm posting here.
      My ComputerSystem Spec

  4. Posts : 169
    Win 10 64 Build 1709
    Thread Starter

    I was interested in this link :
    VSS fails due to modification by 3rd party software - KnowledgeBase - Macrium Reflect Knowledgebase

    as I used to have Acronis True Image on the system but I removed it a long time ago, I have a feeling I still have a small recovery partition on my C drive that may be Acronis, but if it is I don't know how to get rid of it. If it is that causing problems how come it has only just started playing up? The article talks about registry stuff. I have checked and there are no providers listed but there is an entry

    (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS\Providers\{b5946137-7b9f-4925-af80-51abd60b20d5} which I assume is a 'title' as there is no data given only 'Default, Type, Version and Versionid. So I don't know if that is relevant and they are empty as well.

    Scrolling down the article it says I should have (see article) and it tells me I need to enter some data. I would like to get confirmation that this is what I need to do. As I have nothing showing under providers it seems to me because part of the error message says unexpected provider error I need to have the Macrium data added there?
    What say you?
      My ComputerSystem Spec

  5. dalchina's Avatar
    Posts : 19,882
    Win 10 Pro (1903)

    Cannot backup to Macrium Reflect Free-snap-2017-01-20-16.53.40.jpg
    It does indeed seem your VSS is damaged, and the article gives the means to reinstate the key.
      My ComputersSystem Spec

  6. Posts : 169
    Win 10 64 Build 1709
    Thread Starter

    Well, that went well! First off I exported the registry, copied the keys from the text into Notepad, saved it as VSSWriters.reg then entered it into the registry, it said it had.

    But there is still no data in the Provider key. I tried this 4 or 5 times but it just doesn't show. I wonder if the text refers to an earlier Windows?

    Oh well, back to the drawing board.
      My ComputerSystem Spec

  7. dalchina's Avatar
    Posts : 19,882
    Win 10 Pro (1903)

    Did you follow the preceding step in the doct?

    To fix this problem take the following steps:

    1. Uninstall ShadowProtect
    2. Remove the registry key:
    3. Restart Windows.

    Have you then merged the reg file, then restarted?
      My ComputersSystem Spec

  8. Posts : 169
    Win 10 64 Build 1709
    Thread Starter

    I had a different take on that. I don't know what Shadow Protect is, I assume it is a program but I don't have that, and the key is not what I have in my registry.

    Then - if you don't have the registry key above then check you only have the following entry for VSS software providers in your registry key:


    I don't have anything under that key so I went for the patch as the key value in the patch is the same as in my registry {b5946137-7b9f-4925-af80-51abd60b20d5} How do I merge the reg file? I just clicked it and I got a warning which I Okayed and it then said it had been entered into the registry. No sign of it though!
      My ComputerSystem Spec

  9. dalchina's Avatar
    Posts : 19,882
    Win 10 Pro (1903)

    You have to follow the instructions. a precedes b so b works. b is merging the reg file.
      My ComputersSystem Spec

  10. Posts : 169
    Win 10 64 Build 1709
    Thread Starter

    But I can't remove Shadow Protect (what is it anyway) and I'm not sure about removing the the key (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\VSS\Providers\{24602736-bed9-4619-91b0-243447c6409c}) as I don't have that value in my registry! I reckon that is the key for Shadow Protect. It looks like I have the right key but with no values in it which the patch is supposed to fix.

    Sorry if I'm sounding a bit dim! And are there permissions involved here preventing the merge from working?
      My ComputerSystem Spec

Page 1 of 6 123 ... LastLast

Related Threads
Backup & Restore Backup and Restore with Macrium Reflect in Tutorials
How to Create and Restore a System Image Backup with Macrium Reflect To begin I quote myself from the Macrium viBoot tutorial: This tutorial will show you the basics of Macrium Reflect, how to create backup images and restore them. We will...
Solved Macrium Reflect Backup Failures in Backup and Restore
I noticed today that my daily Reflect backups had failed for the past three days, all with the same log file errors. The Reflect help file has an entry for VSS Error: 0x8004231f - Failed to Create Volume Snapshot. I started to research that,...
to create an image of my ssd which contain my windows 10 all of my programs all of my data and my images etc so I can backup and restore without the need to reinstall everything or the paid home version is better ?
I'm using macrium reflect free V6 6.1.1225 and there is a new version 6.1.1311 will my old backups work if I update it ? also which is better uninstall macrium and download the new version or just update ?
Solved Macrium reflect free compatibility in Backup and Restore
Short question are the images produced on reflect 5.1 compatible with 6.Long question: I have backed up my laptop over wireless to a network drive. Laptop is running xp and networked desktop is running win 10. I plan to change my laptop hard drive...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 04:46.
Find Us