Windows 10: System Restore fails: AppxStaging %ProgramFiles%\WindowsApp 0x80070091

Page 6 of 28 FirstFirst ... 4567816 ... LastLast
  1.    26 Feb 2017 #51

    Well here are my results...

    takeown /f "%ProgramFiles%\WindowsApps" /r /d y ran well came back with
    success for ever folder



    C:\Windows\system32>icacls "C:\Program Files\WindowsApps" /grant PAS/skeetz:F /t
    PAS/skeetz: No mapping between account names and security IDs was done.
    Successfully processed 0 files; Failed processing 1 files


    C:\Windows\system32>rd "C:\Program Files\WindowsApps"
    The directory is not empty.


    no idea where to go from here
      My ComputerSystem Spec


  2. Posts : 47
    Windows 10 v1607 Pro 64 bit
       26 Feb 2017 #52

    Hello skeetz,

    Does that mean you have repaired the System Restore?

    I have spent the night from Midnight to now (06:00 AM) installing the applications on top of a Windows 10 Home 32 bit fresh Custom installation from a media creation tool ...began yesterday. Two days until it is finished. BUT I get AppsxStaging error still from a clean installation with no registry or defragmenting work conducted. A bit frustrating!

    I need a decision....abandon it or repair it.

    Any thoughts yet? From SimonFastEddy.
      My ComputerSystem Spec

  3.    26 Feb 2017 #53

    skeetz said: View Post

    C:\Windows\system32>icacls "C:\Program Files\WindowsApps" /grant PAS/skeetz:F /t
    PAS/skeetz: No mapping between account names and security IDs was done.
    Successfully processed 0 files; Failed processing 1 files
    This section is wrong in a few ways. Don't enter PAS/skeetz.

    Use %USERDOMAIN%\%USERNAME% exactly like that.

    Actually type in %USERDOMAIN%\%USERNAME%:(F) /t and it will automatically perform the procedure using your current domain and username.
    Also you left the parenthesis off the F.
    Also you used a forward slash instead of a backslash. It must be exactly correct.

    Your first Section says ProgramFiles without a space. Put the space in.

    Go back and look at my previous post (at the bottom of Page 5) very carefully. It has to be exact. It didn't work straight away for me either until I realised what was wrong with the original code I was given.

    Your current User Domain if you are on a home computer is probably the name Windows gave your computer when it was installed. For example mine is DESKTOP-U8******\Greg. I'm not providing my full Computer name because I don't know if that is a security risk or not.
    Last edited by glivo; 26 Feb 2017 at 03:03.
      My ComputerSystem Spec

  4.    26 Feb 2017 #54

    SimonFastEddy said: View Post
    Hello skeetz,

    Does that mean you have repaired the System Restore?

    I need a decision....abandon it or repair it.

    Any thoughts yet? From SimonFastEddy.
    SimonFastEddy,

    skeetz has not fixed his system yet, but if he does it correctly he will. So can you. I would be trying the fix first before abandoning everything. What have to got to lose? If you are prepared to start over again, you have nothing to lose and only everything to gain if it works.
      My ComputerSystem Spec

  5.    26 Feb 2017 #55

    perhaps going and reading all the post on here and not "cherry picking" and you might have better luck, I restored a laptop 5x until I figured out how to fix the sound issue caused by KB3213986. All 5x I had appstaging issue and all 5x I did the steps I've outlined here. OTHER then the guy with the language issues with his command switchs, as long as your en-us all the steps work.
      My ComputerSystem Spec

  6.    26 Feb 2017 #56

    No Simon I have not fixed it yet...lol I thought I was supposed to use my user name


    I have another ? why am I not able to delete the windowsapps folder

    it says its not empty...is that going to be a problem

    I went back and looked at your post I think I have it now will
    let you know as soon as I try again


    Thank so much for your time and patience with me glivo
    Last edited by skeetz; 26 Feb 2017 at 07:32.
      My ComputerSystem Spec

  7.    26 Feb 2017 #57

    Well I don't know what happened now...these are the results I got

    1st part completed with success on all folders

    SUCCESS: The file (or folder): "C:\Program Files\WindowsApps\Microsoft.ZuneVideo_2019.17012.10301.0_neutral_~_8wekyb3d8bbwe\AppxMetadata\AppxBu ndleManifest.xml" now owned by user "PAS\skeetz".


    2nd part came back

    C:\Windows\system32>icacls "C:\Program Files\WindowsApps" /grant "%USERDOMAIN%\%USERNAME%"F) /t

    C:\Program Files\WindowsApps\Microsoft.Advertising.Xaml_10.1702.3.0_x64__8wekyb3d8bbwe\AppxBlockMap.xml: Access is denied.
    Successfully processed 72 files; Failed processing 1 files

    3rd part came back access is denied on all folders attached a copy

    rd /s "C:\Program Files\WindowsApps"

    C:\Program Files\WindowsApps\MI8FDB~1.0_X\Assets\AppList.targetsize-256.png - Access is denied.
      My ComputerSystem Spec

  •    26 Feb 2017 #58

    skeetz,
    Something is not working fully for you.

    In step 1 did your process only take ownership of the Microsoft.ZuneVideo*****\files? It should take ownership of the whole WindowsApps directory and everything in it. Maybe the results file you posted only shows me the bottom section from that process.

    In step 2 your process successfully processed only 72 files and failed on 1 in the Windows.Advertising *****\ directory. (This 1 file may or may not be a problem later.)

    When I ran this code my process changed the attributes of every subdirectory and file which was over 30,000 files. Something isn't working for you.

    Perhaps try this. Change over into the Program Files directory and perform the procedure from within it. Is your computer setup to use English? It Matters!!!

    Ensure you are in Safe Mode and Command Prompt (Admin).

    At the prompt
    C:\Windows\System32>cd C:\Program Files
    Note: (You should now have a prompt that says C:\Program Files>) Let me know if you don't.

    At C:\Program Files>takeown /f WindowsApps /r /d Y

    At C:\Program Files>icacls WindowsApps /grant "%USERDOMAIN%\%USERNAME%":(F) /t

    At C:\Program Files>rd /s WindowsApps
      My ComputerSystem Spec

  •    26 Feb 2017 #59

    OK I'm on my way to try this thank you yes its english
      My ComputerSystem Spec

  •    26 Feb 2017 #60

    I don't get why its not working for me....very frustrating...here are the results
    I couldn't get the full report for the deletion it was too log, but I captured enough
    to see the results

    I'm sorry this has turned into such a mess...I do appreciate all the time
    you have invested and your amazing patience with me glivo
      My ComputerSystem Spec


  •  
    Page 6 of 28 FirstFirst ... 4567816 ... LastLast

    Related Threads
    So I try to restore any point and get an error: 35772 I have turned off Malwarebytes and SuperAntiSpyware. I also did a sfc /scannow with no integrity violations. Running Windows 10 Pro 64bit... Any suggestions?
    Tired of Giving Permission Rights In WindowsApp Folder in User Accounts and Family Safety
    I have installed one app in Windows 10 through Win store, and I want to move one file to that app folder, but every time it is asking me, u need to perform this action - try again or cancel. I have permission to all the groups to move that file,...
    Maybe I have a misunderstanding of how System Restore works. Yesterday I uninstalled a program that I'd like to now get back. The company that made the program no longer offers archive downloads for that program in particular. Today it occurred to...
    I have set up the following in Task Scheduler:- 50990 However it does not work! Any ideas anyone? PS: How can I enable history?
    So why did Microsoft change this? If I remember correctly all previous versions would create a system restore point before doing Microsoft updates. Since 10 installed all updates that come in for me are downloaded and installed without a restore...
    Our Sites
    Site Links
    About Us
    Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

    Designer Media Ltd
    All times are GMT -5. The time now is 21:12.
    Find Us