Page 3 of 28 FirstFirst 1234513 ... LastLast
  1.    22 Feb 2017 #21
    Join Date : Feb 2017
    Posts : 11
    win10x64

    Quote Originally Posted by lx07 View Post
    Is your user name "administrators" though as @cgdsatx said to put in?


    Quote Originally Posted by cgdsatx View Post

    put your username not administrators


    smh
      My ComputerSystem Spec
  2.    22 Feb 2017 #22
    Join Date : Feb 2017
    Posts : 11
    win10x64

    Quote Originally Posted by jsdeprey View Post
    Hello, I am having this same issue.
    Recently it seemed like my PC was running some game worse than it had been a week ago and I thought maybe something had changed or I had a virus, but virus scans showed no issues.
    I normally just do a system restore when something like this happens, but I got the error "0x80070091" so I thought maybe I did have a virus because I have seen a virus kill system restore many times before. Anyway, I first did a Windows 10 reset and still had the same System Restore issues just doing a quick create and restore, so thought maybe the virus was still there.
    So then I did a full new install of Windows 10, a new System Restore seemed to work fine, but after another day and some software installs and Windows updates another System Restore test failed with same error. Check Disks look fine also.
    I have not tried the fix here yet, but I am more trying to figure out why this fix is needed on a new install, if this a windows update bug? I never noticed this before but I can not even browse "c:\program files\windowsapps" at all, is that normal, I have not really poked around Windows 10 much but I am not used to there being a directory on my own OS that I can not look in to.
    My system seems to be running fine now, and I can live without System Restore, but am totally lost how Microsoft can break things like this and not know it.
    Thanks.
    there are many files and folders that are system only

    are you trying to create a restore?
      My ComputerSystem Spec
  3.    22 Feb 2017 #23
    Join Date : Sep 2015
    Posts : 104
    Windows 10

    I wonder if MicroSoft is planning on fixing this problem any time soon. It seems to be wide spread and it's a definite problem. I'm hesitant to rename or delete the windowsapps folder as I don't want to mess anything else up.
      My ComputerSystem Spec
  4.    22 Feb 2017 #24
    Join Date : Feb 2017
    Posts : 4
    Windows 10 Pro

    Quote Originally Posted by cgdsatx View Post
    there are many files and folders that are system only

    are you trying to create a restore?
    I have never seen folders that a system administrator can not see in to before, but that seems totally messed up to me.
    I can create a restore point fine, but when I try to restore to that point it fails just like on this thread with a error "0x80070091".

    I am trying to understand is this a windows bug, I just installed windows 10 fresh and system restore worked but them after a few updates it stopped working and I get this same error again.

    Is this an issue that effects every currently updated version of Windows 10? Maybe test on other PC's to see if they are having the same issue? create restore point then right away restore to that new point and see if you get the same issue?
    Last edited by jsdeprey; 22 Feb 2017 at 22:07.
      My ComputerSystem Spec
  5.    23 Feb 2017 #25
    Join Date : Feb 2017
    Posts : 11
    win10x64

    I assume this is all because of the way windows 10 handles safe mode now, namely that it goes in to a "recovery environment" that doesn't require a "user" log in.
      My ComputerSystem Spec
  6.    23 Feb 2017 #26
    Join Date : Feb 2017
    Posts : 8
    Windows 10

    Quote Originally Posted by cgdsatx View Post
    smh
    Sorry :D
      My ComputerSystem Spec
  7.    23 Feb 2017 #27
    Join Date : Feb 2017
    Posts : 8
    Windows 10

    Quote Originally Posted by lx07 View Post
    OK, one step forward Is your user name "administrators" though as @cgdsatx said to put in? I guess not.

    chcp changes (or displays) the code page of the current job. It is slightly more complicated than this but you can think of a code page as the language. 437 is English. Anything you type after that will be assumed to be in English. This applies to input you give the shell but it doesn't invoke some sort of dictionary.

    If there exists a group object called "Utilisatuers" it will not transfer it into "Users" for you.

    I'm more than happy to but as you wish. I can't help if you don't say what you've done though.

    All these switches make a difference though. When you take ownership and assign authority you have to do it for the same person.

    You could try this:

    Change your job to English
    Code:
    chcp 437
    Take ownership for yourself
    (note there is no /a here assigning it to administrators group, the /r means recuse and the default in /d is defined as Y which is Yes in English which is the language you just told it you would write in.
    Code:
    takeown /f "C:\Program Files\WindowsApps" /r /d Y
    Give yourself full authority
    Don't change this. Just copy it exactly as it is.
    Code:
    icacls "C:\Program Files\WindowsApps" /grant "%USERDOMAIN%\%USERNAME%":(F) /t
    Specifically to not change "%USERDOMAIN%\%USERNAME%" to your PC name or your name or "Administrator" or "Administrateur" or "Administrateurs" or anything. These names are system language specific and are not affected by what language you are writing in. They are objects that exist with specific names created when you install Windows. The shell will populate it for you.

    You can see this if you enter (just for interest)
    Code:
    echo "%userdomain%\%username%"
    I really can't help any more unless you say what language you are using and give a screenshot of the error but I will say this is one reason I install Windows as en-US. It simply makes life easier.
    It worked. Thank you very much. Do I have to "give back" the ownership or something now?
      My ComputerSystem Spec
  8.    23 Feb 2017 #28
    Join Date : Jul 2015
    Posts : 3,652
    10 Pro

    Quote Originally Posted by mattws10 View Post
    It worked. Thank you very much. Do I have to "give back" the ownership or something now?
    Good news. No you do not. If everything is working then I would leave it as it is.

    If you want to though (for completeness for example) then you can do it like this...
    Code:
    icacls "C:\Program Files\WindowsApps" /remove:g "%USERDOMAIN%\%USERNAME%" /t
    This only removes the authority explicity granted to your profile which you added before. Other authorities will remain as they were. It doesn't add any "deny" authority for your profile so don't worry about that.

    You can then reset the owner to TrustedInstaller
    Code:
    icacls "C:\Program Files\WindowsApps" /setowner "NT SERVICE\TrustedInstaller"
    You can then check the authority - it should look like this (type the bit in red and then see if the other looks the same)
    Code:
    Microsoft Windows [Version 10.0.14393]
    (c) 2016 Microsoft Corporation. All rights reserved.
    
    C:\Windows\system32>icacls "C:\Program Files\WindowsApps"
    C:\Program Files\WindowsApps NT SERVICE\TrustedInstaller:(F)
                                 NT SERVICE\TrustedInstaller:(OI)(CI)(IO)(F)
                                 S-1-15-3-1024-3635283841-2530182609-996808640-1887759898-3848208603-3313616867-983405619-2501854204:(RX)
                                 S-1-15-3-1024-3635283841-2530182609-996808640-1887759898-3848208603-3313616867-983405619-2501854204:(OI)(CI)(IO)(GR,GE)
                                 NT AUTHORITY\SYSTEM:(F)
                                 NT AUTHORITY\SYSTEM:(OI)(CI)(IO)(F)
                                 BUILTIN\Administrators:(CI)(RX)
                                 NT AUTHORITY\LOCAL SERVICE:(OI)(CI)(RX)
                                 NT AUTHORITY\NETWORK SERVICE:(OI)(CI)(RX)
                                 BUILTIN\Users:(Rc,S,RD,REA,X,RA)
                                 Mandatory Label\Low Mandatory Level:(OI)(CI)(NW)
    
    Successfully processed 1 files; Failed processing 0 files
    
    C:\Windows\system32>
    HTH
      My ComputerSystem Spec
  9.    23 Feb 2017 #29
    Join Date : Feb 2017
    Posts : 3
    Windows 10

    Hey, many thanks! I am 73 years old and mostly blind now and use a text-to-speech screenreader these days to navigate and listen to the Internet, et al. I was able to follow most of this thread and resolve my problem with System Restore and the windowsApp folder. I did not use the CMD prompt however. I gained control of the folder using the prompts in Windows 10 and then was finally able to rename the folder by using cntrl-alt-del and signing out and then back in (instead of using exit and restarting in Safe Mode). Anyway, once I renamed the windowsApp folder, System Restore started working again and a new WindowsApp was created with all the apps restored. Many thanks for leading me in the right direction to fix this problem without needing to do a full system image restore. You are the best!!!
      My ComputerSystem Spec
  10.    23 Feb 2017 #30
    Join Date : Sep 2015
    Posts : 104
    Windows 10

    After this fix is applied does System Restore continue to work indefinitely or does it mess up again?
      My ComputerSystem Spec

 
Page 3 of 28 FirstFirst 1234513 ... LastLast


Similar Threads
Thread Forum
System Restore Fails Error 0x80070005
So I try to restore any point and get an error: 35772 I have turned off Malwarebytes and SuperAntiSpyware. I also did a sfc /scannow with no integrity violations. Running Windows 10 Pro 64bit... Any suggestions?
Backup and Restore
Tired of Giving Permission Rights In WindowsApp Folder
I have installed one app in Windows 10 through Win store, and I want to move one file to that app folder, but every time it is asking me, u need to perform this action - try again or cancel. I have permission to all the groups to move that file,...
User Accounts and Family Safety
Solved System restore doesn't restore uninstalled software.
Maybe I have a misunderstanding of how System Restore works. Yesterday I uninstalled a program that I'd like to now get back. The company that made the program no longer offers archive downloads for that program in particular. Today it occurred to...
Software and Apps
Solved Task Scheduler fails to schedule Restore Point Creation
I have set up the following in Task Scheduler:- 50990 However it does not work! Any ideas anyone? PS: How can I enable history?
Backup and Restore
System Restore not making restore point before updates.
So why did Microsoft change this? If I remember correctly all previous versions would create a system restore point before doing Microsoft updates. Since 10 installed all updates that come in for me are downloaded and installed without a restore...
Backup and Restore
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:24.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums