Windows 10: System Restore fails: AppxStaging %ProgramFiles%\WindowsApp 0x80070091

Page 22 of 23 FirstFirst ... 1220212223 LastLast
  1.    5 Days Ago #211

    possom2009 said: View Post
    Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB4013429) is downloading, but I see no mention about sysrestore.
    I'm thinking this is could be complex as it involves VSS so it may take MS some time to test and be sure its really fixed. It may come along with the Creators Update in April or they may defer it until after that settles in.
    Last edited by SoFine409; 5 Days Ago at 20:35.
      My System SpecsSystem Spec

  2. Bree's Avatar
    Posts : 1,772
    10 Home x64 (1607), Pro x86 (1511 & 1607)
       5 Days Ago #212

    possom2009 said: View Post
    Cumulative Update for Windows 10 Version 1607 for x64-based Systems (KB4013429) is downloading, but I see no mention about sysrestore.
    KB4013429 has been superseded by Cumulative Update KB4015438 for Windows 10 v1607 Build 14393.969 which fixed MPEG-2 crash issues introduced in KB4013429. I had hoped it would have quietly fixed this one too, but on testing system restore in 14393.969 it still fails with the AppxStaging error.
      My System SpecsSystem Spec

  3. dencal's Avatar
    Posts : 1,695
    W10 Pro + W10 Preview
       3 Days Ago #213

    Methinks its a false positive....have performed this operation several times on both Insider and public released versions.
    If System Restore is turned on Windows automatically does a Restore point on each update.
    Have just done a restore, which shows your pointed out flaw, then a scannow, and a dism, no fault being found, afterwards checked all Apps plus updated Apps
    Everything appears to be working normally.
    Attached Thumbnails Attached Thumbnails sys res.jpg   AWPOWER.png  
    Last edited by dencal; 3 Days Ago at 11:41. Reason: posted wrong Powershell
      My System SpecsSystem Spec

  4.    3 Days Ago #214

    dencal said: View Post
    Methinks its a false positive....have performed this operation several times on both Insider and public released versions.
    If System Restore is turned on Windows automatically does a Restore point on each update.
    Have just done a restore, which shows your pointed out flaw, then a scannow, and a dism, no fault being found, afterwards checked all Apps plus updated Apps
    Everything appears to be working normally.
    https://www.tenforums.com/attachment...-a-sys-res.jpg
    https://www.tenforums.com/attachment...-a-awpower.png
    What do you mean by false positive? I assure you that it's broken for me and all the other folks who have posted here, and probably everybody else too.
      My System SpecsSystem Spec

  5.    3 Days Ago #215

    JSheridan said: View Post
    What do you mean by false positive? I assure you that it's broken for me and all the other folks who have posted here, and probably everybody else too.
    Same here. I even checked programs that I installed after the restore point. They're still there, when they should have been removed.
      My System SpecsSystem Spec

  6.    3 Days Ago #216

    I tested system restore on insider build 15063 and it worked.

    Mind you I have uninstalled most apps from WindowsApps anyway (and the upgrade doesn't put them back) so it wasn't a very good test. I'll do a clean install test later unless someone else has already tested it on this build.
      My System SpecsSystem Spec

  7.    3 Days Ago #217

    Microsoft Community Forum has published a far less daunting procedure for the renaming of the WindowsApps Directory. It is done in the Recovery Enviroment (RE) and allows the takeown and icacls commands to be skipped. I have asked if step 2 uses any administrator user account password or the inbuilt, inactive System Administrator password. Most people who have trouble with the other commands probably don't know the System Administrator password.

    Option 2 in the second post on this page. https://answers.microsoft.com/en-us/...0-a1544631adb6

    Important: There are 2 things you should do first BEFORE you perform this procedure.
    1/ Create a Backup
    2/ Make sure you have a Restore Point to use in the last step of this procedure. If you don't you will have problems.
      My System SpecsSystem Spec

  8. Bree's Avatar
    Posts : 1,772
    10 Home x64 (1607), Pro x86 (1511 & 1607)
       2 Days Ago #218

    SoFine409 said: View Post
    I'm thinking this is could be complex as it involves VSS so it may take MS some time to test and be sure its really fixed. It may come along with the Creators Update in April or they may defer it until after that settles in.
    A new update, only available from the update catalog, has just been issued.
    Cumulative Update KB4016635 for Windows 10 v1607 Build 14393.970

    As it addresses store apps issues...
    Key changes include:
    • Addressed a known issue with KB4013429 that caused form display issues with CRM 2011 on Internet Explorer 11.
    • Addressed the issue with KB4013429 that prevents users from updating apps from Windows Store with 0x80070216 error.
    https://support.microsoft.com/en-us/help/4016635

    ...could this be the one?
      My System SpecsSystem Spec

  9.    2 Days Ago #219

    I think I'll hold off on installing it for a while. That way I get to keep the sweet hope that this might be "the one" for a little bit longer.
      My System SpecsSystem Spec

  10. dencal's Avatar
    Posts : 1,695
    W10 Pro + W10 Preview
       2 Days Ago #220

    Bree said: View Post
    A new update, only available from the update catalog, has just been issued.
    Cumulative Update KB4016635 for Windows 10 v1607 Build 14393.970

    As it addresses store apps issues...
    https://support.microsoft.com/en-us/help/4016635

    ...could this be the one?
    Unfortunately this update does not get rid of the error notification....see attachments.
    I will if requested prove my earlier post "False Positive" by doing a scannow and dism. to confirm.
    Attached Thumbnails Attached Thumbnails 2017-03-23_15h16_18.png   2017-03-23_15h18_07.png  
      My System SpecsSystem Spec


 
Page 22 of 23 FirstFirst ... 1220212223 LastLast

Related Threads
So I try to restore any point and get an error: 35772 I have turned off Malwarebytes and SuperAntiSpyware. I also did a sfc /scannow with no integrity violations. Running Windows 10 Pro 64bit... Any suggestions?
Tired of Giving Permission Rights In WindowsApp Folder in User Accounts and Family Safety
I have installed one app in Windows 10 through Win store, and I want to move one file to that app folder, but every time it is asking me, u need to perform this action - try again or cancel. I have permission to all the groups to move that file,...
Maybe I have a misunderstanding of how System Restore works. Yesterday I uninstalled a program that I'd like to now get back. The company that made the program no longer offers archive downloads for that program in particular. Today it occurred to...
I have set up the following in Task Scheduler:- 50990 However it does not work! Any ideas anyone? PS: How can I enable history?
So why did Microsoft change this? If I remember correctly all previous versions would create a system restore point before doing Microsoft updates. Since 10 installed all updates that come in for me are downloaded and installed without a restore...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 06:16.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums