Windows 10: Still can't get DISM restore health to work ?? Solved


  1. Posts : 81
    Win 10 Pro 64bit - Build
       30 Oct 2016 #1

    Still can't get DISM restore health to work ??


    Been trying for weeks to get the DISM to work despite lots of help in forums...here's my latest discovery:

    I am running : Dism /Online /Cleanup-Image /RestoreHealth /Source:wim:H:\sources\install.wim:1 /limitaccess

    Hopefully this is correct...but my mounted new current image of the iso file is mounted on my H: hhd...(pre-mount jpg attached. However when I go to the mounted directory to verify the mount location...explorer is showing the mounted image as on my DVD drive "N" as the pics attached show....

    1) is my dism command correct above...and
    2) why does the mounted image point to the dvd N) instead of the iso file location HDD (H) ?

    Is this why I'm am repeatedly getting wim file (source) not found ?

    Is this normal ?

    Thanks all....

    TiminAz
    Attached Thumbnails Attached Thumbnails mounted.jpg   pre-mount.JPG  
      My ComputerSystem Spec

  2.    01 Nov 2016 #2

    Hi, I'd suggest you try Kyhi's excellent tool which handles using an installation DVD or a mounted iso.

    It makes the task rather easier.
    Windows 10 Recovery Tools - Bootable Rescue Disk - Windows 10 Forums
    - see post #2 for a tool which helps with DISM commands and others in a useful sequence.
    I've just used it with a Win 10 1607 DVD.

    (Post #1 is a good bootable recovery disk with utilities).

    Your particular difficulty might be that you don't actually have a WIM file - DVD's generated via the media creation tool give you an ESD. Kyhi's tool deals with that.

    There is a tutorial in the Tutorial section about converting ESD-> Wim if I recall.
      My ComputerSystem Spec

  3.    01 Nov 2016 #3

    Try instead this commands:
    if you have a Install.WIM : DISM /online /cleanup-image /restorehealth /Source:N:\sources\install.wim /limitaccess
    if you have a install.ESD : DISM /online /cleanup-image /restorehealth /Source:N:\sources\install.esd /limitaccess
    This commands are working for me.
      My ComputerSystem Spec


  4. Posts : 81
    Win 10 Pro 64bit - Build
    Thread Starter
       01 Nov 2016 #4

    Success !!!

    To all who helped on this...my problem has been completely corrected...but I can't say 'solved'...since I don't know exactly what happened. What I did is go back to a complete Acronis tib system backup of my Windows Pro C: drive system from July 1, 2016

    After start up...I just left everything alone and low and behold...everything...including Anniversary Update, downloaded and installed without a hitch. Last 24 hours of testing/using also went without a hitch...Updates - Firewall issues gone - and all my accessories and options respond and are working fine...even Cortana is zipping along.
    Obviously immediately saved another current Acronis image and backed that up twice to two different drives ?
    Wish I could report what worked...but glad I'm up and running with (so far) a new Win 10 Pro 64bit system and Anniversary update that is functioning great !!

    Many thanks to all that helped....

    TiminAz
      My ComputerSystem Spec


 

Related Threads
Solved I cannot get DISM to work! Help please! in Performance & Maintenance
Nevermind. A user on another site solved it for me by providing me the correct ISO.
If I backup my drivers on my Win 10 Pro X64 system using Dism /Online /Export-Driver /Destination:D:\Lenovo_Drivers how do I restore them after I do a clean install? I've seen lots of tutorials on how to backup but nothing on how to restore...
Solved Error DISM restre health in Performance & Maintenance
I've tried using image_health because sfc /scannow wouldnn't fix my problems. When I pressed 1 it ran ok. But when I pressed 2 I got this: Error: 0x800f081f The source files could not be found. Use the "Source" option to specify the...
scannow and dism don't work right in Performance & Maintenance
I ran sfc/scannow (trying to diagnose a sleep problem) and it found irreparable files, and I ran it again in safe mode, and again, irreparable. I ran dism and it couldn't access the source files. (Afterwards, I checked windows update, and it says...
No idea what is going on here. Dism was returning errors so I did a bunch of things literally spent 3 hours doing standard stuff. Finally found old usb stick so I could do a refresh install overnight. . Keeping apps etc but then when I woke up and...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Š Designer Media Ltd
All times are GMT -5. The time now is 08:07.
Find Us