Windows 10: rsync server backup, but now created folder I can't delete / view!

  1.    25 Oct 2016 #1

    rsync server backup, but now created folder I can't delete / view!


    I'm trying to get a rsync scheduled task setup on my PC, that will do a rsync on my server and grab the files. So after a lot of hassle (getting the SSH key-pair working), I've finally got it going. My issue though, is that I was running this:

    rsync -vcr -e "ssh -l root -i /cygdrive/F/ServerBackups/foo" "" "/cygdrive/F/ServerBackups/Foo"
    For some reason that has done some weird stuff with the permissions. After reading up a bit on it, I found I should have really used the --chmod=ugo=rwX flag as well, to set the permissions. This is what I'm using now:

    rsync -vcr --chmod=ugo=rwX -e "ssh -l root -i /cygdrive/F/ServerBackups/foo" "" "/cygdrive/F/ServerBackups/Foo2"
    That works fine, and I can read Foo2, and all its contents. The proble now is getting rid of the "bad" one!

    Andy@Andy-PC /cygdrive/F/ServerBackups
    $ chmod 755 Foo
    chmod: changing permissions of 'Foo': Permission denied
    In Cygwin, here is this chmod's of that folder:

    Andy@Andy-PC /cygdrive/F/ServerBackups
    $ ls -lh
    -rw-------+ 1 Andy Andy 1.7K Oct 25 10:13 foo
    -rwxr-xr-x+ 1 Andy Andy 0 Oct 25 08:57 known_hosts
    d---rwxrwx+ 1 Andy Andy 0 Oct 25 10:21 Foo
    drwxrwx---+ 1 Andy Andy 0 Oct 25 10:32 Foo2
    Here is the permissions of the folder that I'm having issues with:

    Click image for larger version. 

Name:	2016-10-25 at 10-41-02.jpg 
Views:	12 
Size:	24.3 KB 
ID:	107480

    It has read-only ticked, so I have tried to remove that:
    Click image for larger version. 

Name:	2016-10-25 at 10-40-48.jpg 
Views:	12 
Size:	30.4 KB 
ID:	107479

    but then I just get this nasty error:
    Click image for larger version. 

Name:	2016-10-25 at 10-41-26.jpg 
Views:	12 
Size:	12.7 KB 
ID:	107481

    The folder is only a couple of hundred Mb's, but I'd still like to try and get rid of it if I can, so I can do some housekeeping =)T


      My ComputerSystem Spec

  2. Posts : 4,611
    Mac OS High Sierra 10.13.5
       25 Oct 2016 #2

    You are talking about stuff that is advanced user, not something for the faint of heart, since it can royally screw up the system you are wanting to back up. See The Non-Beginners Guide to Syncing Data with Rsync Cloud Storage for Offsite Backups (Mentions about Server 2008, but will work with regular Windows) rsync + ssh + cygwin - full and TOTAL instructions - Windows 2008 R2 - YouTube More info rsync

    Just know that you can hose up your Windows system and the device that you are using for the storage if you do this wrong. Use Macrium backup on your windows machine before you mess around with Rsync.
      My ComputerSystem Spec

  3.    25 Oct 2016 #3

    Thanks bro :) I actually have it all working (its backing up 6 of my sites now perfectly, and is set to run in the morning at 9am, after the server backups have finished. The only issue I have, is removing the "incorrect" one I did to start with. Maybe I'll just leave it, as its only a few hundred mb (on a 500gb SSD), so not wasting too much space. I was just hoping there was a simple fix :)

      My ComputerSystem Spec

  4. Posts : 4,611
    Mac OS High Sierra 10.13.5
       25 Oct 2016 #4

    I sent a message to Jimbo45 regarding this. He has been doing a lot of advanced stuff with Linux that I do not get into. With rsync there really is not a simple fix, because of how complex it is to make it work properly. We are talking old school tech, that rsync came out five years after Linus gave us Linux.

    If I do stuff with a test server running any form of Linux, I use webmin to let me do stuff that way.
      My ComputerSystem Spec

  5.    26 Oct 2016 #5

    Cool. thanks! Yeah it's tricky using a wrapped like Cygwin to emulate a *nix backend so that it can run. It's worked really well for me so far (all my sites are backed up locally, and it's doing the morning backup now, and only downloading the changed files :))


      My ComputerSystem Spec


Related Threads
How to Backup and Restore Folder View Settings in Windows 10 In Windows, you can change the template, column width, Group by, Sort by, and layout view of the content of your folders to how you like. This tutorial will show you how to backup...
My DELL Latitude laptop came with Windows 8.1 Pro x64 on it. I decided that I want to upgrade it to Windows 10 Pro x64. Before I did anything I used DELL Backup and Recovery to create a flash drive so I can always restore the PC back to factory...
I'm using macrium reflect free V6 6.1.1225 and there is a new version 6.1.1311 will my old backups work if I update it ? also which is better uninstall macrium and download the new version or just update ?
Unable to delete users I created in Windows 10 in User Accounts and Family Safety
I did NOT sign up with Microsoft. I set up my logon, and then tried to set up a single user without a password. It all failed and now I have 2 extra users show up when the login screen appears. I want to DELETE the 2 extra users, but can't. I go to...
Solved Cannot delete User Pin once created in User Accounts and Family Safety
Win 10 Home With multiple Users, it appears that once you have created a pin number, you cannot go back and no longer use a PW or PN. Must create a PW first and then you can create a PN You can delete the PW but not the PN
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 09:36.
Find Us