Windows 10: System Restore is not functioning

Page 1 of 2 12 LastLast
  1.    09 Sep 2016 #1

    System Restore is not functioning


    I open the System Properties window, select System Protection tab. My drive never comes up and all the option boxes are grayed out. Can anyone help?Click image for larger version. 

Name:	systemrestore.PNG 
Views:	60 
Size:	23.5 KB 
ID:	100556
      My ComputerSystem Spec


  2. Posts : 2,565
    10 Home x64 (1703) (10 Pro on 2nd pc)
       09 Sep 2016 #2

    Have a look at Services (type services in the Cortana search box to find it). The System Restore seems to require 'Volume Shadow Copy' and 'Windows Backup' services to be running. They are set to 'Manual' on my machine and will start whenever I open the System Protection tab in the System Properties window. Make sure yours aren't set to 'disabled'.
      My ComputersSystem Spec

  3.    09 Sep 2016 #3

    If you download Macrium Reflect Free (this is a backup software that like System restore points and so on uses VSS). VSS is the Volume Shadow Copy Service which is used to make Windows restore points and is also used by (pretty much) all other backup software.

    It has an option to fix the normal (I mean common) VSS errors by stopping and starting services, checking the registry and so on.

    You need not use it (although I do). Try downloading it (forget the PE option if you are not interested in using it for backups) and then take this option:

    Click image for larger version. 

Name:	Capture.PNG 
Views:	56 
Size:	30.0 KB 
ID:	100560
      My ComputerSystem Spec

  4.    09 Sep 2016 #4

    TheSys said: View Post
    I'm going to agree that you're probably using a service that uses Volume Shadow Copy Service. Because Windows System Restore is fickle, there's not many other options other than uninstalling the otherwise more important backup solutions.

    My recommendation: Replace Windows System Restore with a 3rd party alternative like either Comodo Time Machine or RollBack Rx. Either will work just fine.
    Comodo uses VSS (see here COMODO Backup News / Announcements / Feedback). Comodo is simply a worse backup solution than Windows, Macrium or any of the other providers that use the exact same VSS technology..

    Rollback makes it's own database. It isn't terrible software but has its own little niche use (rolling back after installing something). Considering that there have been VMs for the last 20 years this niche is rather debatable. Their software is therefore basically pointless.

    If you want a snapshot then you use VSS. Acrionis tried to write their own VSS provider but it didn't work and they gave up.

    If you want a decent backup software for home you use Reflect. Possibly Eauseus or Paragon (both of which also use VSS) but not these two.

    Honestly, no. I'd recommend almost anything else really.
      My ComputerSystem Spec

  5.    09 Sep 2016 #5

    I appreciate all the responses. I wish I could make this shorter but don't know how so I beg your indulgence.

    I checked "Services" and found Volume Shadow Copy and Windows Backup both on "Manual." I started in SAFE mode, used that Troubleshooting option and clicked on System Restore. It opened and all my points were there. I exited and just restarted normally and after doing so, I was able to open System Restore, as normal. Whether it will remain that way I don't know.

    I am definitely interested in Macrium. That's what started my whole mess. I was having some problems with it and what I decided to do as a fix is what got me into trouble. I had it scheduled to keep 3 full backups and 10 differentials. However, it kept making way more full backups and only a few differentials, some of the differentials were stored on the external hard drive (which I can no longer access) and some were going to a folder called "Reflect" in Documents. I decided I must have done something wrong and was going to remove all the previous backups, uninstall using RevoUninstaller, then re-install and start over. The first thing I did was go to the external HD and delete all the backups ... then ... I uninstalled Macrium and restarted and woke up to my nightmare. I could no longer access my external HD where the backups had been stored. I also have lots of pictures and such on that external. In trying to find a solution through Googling it was suggested to go into Device Manager, click on the external and uninstall. Then Windows was supposed to install a new driver, etc. Only it didn't happen.

    It's an Iomega drive. I plug it in and the light comes on. It doesn't make any noise but when I hold it I can feel that it's running. Before I followed those instructions to Uninstall, It was appearing under Device Manager and in my Computer, but I couldn't access it. I got the message that the "parameter is incorrect." When I unplug it from my computer, or plug it back in, it makes the sound that hardware has been added or removed, but it doesn't show up. I'm willing to purchase a new drive but I want to get the information off this one I have. Can you guys/gals help me with this at all? I would so much appreciate it if you could and would.

    And do you know why what I did with Macrium caused this problem? I'd like to know because I also have it on my laptop and I don't want this happening again. Was I wrong in deleting the backups? I would think I could delete those any time I want without a problem.
      My ComputerSystem Spec

  6.    09 Sep 2016 #6

    You have 2 (possible) issues here.

    1. VSS isn't working
    2. Your Iomega drive isn't working.

    I've had problems with both of these.

    First thing you have to understand is that they are not necessarily connected.

    Let us try 2 things.

    1. Check VSS. Go to an administrator powershell window (if your Windows is in English then press and X then type A.

    Type the following:
    Code:
    powershell
    checkpoint-computer "A Test"
    If that works then your VSS is working.

    2. Check your Iomega. I have a USB-3 Iomega that works with Windows 7 and MacOS. It doesn't work with Windows 10. Try copying some big file to it and see if it works. Mine doesn't - I can read from it but if I copy a big file it hangs up. That is a separate problem.
      My ComputerSystem Spec

  7.    09 Sep 2016 #7

    Does the VSS test have something to do with system restore? When I do it I get a long paragraph that starts out by stating that a new restore point can't be created because one was already created within the past 1440 hours.

    I can't add anything to that external. I just get a red circle with a line through it and everything freezes up. I turn it on and get the sound indicating that new hardware has been added, things flash a couple of times and then it once again appears in Device Manager and Computer (It is drive L) but then it turns off. When I monkey with it there ends up a gold triangle on all or some of my portable drives and the message with that is that Windows stopped the device because it reported a problem. (Code 43) ... and yet, on usb flash drives marked Patriot and M, I can still open those and access the things I have copied to them. It's all pretty confusing for me.

    Click image for larger version. 

Name:	DevMgr Portable dev..PNG 
Views:	46 
Size:	5.1 KB 
ID:	100595
      My ComputerSystem Spec

  8.    09 Sep 2016 #8

    Nikilet said: View Post
    Does the VSS test have something to do with system restore? When I do it I get a long paragraph that starts out by stating that a new restore point can't be created because one was already created within the past 1440 hours.
    Yes it does - VSS (the volume snapshot service) is how system restore points are made.

    I forgot though (so egg on my face) that with powershell you can only make one every 24 hours. You can try and make one manually through the GUI as is doesn't have that restriction. I think that looks OK though.

    Nikilet said: View Post
    I can't add anything to that external. I just get a red circle with a line through it and everything freezes up
    Me too. Your drive (like mine) tries to attach via UAS (USB Attatched SCSI). It doesn't work and MS don't want to fix it. Neither do Iomega (now owned by Lenovo).

    You can use the drive on a USB 2 port (if you have one). Otherwise you may as well give it to someone else who uses Windows 7 or OSX or buy a SATA --> USB 3 cable.
      My ComputerSystem Spec

  9.    09 Sep 2016 #9

    I have already decided to buy a new drive, but do you think if I take this to a computer tech they will be able to get my data off from it? Man I hate to lose all the stuff I had saved on this thing.

    Also, you never mentioned why what I did with Macrium caused the drive to be corrupted, etc. That drive was working beautifully before I went through that process of removing Macrium and deleting all the backups, etc. I've had this drive on this computer for quite awhile and right up to yesterday everything was fine. I don't even blame Macrium. I blame me for doing something wrong but I don't know what it was. That's what I hate about Macrium. If you are a user like me who's going to have questions that aren't in the knowledge base, because I don't understand some of it, you can't get any more help unless you want to pay a whopping $70 for a license.

    P.S.
    I think my first problem is worrying I've done something really egregious and probably ruined everything. My 2nd place problem is patience ... I guess. I walked into my computer room shortly after posting the above and I was at the sign-in screen. So after I got booted up again I checked the task scheduler to make sure chkdsk had completed and wasn't still sitting in there. Then I ran the chkdsk c: again and this time no errors were found.

    At this point I think I'm ready to just purchase a new external. And I think I've learned that from now on if I am going to mess around with something that I'm not sure of how to run I'll make sure to have my external disconnected.

    Thanks for all your patience, help and broad shoulders!!!
    Last edited by Nikilet; 09 Sep 2016 at 21:56.
      My ComputerSystem Spec

  10.    09 Sep 2016 #10

    I absolutely don't think you did anything wrong and I don't think Macrium had anything to do with it.

    Don't pay anyone to get your data back - you don't need to it is all still there.

    What you should do (if you can) is buy a new drive and then ask someone (perhaps a friend who is using OSX or Windows 7) to copy your data from the old drive to the new one.

    The only problem is some old USB 3 drives don't work with Windows 10. That was my problem - and I think yours also.

    All you need is to copy it to a drive you can read. If you buy a new drive from a shop then they will copy your old data for free I'd expect. Certainly if it was my shop I would.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
I receive this error message in the Windows System log regularly. Device Manager does not show any malfunctioning devices. Apparently csvol service is part of HFS+ for Windows. This is a program that allows reading of HFS+ file systems on...
system restore in Backup and Restore
if I do a system restore before the time I downloaded a program will all of the program icons that were leftover after I deleted the program be gone
Maybe I have a misunderstanding of how System Restore works. Yesterday I uninstalled a program that I'd like to now get back. The company that made the program no longer offers archive downloads for that program in particular. Today it occurred to...
I have updated to Windows 10. After scouring the internet for options, I need to turn to ask the experts. Movies play, songs play... even the system sound previews play when I pick a sound scheme. But under normal computer operation, no system...
So why did Microsoft change this? If I remember correctly all previous versions would create a system restore point before doing Microsoft updates. Since 10 installed all updates that come in for me are downloaded and installed without a restore...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:31.
Find Us