Windows 10: Data Backup Issues Solved

Page 1 of 3 123 LastLast
  1.    19 May 2016 #1

    Data Backup Issues

    Hi all

    I'm a desktop engineer by trade to start with so am very familiar with most things that my topic covers. But this one issue has me a little bamboozled lol

    In my work, I never experience this so I believe it is down to permissions etc...

    The problem is...Sometimes I fix machines at home. In doing so, general procedure, backup users data and reimage the machine depending on the problem.
    I will backup the users data to my machine slaving their drive into my PC using sata 3. Diskpart their drive, clean it, repartition and copy the Windows install to the drive then boot the drive straight into the installer.
    Install Windows, run all updates, get fully functional.

    Now the part where it all falls down, and this doesn't happen always, just sometimes.
    Put their drive back into my PC slaved on sata again, Either create a folder on the C drive or use a pre created folder I made whilst the laptop was booted called data or backup or something similar.
    Dump their files back into that folder. Eject the drive from my machine properly (hot swap all setup correct), put the drive back in their laptop. Boot said laptop.
    Navigate under Windows Explorer to the folder I put the data in...And there is NOTHING to be seen. No files, no hiddens, nothing. The data has GONE. But the space is still showing as used up under the main Explorer drive sizes.
      My ComputerSystem Spec

  2.    19 May 2016 #2

    So...Any ideas WTF is going on.
    A few hints for reference: -
    1) This has happened to me on and off for the past few years using all forms of Windows since at least Windows 8 x64, probably 7 too but that was too long ago to remember.
    2) It doesn't always happen, it possibly even seems drive dependant as Most times it goes without hiccup. Although I have tried alternate drives before to rule this out and had the same scenario.
    3) If I slave the drive back into my own PC after this happens, sometimes the data doesn't show up again here too. And I always validate the data and check its navigatable before I disconnect it from dumping it back onto the users drive.
    4) This has happened to me independent of all components, I now have a completely brand new PC compared to when this first happened to me. New drives, board, psu, the lot.
    5) In general, I overclock my systems. My last one was quite overclocked but my current given I only have a i3-4150 currently, I let my board auto OC it to a 102Mhz base clock instead of the stock 100.2. Other than that, it was running stock. I've always kind of suspected it may be to do with the OC'ing but not really sure why. If not OC'ing then this surely must be permissions in some way.

    I really hope someone can answer because this problem has annoyed me for years, for example, it literally just happened, after copying 108GB on a machine I really wanted to get out the door as soon as it finished, now I'm resorting to copying the data through my LAN. A bit tedious on sizes like this and sometimes much more. Been known to have to backup over a TB before. Someone save me!
      My ComputerSystem Spec

  3. badrobot's Avatar
    Posts : 5,135
    Win 10 Pro x64
       19 May 2016 #3

    Is there a drive letter assigned to the drive?

    Also, loading and unloading hard drives can cause hard drive issues at random so you might wanna run check disk on the hard drive in question.
      My ComputerSystem Spec

  4.    19 May 2016 #4

      My ComputerSystem Spec

  5.    19 May 2016 #5

    badrobot said: View Post
    Is there a drive letter assigned to the drive?

    Also, loading and unloading hard drives can cause hard drive issues at random so you might wanna run check disk on the hard drive in question.
    Yes, it appears completely normal for all intents and purposes. I can navigate the drive fully.
    I diskpart the drives everytime myself, first running a clean command, then I create a primary parition formatted as ntfs, assign a drive letter and make the partition active so that I can boot into the OS installer from the drive itself.

    As far as loading and unloading HDD causing random issues, can you explain why I do not experience this problem quite literally EVER in my work environment. In work, we have a domain so all user accounts are the same from one machine to the next as its controlled by AD. So permissions don't cause any issue, this is why I think it may be related to permissions although not sure how to stop it happening.
    I also reimage a hell of a lot more machines in work than I do at home using this exact same process. Yet in work, it NEVER happens.

    I am checkdisking the drive as we speak. But either way, this shouldn't be necessary. Its been chkdsking for about an hour so far and stuck on 10%. There is an underlying problem here I think and I can't see its just through mounting a drive into a different system.

    Another thing I'm wondering, why does this never happen with USB drives, if there is no build on the drive, it doesn't seem to be a problem. Again, leaning me to permission settings.

    I suppose I could possibly workaround it by reparitioning and creating a backup drive the size of the users backup so that its free of permissions and then cut and paste it into the build, then remove the partition. Farty way though really, I just wanna copy and paste lol
      My ComputerSystem Spec

  6. badrobot's Avatar
    Posts : 5,135
    Win 10 Pro x64
       19 May 2016 #6

    Improper PC shutdown alone can cause hard drive issues. The more chances it can occur when you pullout a hard drive out of the PC, hot-swapped or not. When you pull out the hard drive, is the power on the PC completely shut?

    It also happens to USB drive. Happened to me in the past.

    One other possible reason is a bad or failing hard drive.
      My ComputerSystem Spec

  7.    19 May 2016 #7

    I eject every drive properly. I do not shut down, there is no need, that is the point of hot swap technology.
    Again...Does not happen in work, same process exactly using hot swap.

    Bad or failing drive is a possible but again as I mentioned, I have replaced a drive in the past for this reason deeming it bad even though all other signs did not point to a bad drive. And it happened exactly the same on the brand new drive.

    The current drive came to me after a failed windows update completely borked the file system. I had to use runtime getdataback to pull the data from the drive. I've ran a diagnostic which tested fine and the smart info shows nothing wrong at all. Plus it built fine and has performed what I would consider normal ever since apart from this issue. It boots quickly aswell for a non ssd.
    I've also ran a disk mark bench on it which showed me pretty normal speeds for a 2.5" conventional drive.

    I'm not trying to be just calling no on all your suggestions, its just, I've already considered and tried them. And I consider hot swap to work properly as I use it all the time in work. I re-image probably 10-20 machines per week using this method. I also use the exact same methods in work as I do at home for detecting a bad drive. A good read and digest of the smart info, a general feel for the machine and keeping watch on perf manager, good diag tools for running short and long dst. But most of the time, if a drive is going to fail a diag, it will show something in smart. A bad sector or two, something.
      My ComputerSystem Spec

  8.    19 May 2016 #8

    Doesn't some external drives have problems copying large files using Sata 3 and win 8 and higher? I seem to remember seeing something about that.
      My ComputerSystem Spec

  9. badrobot's Avatar
    Posts : 5,135
    Win 10 Pro x64
       19 May 2016 #9

    I don't personally believe that the hot-swap technology protects your hard drive 100%. I have it enabled on my motherboard and I also have a hot-swap hardware. The sudden loss of power while the drive is still spinning can cause possible problems. As I mentioned, even improper shutdown can cause this issue.
    As to why it doesn't happen at work. I have no idea. Maybe you can try that same hard drive at work and see if the files will show up.
    Last edited by badrobot; 19 May 2016 at 11:34.
      My ComputerSystem Spec

  10.    19 May 2016 #10

    OK. I have my final answer.

    It was due to overclocking. I'd suspected that before, as its an issue that I've described to other techs and they've not seen it before. They don't overclock.

    I copied it four times when OC'd and it failed each and every time in the ways I mentioned.
    I just removed my OC, bearing in mind, it was only OC'd by 2Mhz on the Base clock. Followed the exact same process, using hotswap again as before.
    This time, all files are in place on the laptop, no problem, all 30,000 files :)

    Alls well that ends well, hopefully this info will help out some lowly overclocking tech in the future. Although it does make me wonder, is overclocking really safe then? I've always done it, never noticed any problems at all apart from this. But could this potentially be messing with my own drives. Hmmm, oh well, problem solved anyway, for now
      My ComputerSystem Spec

Page 1 of 3 123 LastLast

Related Threads
After upgrading my laptop to Win 10 I found File History and activated it. Seemed to be working fine until 8/15 when the backups stopped. Tried to get it to backup further but, no way so after trouble shooting without success I deleted the back up...
Win7 Backup Data Management in Backup and Restore
I continue to use the Win 7 User Data Backups even after I upgraded from Win7 to Win10. I do not use the File History Backups offered with Win 10. My question regards the datasets saved by the Win7 Backup procedure. I notice my backups include...
Solved Restore Windows From Data Backup? in Installation and Upgrade
So I managed to break my partition table, but I was able to recover my entire C: drive and copy every file and folder to an external drive. My question now becomes, is there anyway to, when I reinstall Windows, to restore from that backup (since...
When I was on Win 7, I used Norton Security Suite that included backup tools that I used to backup all my data. I'm now on Win 10 and have decided to use the MS security tools instead of Norton (not sure if this is a good idea or not so feel free...
I would like to backup Metro/Modern Apps, is this possible? Once backed up, how do you restore them? Also, what about Metro/Modern App Data? Thanks.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:18.
Find Us