Windows 10: Restore Points Intel Technology Access Solved

  1.    14 Apr 2016 #1

    Restore Points Intel Technology Access


    When I look at existing restore points in my system, there are always lots of points labelled "Intel(R) Technology Access"
    Many have been created at very short time intervals, sometimes just a few seconds apart.
    Does anybody know why they are created and what is instigating their creation?
      My ComputerSystem Spec

  2.    14 Apr 2016 #2

    Seems to be an issue with Intel Technology Access itself. See this Intel Communities post entitled, prosaically enough "Problems with the Intel Technology Access." Removing the utility seems to do the trick.
    HTH,
    --Ed--
      My ComputersSystem Spec

  3.    14 Apr 2016 #3

    Many thanks for the link.
    It would appear that if I don't have a touch screen (which I don't) then I could remove ITA without issue. I'll try that and report back.
      My ComputerSystem Spec

  4.    24 Apr 2016 #4

    Seems to me you might be able to mark this thread solved, IMHO anyway.
    Thanks!
    --Ed--
      My ComputersSystem Spec

  5.    24 Apr 2016 #5

    Solved


    Apologies for my delayed response - been away from home a while.
    I didn't uninstall the software, but disabled it. That seems to have removed the problem as no more restore points appear to have been created since my last manually created one.
    Thanks for your help.
      My ComputerSystem Spec


 

Related Threads
Wonder what all this Intel software is about Is it coming down from the latest 10 build in updates? I now have 4 Intel programs on my machine: Ethernet Adapter and Intel MEI Plus the 2 in the OP Is Intel and Microsoft teaming up to deliver...
What the hell is W10 doing? Yesterday I still had several restore points. Today, I have only one, which is a new one called Scheduled Checkpoint. My own restore points were removed and the Disk Space Usage was diminished. In the meantime, no...
First off, Does RST work with Windows 10? I can install it and open it, I just don't see the Accelerate option Asus G750JW, HM87 Chipset 1TB HDD boot drive installed a 60GB SSD that I want to use Intel's RST for SSD caching I've tried...
For PCH5/6/7/8 Intel Rapid Storage Technology Version 12.9.4.1000 WHQL http://www.station-drivers.com/index.php?option=com_remository&Itemid=352&func=startdown&id=687&lang=en
Restore points in W10 in Backup and Restore
I like to have some kind of safety net - a reinstall is always possible but dull. Restore points are one option but I like to have several options since we know that restore points are very volatile. For the purpose I tried AOMEI OneKey which...

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:22.
Find Us