Backing up a crashed system from the recovery console (or what10 calls


  1. Posts : 1
    98SE,XP,7,10
       #1

    Backing up a crashed system from the recovery console (or what10 calls


    I have a system that refuses to boot to Windows 10 Professional (64-bit), and I think I need to do a reinstall.
    The advanced boot options is available, but it will not go into safe mode. I can however get the command line, and it recognizes both robocopy and xcopy.
    Assume that C is the hard drive, and D is an external portable USB backup drive.
    Anyways, from the command prompt I typed

    robocopy c:\users d:\ /e /copyall /z /DCopyAT /R:3 /W:5

    big mistake. I got stuck in some loop in c:\all users\applicationdata

    where it kept making nested appdata folders and kept copying something from the public folder.

    I attempted to delete the resulting d:\users with rd /s but got errors about the directory not empty.

    I did a dir and thought I had a lot of free space due to misreading the number of commas as I wasn't fully awake yet, and tried to just go for my own user folder.

    I tried xcopy since I was having trouble with robocopy

    xcopy c:\users\slick d:\users\slick /e /c /f /g /k /y /z

    This ran out of disk space, and I found I only had about 180gb on a 2tb drive and I had a lot more junk in my user folder.

    exploring with the command prompt didn't show me any files. So I took the drive over to my working Windows 7 Professional computer (It's over 10 years old, and I tried win10 during the free upgrade, but it didn't perform well so I went back to 7. The computer came with Vista Home Premium; so please don't tell me to downgrade it to Windows 10. It's too old. Win7 was an upgrade, Win10 was a downgrade). I attempted to delete the resulting c;\users folder, but I cannot take ownership of parts of it, I cannot use the security tab to grant myself or the administrators group full control, and I cannot delete the damn folder that apparently is taking up over 1.5tb of data but getting properties won't acknowledge it.

    Yes, I got the prompt about getting access, but it didn't work and told me to use the security tab. I also tired takeown.exe which didn't seem to work either.

    ImageImageImage

    I get no error when trying to delete the users folder with Explorer when logged in as an admin, it just doesn't work.

    The command prompt however gives this;

    H:\>rd /s users

    users, Are you sure (Y/N)? y

    users\ALLUSE~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\AP

    PLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1 - The dire

    ctory is not empty.

    users\slick\AppData\Local\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\

    APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1 - The di

    rectory is not empty.

    H:\>rd /s "\\?\h:\users"

    \\?\h:\users, Are you sure (Y/N)? y

    \\?\h:\users\ALLUSE~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPL

    IC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1 - T

    he directory is not empty.

    \\?\h:\users\slick\AppData\Local\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\AP

    PLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1\APPLIC~1 -

    The directory is not empty.

    Chkdsk reports that there are thousands of files, which would be consistent with the stuff I saw it copying from my "phonebackup" folders that I saw when robocopy was going for days. However i can't see the files and I can't get rid of them. I have a huge fanfic library stored on my phone and the phonebackup is a quick and and easy way to restore everything when I reset my phone. Checkdsk also claims there are no errors to fix, yet things are FUBAR with that c:\users.

    I'm about ready to reformat the drive, but I'm not sure if there are drivers or anything I need to keep on a seagate portable hard drive.


    So anyways, a second question is what did I do wrong trying to backup the user directories with the command line? What command/parameters should I have used?

    TL;DR?
    1. 1. Should I reformat the backup drive to fix the mess my copy attempts made or what should I do to fix it,
    2. 2. What command(s) should I have used (with what parms) to easily back up the public folder, my limited account, the admin account, and the other users's folders from the command line/recovery console?

    Re-posted from the unhelpful Microsoft forums, sorta combining two posts. Feel free to reply there as well.

    https://answers.microsoft.com/en-us/...4-96812a42fa76
    https://answers.microsoft.com/en-us/...f-ebb033df634c

    P.S. the prompt here suggests I should include my version number. The VER command reports
    Microsoft Windows [Version 10.0.19041.1].
      My Computer


  2. Posts : 11,379
    Windows 10 Home x64 Version 21H2 Build 19044.1706
       #2

    The only alternative I can think of [to reformatting the backup drive] is using RoboCopy to trick it into overwriting the top level folders concerned.
    my ditty about using RoboCopy to clear out a rogue file - TenForums

    Then you'll have the space on the backup drive to do this - make a Macrium Reflect boot usb on another computer then boot the crashed system from it to make a complete system image of your crashed system's disks.

    Macrium Reflect [free edition] is often recommended in this forum for making system images. Other utilities are available but this one is so commonplace that you can get plenty of help for it.

    Backup and Restore with Macrium Reflect - TenForumsTutorials
    Macrium Software Macrium Reflect Free
    Macrium USB - TenForums
    Macrium Reflect KnowledgeBase - user guide [version-independent link]

    It can also make bootable system images. This facility is called viBoot and it requires Win10 Pro.
    Macrium viBoot - Macrium KB
    Macrium viBoot - Create Virtual Machine using Macrium Image - TenForumsTutorials

    Denis
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:53.
Find Us




Windows 10 Forums