System Restore doesn't work (0x8007045b)


  1. Posts : 1
    Windows 10 64-Bit
       #1

    System Restore doesn't work (0x8007045b)


    Hello Tenforums-Community,

    I've recently started getting an issue with my Windows-10 Restore tool. It just fails with the description (translated) "The Original Copy of the Directory could not be extracted from the Restoration point. Source: %ProgramFiles%\WindowsApps Destination: AppxStaging". Now, I have found some things about this error, but I could not find a fix.
    Please note! AppxStaging is not the source in my error!
    I have already attempted a lot of fixes and read through a lot of posts. My Windows Version is 20H2, this issue first started appearing in 1909.
    • I have completely reinstalled Windows (twice)
    • I have tried running "sfc /scannow" and "chkdsk /F /R c:", it doesn't return any errors
    • I have uninstalled the office hub
    • I tried using the Windows Recovery envoirement
    • I tried using it in Safe Mode
    • I tried all resolving tips in the Microsoft support Article
    • I have tried to find a solution in these tenforums threads: 1, 2

    Screenshot:
    System Restore doesn't work (0x8007045b)-a2ec3fb0-490a-4140-a1a7-11d25bf868e5.png
    More Screenshots are availible in my german Microsoft-Answers thread: here.
      My Computer

  2. dalchina's Avatar
    Posts : 34,309
    Win 10 Pro (1903) (2nd PC is 21H2)
       #2

    When I encountered something like this (not the same error number, but appxstaging related) back in 2016, I eventually found it started working again a few months later. No idea why, though as I certainly didn't bother wasting time by continually testing it. 11 page thread or so:
    System Restore fails: AppxStaging %ProgramFiles%\WindowsApp 0x80070091

    SR is simply regarded by many here as not to be depended on; great when it works though- I have a SR point set on schedule every day to complement disk imaging.
      My Computers

  3. Ghot's Avatar
    Posts : 16,054
    Win 10 Home 10.0.19044.1469 (x64) [21H2]
       #3

    @EktoHunter

    I never use System restore, I only use backup software.

    However, someone just linked this site for me, for a different problem, that I've been trying to solve for 3 months.
    In my case the site offered 10 options for solving my problem. Number 9 worked like a charm.

    So... I will do you the same favor...
    Fix: System Restore Failure with Error 0x81000203 - Appuals.com

    I would GUESS, that Method 4 would be what you are looking for.
    Ofc, if that doesn't work, check the other methods.
      My Computer

  4. Bastet's Avatar
    Posts : 2,099
    Windows 11 Pro 64bit
       #4

    Try system restore in safe mode. Worth a try.

    I prefer imaging software these days.
      My Computer

  5. zebal's Avatar
    Posts : 986
    Windows 10 Pro x64 21H2 (Build: 19044.1415)
       #5

    0x8007045b
    A system shutdown is in progress
    EktoHunter said:
    "The Original Copy of the Directory could not be extracted from the Restoration point. Source: %ProgramFiles%\WindowsApps
    Very likely because store apps have not be set, the first time you install OS it will take some time until store apps are set.
    IMO only, until apps are set they can't be restored because configuration does not exists, and Windows "thinks" it needs to restart.

    If you're trying to restore to initial state of system it would be better to do system reset instead of restore.
    Otherwise try to create restore point manually and see if it works.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 22:50.
Find Us




Windows 10 Forums