All of a sudden I could not boot up my MSI Titan GT80 SLI.

The event that happened right before that, I installed RAM, an 8GB DIMM. I powered off the box, inserted the DIMM, powered it back on and it bootlooped. Hit the BCD entry, tried to hit the disk via the BIOS and never booted.

I have the dual boot setup, clone primary win10 onto clone win10 disk. Both SSD. I've used that scheme for years with success. So I tried to boot off the clone disk, also to no avail. Apparently I didn't create the bcdboot entry for it. So that was just a minor oversight.

I booted off flash drive that had the the Windows rescue disk off this forum and looked around. Primary disk looked like it was cleaned out somehow, said 800GB free. Weird. I tried to access C: via Explorer and it said "Do you want to format it?". The filesystem was just gone. I never did anything to it, the only other thing I did before the crash was run Macrium Reflect to clone the primary disk. I then ran EasyBCD to create a boot entry for the clone disk and something went wrong somewhere. It did work for a while, had its filesystem right until the time I started messing with the RAM. RAM install was apparently the pivotal event, or just a coincidence. However the filesystem on the primary disk *was* there before I ran the shutdown command and was *not* there after I installed RAM and tried to boot the machine.

Anyway I removed the cleaned-out primary SSD, installed the clone SSD and booted off Windows rescue flash off this forum and was relieved to see that the clone disk was OK just its BCD stuff was missing. I ran bcdboot, fixed it and booted off the clone disk.

Then I installed the primary disk and ran Macrium Reflect to clone from the good clone disk to the bad (formerly) primary disk and then either disk became bootable again.

The question that I still have is what caused the serious filesystem corruption on the primary disk? I ran the Win recovery boot program and ran its partition manager tool and it didn't see any partitions at all on the primary disk. As if someone wiped it out with diskpart. I know I didn't ran that. Or anything like that.

so the question:

could me installing the 8GB DIMM have caused a power surge - the laptop was down but the machine was plugged to the power outlet. My SATA III drives, one containing Linux and the other SATA that was just a data disk was not affected. So the power surge theory seems unlikely. Especially in light of the fact the mirror disk was not touched, just the primary PCIe disk. I have 4 disks in the machine, 3 of them were not affected.

I know this question is impossible to answer especially after I overwrote everything on it with the info from the clone.