Issue with USB 3 & Win RE

  1.    #1

    Issue with USB 3 & Win RE


    I recently attempted to restore my W10 system image to a new SSD via a Macrium-created Win RE USB recovery medium. The image was created, verified and saved to an external HDD in a USB 3 compatible drive dock (both HDD & USB stick connected via USB 3 ports).

    Several attempts to verify the image in the recovery environment resulted in the following error message:
    Verify: Verification failure. Read error - no such file or directory.

    I shut down, detached the new SSD, reattached the original SSD (OS disk), restarted and successfully verified the image in the W10/Reflect environment.

    Again shut down, recreated the 'recovery' scenario, and again failed to verify. I also attempted to restore the image without first verifying, and failed with the following error:
    Error 105. The system cannot find the file specified.

    Eventually, I succeeded in verifying & restoring the image by performing the operation with the external HDD/dock connected via a USB 2 port (c. 20 minutes for c. 50GB data).

    The usual explanation offered for this issue relates to 'flaky' USB 3 ports/controllers/drivers etc. However, all my images are created and verified using the above external USB 3/HDD setup, and I recently successfully verified and restored a data disk image to a new internal HDD via the Macrium/Win RE boot menu option.

    I also successfully used the viboot feature to test a system recovery image stored on the external HDD via a USB 3 port.

    Is it possible that read/write speeds are the issue in that particular recovery environment?
    Or USB 3 'flakiness' when both RE & external disk are simultaneously connected to USB 3 ports?
    Maybe something obvious, like a Brexit-related issue?
      My ComputerSystem Spec

  2. Caledon Ken's Avatar
    Posts : 14,634
    Windows 10 Pro x64 Build 1809
       #2

    While I can't comment on cause I too had a similar situation around Christmas with Macrium.

    I was backing up a Lenovo (HDD) to an HDD in a Nexstar Vantec dock. Connected with USB3.0. Could not verify. Switch cabled. Same. Plugged it in USB2.0 port and success. Just assumed it is my dock, it is older.
      My ComputerSystem Spec

  3.    #3

    Sounds like the USB 3.0 controller needs a Windows driver. When you are using it from a full Windows environment, the driver is loaded. In a WinPE environment, the driver is missing, unless you specifically add the driver to the WinPE environment.
      My ComputerSystem Spec

  4.    #4

    NavyLCDR said: View Post
    Sounds like the USB 3.0 controller needs a Windows driver. When you are using it from a full Windows environment, the driver is loaded. In a WinPE environment, the driver is missing, unless you specifically add the driver to the WinPE environment.
    The rescue medium was created in MR 7.2 on Windows 10 Pro, and used native WinRE rather than the downloaded WinPE files. The mounted iso indicates the presence of Intel USB 3.0 drivers for controller & hub, matching the Intel board's chipset.

    I believe the same setup is used for the Macrium boot menu recovery environment, and that has verified & restored images using a USB 3.0 connection.

    Is the Intel driver set the issue? Does the recovery environment require a generic Microsoft set of USB 3.0 of drivers?
    @Caledon Ken
    I'm not sure it's the same issue here, as USB 3.0 has only been a problem for me when doing stuff in the recovery environment's 'lightweight' platform. However, considering 3.0 has been around for a decade, it's surprising (or maybe not) that support for it is still problematic even on more recent hardware/systems.
      My ComputerSystem Spec

  5. jimbo45's Avatar
    Posts : 7,257
    Windows / Linux : Centos, Ubuntu, OpenSuse
       #5

    Hi there
    I had similar when plugged into native USB3 port - then tried a powered USB 3 Hub (Anker). Swapped for a Sabrent USB 3 Hub (Unpowered !!!) and it worked fine -- the machine was an HP envy laptop -- INTEL CPU and graphics. Backup image on an SSD (connected to the USB3 Hub via SATA-->USB3 connector --I've never had any problem with that type of connection for backing up / restoring to SSD's.

    Obviously here there's something not quite "kosher" with the USB 3 drivers -- hopefully this will get sorted out quickly as USB 3.2 is here already. Another set of drivers will be needed if you have the hardware.

    Cheers
    jimbo
      My ComputerSystem Spec


 

Related Threads
Hi, I manually upgraded to the new 1703 release of Windows 10, and this OS is very stable. I burned the ISO and did an in-place upgrade from Version 1607 on 3 PCs, and got this weird issue. All of them have NVIDIA graphics cards, and...
Solved Update issue.. UEFI firmware issue in Installation and Upgrade
14703 Any suggestions??
Hello! I bought a Windows 10 Asus laptop about a month back and have been running into a few issues. I actually have tried asking the Microsoft tech forums directly but with a lack of responses I feel I need to ask elsewhere. There are two...
Hello! I upgraded to Windows 10 today. I have two issues. 1. I play a game called "Starcraft II" and I have a problem with the game minimizing and maximizing sometimes very slowly, every 5th attempt or so. During this time it takes up to 40...
After installing Windows 10 the wired Ethernet adapter is missing from the device manager. I found similar threads in the forum but most of the answers concern downloading of drivers for the adapter. My question is how do I download the adapter. One...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 01:53.
Find Us