Invalid Signature Detected

  1.    #1

    Invalid Signature Detected


    Hello everyone
    I have an ASUS Notebook, but I’m not sure if which version of Windows I have (7-10?). This morning my laptop automatically updated and after that a message saying “Invalid Signature Detected. Check boot policy in setup.” appeared. We looked it up online and tried to disable Secure Boot Control. It didn’t help & now all I see is Asus, In Search Of The Incredible. What can I do to fix this? There is an important file on my laptop I need as soon as possible.
    Thank you for your help
      My ComputerSystem Spec

  2.    #2

    What model is the ASUS Notebook? Windows 7-10 is a bit vague.

    What model is your laptop that you want to connect to and how do you connect it to your Notebook? Same network?
    Last edited by lx07; 17 Mar 2019 at 11:33.
      My ComputerSystem Spec

  3.    #3

    I have the Flipbook TP501U and I don’t know which version of Windows I have. I don’t know how I can see that since my computer crashed...

    I haven’t connected a laptop to mine. Do I have to?

    I followed the instructions on this video: secure boot violation invalid signature detected check secure boot policy in setup - YouTube but like a couple of people said it sits on the loading screen forever afterwards.

    My file is on the Flipbook.
      My ComputerSystem Spec

  4.    #4

    Please Ignore my previous question about laptop - I was misunderstanding.

    Just to be clear (following the video). You disabled secure boot on the ASUS, yes?

    This should resolve the signature issue. You should definitely leave this disabled.

    Did you change fast boot or csm settings (around 47s in the video)? I can imagine enabling csm could cause an issue. You could try to leave csm and fastboot disabled then hard shutdown (hold power until it turns off). Then restart. Some comments on the video say this works.

    If it doesn't work you can take a picture of the BIOS settings (perhaps with your phone or a camera or something) and upload them.
      My ComputerSystem Spec

  5.    #5

    I did.
    And I’ve tried everything: CSM disabled, CSM enabled, Fast Boot disabled... nothing works

    Do I have to take a picture of the “Main” screen?
      My ComputerSystem Spec

  6.    #6

    What is giving the signature error the BIOS or windows as windows writes a signature to the hd
      My ComputerSystem Spec

  7.    #7

    Samuria said: View Post
    What is giving the signature error the BIOS or windows as windows writes a signature to the hd
    Microsoft's public keys are held in the firmware (this is a condition of being Windows certified device since Windows 8).

    With secure boot enabled these are compared against the efi binaries (EFI/Microsoft/Boot/bootmgfw.efi or whatever) which are signed with Microsoft's private key.
      My ComputerSystem Spec


 

Related Threads
Hi all, This is my first build and I am so close yet it feels so far away. I'm at the final step of installing Windows 10 onto my PC I have a bootable USB drive connected and everything goes smoothly until I have to select a hard drive! I have...
My laptop has suddenly started running CHKDSK during startup. After it completes and finishes booting I go to Properties > Tools > Error Checking of my C drive and click “Check”. It says errors were found on this drive and to repair drive now to...
Since yesterday every new program I try to download I get a message similar to the above ?????????? This is for CCleaner Any ideas Thanks
Hi, everything was working fine until today. Now, every download I attempt on Microsoft Edge comes up with the message "the signature of this program is corrupt or invalid". I haven't made any changes to my PC, or installed any new software, and I...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:36.
Find Us