Windows 10: Powershell problem since 12/11 upgrade to 1709 Solved

  1.    15 Dec 2017 #1

    Powershell problem since 12/11 upgrade to 1709


    I don't know if I described my problem correctly so I'll explain.

    I created a one-click shortcut for creating a restore point by using this:
    powershell.exe -NoExit -Command “& {Checkpoint-Computer -description “MyRestorePoint” -restorepointtype “Modify_Settings”}

    It worked beautifully and I found it to be one of the most helpful shortcuts I've ever used. After the upgrade to 1709, it will no longer work. I've thrown it away and tried to recreate it several times but it does not work.

    Can anyone help me fix this?

    I found this command and thought it was working.
    [COLOR=rgba(0, 0, 0, 0.85)]cmd.exe /k "wmic.exe /Namespace:\\root\default Path SystemRestore Call CreateRestorePoint "My Shortcut Restore Point", 100, 7"[/COLOR]

    This is what shows in the command window after I click on the shortcut, but when I go to my Restore Points it was not entered there:
    Executing (SystemRestore)->CreateRestorePoint()
    Method execution successful.
    Out Parameters:
    instance of __PARAMETERS
    {
    ReturnValue = 0;
    };
    Last edited by Nikilet; 15 Dec 2017 at 07:32. Reason: new problem
      My ComputersSystem Spec


  2. Posts : 27,174
    64-bit Windows 10 Pro build 17604
       15 Dec 2017 #2

    Hello Nikilet,

    If you haven't already, be sure to change the SystemRestorePointCreationFrequency DWORD value to 0 in Registry Editor from the tutorial below to have system restore never skip creating a new restore point.

    Change System Restore Point Creation Frequency in Windows 10 Performance Maintenance Tutorials

    Afterwards, see if your PowerShell script will work for you now.
      My ComputersSystem Spec

  3.    15 Dec 2017 #3

    I followed those instructions but it didn't work.

    Using the command that starts with cmd.exe, I now get this message
    Invalid format.Hint: <paramlist> = <param> [, <paramlist>].

    Using the Powershell command I get
    The string is missing the terminator: ". + CategoryInfo : ParserError: ( [], ParentContainsErrorRecordEx ception + FullyQualifiedErrorId : TerminatorExpectedAtEndOfString
      My ComputersSystem Spec


  4. Posts : 27,174
    64-bit Windows 10 Pro build 17604
       15 Dec 2017 #4

    Test using Option 2 below to see how that may work for you.

    Create System Restore Point in Windows 10 Performance Maintenance Tutorials
      My ComputersSystem Spec

  5.    15 Dec 2017 #5

    What parameter command should I use?
      My ComputersSystem Spec


  6. Posts : 27,174
    64-bit Windows 10 Pro build 17604
       15 Dec 2017 #6

    You could use any one you like, but I like using "MODIFY_SETTINGS".
      My ComputersSystem Spec

  7.    15 Dec 2017 #7

    Yes, that worked. Apparently you can't create an actual shortcut but have to open the elevated command each time and paste in that command. But it does work.

    You've been so helpful and now I need some help with, I think, Windows Permissions. Can you help me with this?
      My ComputersSystem Spec


  8. Posts : 27,174
    64-bit Windows 10 Pro build 17604
       15 Dec 2017 #8

    You could create a shortcut, but you'll need to remember to right click on the shortcut and "Run as administrator".

    If you like, here are some options below that you may find useful for creating a restore point.

    Add Create Restore Point Context Menu in Windows 10 Customization Tutorials

    Create System Restore Point shortcut in Windows 10 Customization Tutorials

    Sure, go ahead and create a new thread for your permissions issues. I'll be happy to take a look at it to see if I may be able to hlpe.
      My ComputersSystem Spec

  9.    15 Dec 2017 #9

    BTW, I added that command to my right-click menu and it worked great!
      My ComputersSystem Spec


  10. Posts : 27,174
    64-bit Windows 10 Pro build 17604
       15 Dec 2017 #10

    Great news.
      My ComputersSystem Spec


 

Related Threads
I eventually got my detachable laptop to upgrade to Fall Creator, and was very pleased, then noticed that when I received notifications there was no sound, checked all the usual suspects, volume, system sounds, drivers, etc even plugged a headset...
Installation & Upgrade Update and Upgrade Windows 10 using PowerShell in Tutorials
Since its birth in November 2006 PowerShell has evolved to be the chosen tool of network administrators and advanced users alike. Originally a native Windows tool it has since August 2016 been an open source project, spreading its wings to other...
Hope I'm in the right place! I am trying to get a Powershell script to run daily in the task scheduler. It basically purges a folder on one of my drives: Get-ChildItem –Path “D:\Dropbox\Quicken\Backup” –Recurse | Where-Object CreationTime...
Read more: Microsoft fixes PowerShell problem caused by Windows 10 Anniversary update | ZDNet See also: Cumulative Update KB3176938 Windows 10 build 14393.105 - Windows 10 Forums
After I updated to Windows 10 I get multiple "Powershell has stopped working" errors. How do I get rid of this error. Things I have tried: Downloaded Malwarebytes and ran scan - did not fix issue. Downloaded RegCurePro and ran scan - did not...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 03:14.
Find Us