Windows 10: WMI report inconsistent Solved


  1. Posts : 13
    Windows 10 (1511)
       16 Sep 2017 #1

    WMI report inconsistent


    [running Windows 10 Creators]

    Hi,

    While investigating the "Error while updating ESET NOD32 Antivirus status to SECURITY_PRODUCT_STATE_ON." problem, I discovered something rather strange...

    If I go to Security and Maintenance, the system reports that ESET NOD32 is turned on. However, if I use WMIC to list the installed security products this way :

    wmic /namespace:\\root\SecurityCenter2 path AntiVirusProduct get * /value

    the result is : No Instance(s) available.

    This is inconsistent. Or Windows doesn't use WMI in the Security Center to retrieve the installed antivirus apps. Did I miss something ?
      My ComputerSystem Spec

  2.    16 Sep 2017 #2

    I don't know how this relates to your situation but I doubt the Security Center uses WMI. WMI is primarily designed for obtaining information on remote computers and for use by scripting languages such as those running under cmd.exe or powershell. Applications and Windows components generally use more efficient methods. I doubt the actual method used is publicly documented. The information may be coming from a different source than WMI uses.
      My ComputerSystem Spec


  3. Posts : 13
    Windows 10 (1511)
    Thread Starter
       16 Sep 2017 #3

    Thanks Lmiller,

    So I should probably start a specific thread about the error message mentioned above.
      My ComputerSystem Spec

  4.    22 Sep 2017 #4

    When a security suite properly registers with WSC (Windows Security Center) it should have an entry in WMI. Here is the powershell version which should work
    Get-WmiObject -Namespace root\SecurityCenter2 -Query 'select * from AntivirusProduct'
      My ComputerSystem Spec


  5. Posts : 13
    Windows 10 (1511)
    Thread Starter
       23 Sep 2017 #5

    Thanks NeemoBeer,

    The problem is now fixed as mentioned in this thread. The Security Center log on was not set to System. Now WMI has the expected entries.
      My ComputerSystem Spec


 

Related Threads
Crazy Report / Wrong Report in Performance & Maintenance
well i finish format my PC i install drivers and programs and when i check command perform /report this appear143150143151 is imposibility beacuse before format this error / warning dont appear , and also i have literaly a monster PC i7...
chkdsk report cut off mid-way? in Performance & Maintenance
I'm having disc problems and I ran a chhdsk report. The report listed up to "Record 68 of 238: Corrupt File" and then the report cut off half-way through. So I can't see the rest of the 238 files that were affected. It says it repaired the files but...
I just wanted to know if MS removed the system health report feature from performance monitor. If so how do you start a system health report in Windows 10, it seems to differ from Windows 7 where you can find in advanced tools "Generate a system...
SFC Error Report in Performance & Maintenance
I just ran SFC /scannow and got his error message Windows Resource Protection found corrupt files but was unable to fix some of them. Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example C:\Windows\Logs\CBS\CBS.log. Note...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 21:04.
Find Us