Page 2 of 2 FirstFirst 12
  1.    08 Sep 2017 #11
    Join Date : Jul 2015
    Posts : 3,694
    10 Pro

    WinRe isn't really required (you can always boot from installation media). If you want to make a partition containing it look at this:

    Deploy Windows RE

    Basically you need to put it somewhere and then use the reagentc command to register it. reagent /info will tell you if you have a registered recovery partition (and which one) like this:

    Code:
    PS C:\Windows\system32> reagentc /info
    Windows Recovery Environment (Windows RE) and system reset configuration
    Information:
    
        Windows RE status:         Enabled
        Windows RE location:       \\?\GLOBALROOT\device\harddisk0\partition1\Recovery\WindowsRE
        Boot Configuration Data (BCD) identifier: 3be03281-176e-11e7-b4ff-c30418e09fae
        Recovery image location:
        Recovery image index:      0
        Custom image location:
        Custom image index:        0
    
    REAGENTC.EXE: Operation Successful.
    
    PS C:\Windows\system32>
    If it doesn't say "enabled" you should be able to figure it out from the link above but do say if you aren't sure.

    Your disk layout is odd (normally the system volume is before C) but actually partition order doesn't matter. I'd leave it
      My ComputerSystem Spec
  2.    08 Sep 2017 #12
    Join Date : Aug 2015
    Posts : 18
    Windows 10 Pro
    Thread Starter

    @lx07, thanks for your continued assistance. With the help of instructions on another site, before you responded I think I got it to the point you show:


    Click image for larger version. 

Name:	WinRE.jpg 
Views:	15 
Size:	114.3 KB 
ID:	152438


    However, the site I was following then said that if the "Recovery image location" line is blank (as mine is), there are more steps to follow. However, I don't have a lot more time to devote to this, and I came to the conclusion that you state, i.e. that I could just boot from installation media.

    In any event, the real problem I need to solve is that BitLocker is now unable to encrypt C (which originally was able to be encrypted, as in my original screenshot), and is only able to encrypt E (which originally was not being encrypted due to the "system" designation, as you pointed out).

    I don't know if WinRE had/has anything to do with it, but the problem remains. BitLocker checks the drive, and then it says "Please wait while BitLocker initializes the drive", at which point I get the message that the system can't find whatever file it's looking for. I don't know why it's not smart enough to transfer any files it needs from E, which seems like it could be an easy solution, but I'm as unsmart as my computer, and I don't know how to do it.
      My ComputerSystem Spec
  3.    08 Sep 2017 #13
    Join Date : Aug 2015
    Posts : 18
    Windows 10 Pro
    Thread Starter

    I have an even bigger problem now, caused in part by impatience.

    I decided I wanted the C partition to be bigger (and thought I should resize it before dealing anymore with the encryption issue). I decrypted and shrank E, and moved the unallocated space adjacent to C. For some reason, instead of merely resizing C, I formatted this new space to NTFS (as C already was), and then I thought I'd go ahead and merge the two partitions. All of this was done using MiniTool Partition Wizard. All seemed well until the merger.

    Upon completion of the merger, I got a BSOD saying there was an NTFS stop code error. I though maybe EasyRE could deal with this automatically, but it hasn't been able to. It seems to be able to see the C partition, and see that there's an operating system on it, but can't make my computer see it. The version of GParted on EasyRE says that it can't read any data on that partition. It tells me this about it:

    Unable to read the contents of this file system!
    Because of this some operations may be unavailable.
    The cause might be a missing software package.
    The following list of software packages is required for ntfs
    file system support: ntfs-3g / ntfsprogs.


    I don't know what to do with this information. GParted itself returns an error when I try to use it to check the partition with it. I'd love to be able to save the details of the error but the instructions online for how to do this through the console it provides don't match what I see on my computer. (The location of my USB drive doesn't show up [that I can see, and certainly not as the online instructions say] and so I can't mount it.)

    I have all of the data synced onto another machine, but still, I should have taken an image. It will be a pain to reinstall Windows and Office and my various programs etc. if that's what I have to do.
      My ComputerSystem Spec
  4.    09 Sep 2017 #14
    Join Date : Aug 2015
    Posts : 18
    Windows 10 Pro
    Thread Starter

    Here are a couple of things from GParted, when I try to check and repair the partition:

    ------------

    Libparted Warning

    Could not get identity of device /dev/ada0
    - Inappropriate ioctl for device

    -------------

    Under "Checking filesystem consistency" it has seven lines of:

    Inode is corrupt ([some number]): Input/output error

    And under "Accounting clusters " it has many lines of:

    Cluster accouning failed at [some number] (0x[other number]): extra cluster in $Bitmap

    It ends with:

    Filesystem check failed! Totally 529 cluster accounting mismatches.
    ERROR: NTFS is inconsistent. Run chkdisk /f on Windows then reboot it TWICE!
    The usage of the /f parameter is very IMPORTANT! No modification was
    and will be made to NTFS by this software until it gets repaired.

    I tried the chkdsk procedure from installation media but it doesn't find any errors.
      My ComputerSystem Spec
  5.    11 Sep 2017 #15
    Join Date : Aug 2015
    Posts : 18
    Windows 10 Pro
    Thread Starter

    Probably no one's waiting with bated breath, but...

    I plugged the drive with the corrupt partition into my other computer, and ended up using MiniTool Partition Wizard to check and repair it, and though I was skeptical because MTPW had caused the bad partition in the first place, it succeed in making the partition contents visible ... while leaving the drive still without boot capability. Ultimately I used EasyRE again to auto-repair the boot capability.

    Tomorrow I'll revisit the encryption issue.
      My ComputerSystem Spec
  6.    11 Sep 2017 #16
    Join Date : Jul 2015
    Posts : 3,694
    10 Pro

    You still have system in partition 3? I do believe it doesn't matter but it could be the case it needs to be before C. That is only a guess though.

    I suppose try it as it is then if it still doesn't work you could either move partitions with MTPW or reinstall. Moving system from partition from 3 to 1 would take absolutely ages as it has to move all the data on the disk (I swapped order of OSX and Windows and it took many hours)

    Perhaps you could consider making an image backup of C with Macrium or something, destroy partitions 1 and 3 (so they are unallocated space) and clean install. Your data partition you could leave where it is. This would create system in partition 1 and a 149GB C in partition 2. You could then restore back C volume from your backup - it would probably be quicker as you wouldn't have to reinstall everything - just reregister recovery.
      My ComputerSystem Spec
  7.    12 Sep 2017 #17
    Join Date : Aug 2015
    Posts : 18
    Windows 10 Pro
    Thread Starter

    I'll try putting partition 3 before C, but my guess is the same as yours, @lx07, that it shouldn't matter.

    In any event, I think maybe Windows is looking in the wrong place for the file it's missing, or a file that should be in a couple of different places has somehow been removed from where it needs to be to encrypt C. I imagine it's not gone altogether, since E can be encrypted, unless this is a particular file required for the OS partition. I don't know how to investigate such a thing. It would be nice if BitLocker said what it was looking for.

    I chatted with a Microsoft support rep who said I should follow up with my computer's manufacturer because it could be a matter of a missing driver. I don't know how that could be true since E can be encrypted.

    The Microsoft rep suggested that I try scannow and DISM to find and repair corrupt Windows files. I've done that now, and some corrupt files were indeed found and repaired, but it didn't result in C becoming encryptable. I get the same "cannot find the file specified" error.

    I'll try escalating my inquiry with Microsoft if rearranging my partitions doesn't jog something into place, unless any promising other avenues come to light.
      My ComputerSystem Spec
  8.    13 Sep 2017 #18
    Join Date : Aug 2015
    Posts : 18
    Windows 10 Pro
    Thread Starter

    Putting 3 before C hasn't solved the problem.

    @lx07, I'm not sure I understand your last paragraph. Windows is on the C partition. Are you saying I can do a clean Windows install and then copy my C drive back over that install so I don't have to reinstall my programs?
      My ComputerSystem Spec
  9.    13 Sep 2017 #19
    Join Date : Jul 2015
    Posts : 3,694
    10 Pro

    Quote Originally Posted by Aaron View Post
    Are you saying I can do a clean Windows install and then copy my C drive back over that install so I don't have to reinstall my programs?
    Yes exactly. Make an image with Macrium or something first.

    Boot from Windows installation USB (you can make one using the Media Creation Tool ) and delete C and system reserved (so they are both unallocated space) during the installation process. You can leave your big data partition.

    When you install Windows it will create 500MB system first and C in the remaining 149.5GB space. Ignore all the prompts but let it finish.

    Then you can boot from Macrium recovery USB and restore your C volume (that you backed up elsewhere before of course) over the top to the C volume created by the clean install. All your programs will be intact.

    Now whether after this whatever file bitlocker is complaining about is still there I don't know. In theory the bitlocker files should be in the system partition so it might work as you'd be replacing it.

    If that doesn't work it is clean install (and install all your programs again) time. Even then you can leave your data partition though.
      My ComputerSystem Spec

 
Page 2 of 2 FirstFirst 12


Similar Threads
Thread Forum
Is encrypting all my drives with Bitlocker necessary?
Is encrypting each and every one of my drives with BitLocker necessary? I highly doubt my PC will ever be swapped or anything. I wonder how many people even use the feature.
AntiVirus, Firewalls and System Security
BitLocker encrypting Used or Entire space?
I usually been reinstalling Win10 to get rid of the so called "clutter" on my system to make it more fresh and such. Regarding BitLocker, I always select to encrypt the entire drive as opposed to encrypting used spaced only. The entire drive...
AntiVirus, Firewalls and System Security
W10 TPM Bitlocker asks erroneously for pwd on one data partition
With a laptop W10 + TPM enabled with hard drive partitioned with C: = system; d: = users; e: = media; f: = the rest - all partitions BitLocker encrypted, all working beautifully well, I have an odd behaviour: after each W10 full startup, the...
AntiVirus, Firewalls and System Security
Solved ugh i forgot i was encrypting my drive with bitlocker???
So oh hum i forgot i was encrypting my drive today with bitlocker and i updated my realtek audio drivers,and its asking me to reboot, can I reboot when bitlocker is encrypting or should i just wait till its finished and then reboot its been running...
AntiVirus, Firewalls and System Security
Solved Can I shut down my PC while BitLocker is encrypting?
What would happen if my computer shuts down while BitLocker is encrypting my data partition drive? It takes ages! I am running Windows 10 Pro Thank you very much in advance
AntiVirus, Firewalls and System Security
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:54.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums